Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS Development (http://www.linux-archive.org/centos-development/)
-   -   mirrorlist issue (http://www.linux-archive.org/centos-development/296951-mirrorlist-issue.html)

Andreas Rogge 12-17-2009 04:02 PM

mirrorlist issue
 
While upgrading our servers to 5.4 I just noticed that the mirrorlist is
somewhat "broken" (at least for me).

For 4.8 it does work:
http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=4.8

For 5.3 it also works:
http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=5.3

But for 5.4 it doesn't work:
http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=5.4

Is that intended? If so: how do I say "I want 5.4 and all its updats but
I don't want to move to 5.5 right now"

<background-info>
I know that usually one would just ask for "release=5", however - our
rpm-patch-and-upgrade-toolchain relies on the ability to pin the system
to a specific CentOS release until we're sure our boxes can be moved to
the new release. We do that by replacing $releasever in the
CentOS-Base.repo with the exact release we want to stay with.
</background-info>

Regards,
Andreas
--
Solvention
Egermannstr. 6-8
53359 Rheinbach

Tel: +49 2226 158179-0
Fax: +49 2226 158179-9

http://www.solvention.de
mailto:info@solvention.de
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

Ralph Angenendt 12-18-2009 10:47 AM

mirrorlist issue
 
On Thu, Dec 17, 2009 at 6:02 PM, Andreas Rogge <a.rogge@solvention.de> wrote:
> While upgrading our servers to 5.4 I just noticed that the mirrorlist is
> somewhat "broken" (at least for me).
>
> For 4.8 it does work:
> http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=4.8
>
> For 5.3 it also works:
> http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=5.3
>
> But for 5.4 it doesn't work:
> http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=5.4
>
> Is that intended? If so: how do I say "I want 5.4 and all its updats but
> I don't want to move to 5.5 right now"

No, I don't think it is intended. Let me look.

Cheers,

Ralph
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

Ralph Angenendt 12-18-2009 10:54 AM

mirrorlist issue
 
On Fri, Dec 18, 2009 at 12:47 PM, Ralph Angenendt
<ralph.angenendt@gmail.com> wrote:
>> But for 5.4 it doesn't work:
>> http://mirrorlist.centos.org/?repo=updates&arch=x86_64&release=5.4
>>
>> Is that intended? If so: how do I say "I want 5.4 and all its updats but
>> I don't want to move to 5.5 right now"
>
> No, I don't think it is intended. Let me look.

Now it does (you wouldn't believe how many files have a hardcoded
release in them) :)

5.2 doesn't work anymore now, though ...

Cheers and thanks,

Ralph
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel


All times are GMT. The time now is 11:49 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.