FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS Development

 
 
LinkBack Thread Tools
 
Old 02-05-2009, 08:52 PM
Tru Huynh
 
Default Security update missing - kernel-2.6.18-128.el5

On Thu, Feb 05, 2009 at 10:25:14PM +0100, Milan Keršláger wrote:
> Please,
>
> do not delay this "Important" multiple security update. See
> https://rhn.redhat.com/errata/RHSA-2009-0225.html for more info.
>
> This update is "5.3" kernel but has been released as security update
> too. RHN pushed this kernel one day ahead of rest of 5.3 packages (on my
> servers).
>
> RH maintains API and ABI (!) compatibility so there is no problem to use
> this kernel AFAIK.
but this kernel -128 version requires a newer version of ecryptfs-utils from 5.3...

So afaik there will be no newer kernel until 5.3 is released.

Cheers,

Tru
--
Tru Huynh (mirrors, CentOS-3 i386/x86_64 Package Maintenance)
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xBEFA581B
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-06-2009, 03:46 PM
David Hrbáč
 
Default Security update missing - kernel-2.6.18-128.el5

Milan Keršláger napsal(a):
> Please,
>
> do not delay this "Important" multiple security update. See
> https://rhn.redhat.com/errata/RHSA-2009-0225.html for more info.
>
> This update is "5.3" kernel but has been released as security update
> too. RHN pushed this kernel one day ahead of rest of 5.3 packages (on my
> servers).
>
> RH maintains API and ABI (!) compatibility so there is no problem to use
> this kernel AFAIK.
>
> So please, do not delay it anymore, this contains multiple security
> vulnerabilities fixed since 2009-01-20.
>
> Thank you for your effort (a lot).
>
> M.K.
>

Tru's right. It not only depends on ecryptfs-utils but other new
packages. It's right it builds fine, but finally depends on a lot of new
modules. Some:
%define kernel_dot_org_conflicts ppp < 2.4.3-3, isdn4k-utils < 3.2-32,
nfs-utils < 1.0.7-12, e2fsprogs < 1.37-4, util-linux < 2.12, jfsutils <
1.1.7-2, reiserfs-utils < 3.6.19-2, xfsprogs < 2.6.13-4, procps <
3.2.5-6.3, oprofile < 0.9.1-2

%define package_conflicts initscripts < 7.23, udev < 063-6, iptables <
1.3.2-1, ipw2200-firmware < 2.4, selinux-policy-targeted < 1.25.3-14,
ecryptfs-utils < 44, cpuspeed < 1.2.1-5

Milan, you can try yourself testing kernel here:
http://fs12.vsb.cz/hrb33/el5/hrb-kernel/stable/x86_64/repodata/
http://fs12.vsb.cz/hrb33/el5/hrb-kernel/stable/i386/repodata/

I'd like to point out one thing. I do want to thank to Centos developers
they have changed update build process. Even that there is 5.3 rebuild
process ongoing, they are releasing security updates for C{3,4,5} and I
like it. This is a new behavior, because every time they had been
rebuilding new distro version, security updates process got stucked. So,
thank you Pasi and Tru.

Regards,
David

_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-07-2009, 02:54 PM
Charlie Brady
 
Default Security update missing - kernel-2.6.18-128.el5

On Thu, 5 Feb 2009, Tru Huynh wrote:


On Thu, Feb 05, 2009 at 10:25:14PM +0100, Milan Keršláger wrote:

Please,

do not delay this "Important" multiple security update. See
https://rhn.redhat.com/errata/RHSA-2009-0225.html for more info.

..

but this kernel -128 version requires a newer version of ecryptfs-utils from 5.3...

So afaik there will be no newer kernel until 5.3 is released.


Why is it not possible to also release a new ecryptfs-utils?____________________________________________ ___
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-07-2009, 02:56 PM
Charlie Brady
 
Default Security update missing - kernel-2.6.18-128.el5

On Sat, 7 Feb 2009, Charlie Brady wrote:

> Why is it not possible to also release a new ecryptfs-utils?

Cencel that - I see there are multiple dependencies.
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-09-2009, 05:28 PM
Scott Silva
 
Default Security update missing - kernel-2.6.18-128.el5

on 2-7-2009 7:54 AM Charlie Brady spake the following:
>
> On Thu, 5 Feb 2009, Tru Huynh wrote:
>
>> On Thu, Feb 05, 2009 at 10:25:14PM +0100, Milan Keršláger wrote:
>>> Please,
>>>
>>> do not delay this "Important" multiple security update. See
>>> https://rhn.redhat.com/errata/RHSA-2009-0225.html for more info.
> ..
>> but this kernel -128 version requires a newer version of
>> ecryptfs-utils from 5.3...
>>
>> So afaik there will be no newer kernel until 5.3 is released.
>
> Why is it not possible to also release a new ecryptfs-utils?
>
In the time it would take to get all the dependencies resolved and spend some
time in QA, 5.3 will probably be out.

--
MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 

Thread Tools




All times are GMT. The time now is 06:58 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org