FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux User Repository

 
 
LinkBack Thread Tools
 
Old 07-13-2011, 09:56 PM
Anton Leontiev
 
Default Request for PKGBUILD check: perl-pdl 2.4.9-1

Hi, all!

Could you help me with PKGBUILD for Perl's PDL module?

Currently I'm stuck with makedepends/optdepends. There is a number of
dependencies which are optional, but to get PDL work with them as with
optional packages in Arch, it should be compiled with them. So I added
the in both makedepends and optdepends. Am I right?

What are official recommendations for AUR packages in this case?

Thank you in advance.

--
Anton Leontiev <bunder@t-25.ru>
 
Old 07-13-2011, 11:07 PM
Peter Lewis
 
Default Request for PKGBUILD check: perl-pdl 2.4.9-1

Hi,

On Wed, 13 Jul 2011, Anton Leontiev wrote:
> Currently I'm stuck with makedepends/optdepends. There is a number of
> dependencies which are optional, but to get PDL work with them as with
> optional packages in Arch, it should be compiled with them. So I added
> the in both makedepends and optdepends. Am I right?

Yes. If they're optional dependencies to enable extra functionality, but are
required to be present at compile time to enable this, then you should add them
to makedepends as well.

The only purpose of optdepends to my knowledge is to provide the user with a
nice message when they install the package to let them know that the package
will have some extra functionality if some other packages are also installed.

Pete.
 

Thread Tools




All times are GMT. The time now is 02:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org