FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux User Repository

 
 
LinkBack Thread Tools
 
Old 02-25-2009, 10:42 PM
Josť Valecillos
 
Default I can't update or upload packages in AUR

Hello, I have a problem, when i try to upload any package in AUR here:
http://aur.archlinux.org/pkgsubmit.php
uploading ends (after ~1 min) by just a blank page. It's AUR bug? I can't
update my package about 3 days. I can't upload a new package either.

I adopt pcsx-df package, and the sources links in the PKBUILD its broken.
This is my PKBUILD:

# Maintainer: Jose Valecillos <valecillosjg (at) gmail (dot) com>
pkgname=pcsx-df
pkgver=1.818
pkgrel=1
pkgdesc="Debian fork of the abandoned original PCSX"
arch=(i686 x86_64)
url="http://pcsx-df.game-host.org/pcsx-df/"
license=('GPL')
depends=('libglade' 'libgl' 'libxv' 'alsa-lib' 'bzip2')
makedepends=('pkgconfig' 'mesa' 'diffutils')
options=('!libtool')
provides=('pcsx')
source=(http://pcsx-df.game-host.org/pcsx-df/files/pcsx-df-${pkgver}.tar.gz
http://pcsx-df.game-host.org/pcsx-df/files/dfOpenGL-1.1.0.tar.gz)

[ "${CARCH}" == "i686" ] && makedepends="${makedepends[@]} nasm"

build() {
cd ${startdir}/src/pcsx-df-${pkgver}
flags="--enable-alsa"
if [ ! "${CARCH}" == "i686" ]; then
flags="${flags} --disable-nasm"
fi

./configure --prefix=/usr $flags
make || return 1
make DESTDIR="$startdir/pkg" install

cd ../dfOpenGL
make clean
make || return 1
install -m755 libdfOpenGL.so
${startdir}/pkg/usr/lib/games/psemu/libdfOpenGL.so
}

md5sums=('9315b421396a34bfd57be5d25f88dff7'
'36ccf31d0b88f099bf4acd6a16b5b04c')

--
Josť Valecillos
 
Old 02-25-2009, 11:24 PM
Loui Chang
 
Default I can't update or upload packages in AUR

On Thu, Feb 26, 2009 at 07:12:51PM +1930, Josť Valecillos wrote:
> Hello, I have a problem, when i try to upload any package in AUR here:
> http://aur.archlinux.org/pkgsubmit.php
> uploading ends (after ~1 min) by just a blank page. It's AUR bug? I can't
> update my package about 3 days. I can't upload a new package either.

Yep must be a glitch in the parser.
I'd guess that it's probably this line is causing the hang up:
> [ "${CARCH}" == "i686" ] && makedepends="${makedepends[@]} nasm"
 
Old 02-26-2009, 12:45 AM
"stefan-husmann@t-online.de"
 
Default I can't update or upload packages in AUR

-----Original Message-----
> Date: Thu, 26 Feb 2009 01:24:00 +0100
> Subject: Re: [aur-general] I can't update or upload packages in AUR
> From: Loui Chang <louipc.ist@gmail.com>
> To: "Discussion about the Arch User Repository (AUR)"
> <aur-general@archlinux.org>

> On Thu, Feb 26, 2009 at 07:12:51PM +1930, Josť Valecillos wrote:
> > Hello, I have a problem, when i try to upload any package in AUR
> > here: http://aur.archlinux.org/pkgsubmit.php
> > uploading ends (after ~1 min) by just a blank page. It's AUR bug? I
> > can't update my package about 3 days. I can't upload a new package
> > either.
> >
>
> Yep must be a glitch in the parser.
> I'd guess that it's probably this line is causing the hang up:
> > [ "${CARCH}" == "i686" ] && makedepends="${makedepends[@]} nasm"
>
>
>
Hello,

will using tools like aurup or aurploader cause trouble here?

BTW there is at least one other user with that problem, see
http://bbs.archlinux.org/viewtopic.php?id=65378

Regards Stefan
 
Old 02-26-2009, 01:15 AM
Josť Valecillos
 
Default I can't update or upload packages in AUR

I drop these line and works...I don't know exactly what is the function os
this line anyway... It was in the PKGBUILD of the original owner.

Thanks for answer!


--
Josť Valecillos
 
Old 02-26-2009, 06:46 AM
Xavier
 
Default I can't update or upload packages in AUR

On Thu, Feb 26, 2009 at 3:15 AM, Josť Valecillos <valecillosjg@gmail.com> wrote:
> I drop these line and works...I don't know exactly what is the function os
> this line anyway... It was in the PKGBUILD of the original owner.
>
> Thanks for answer!
>

I know nothing about the package, but the intention was obvious :
support the x86_64 architecture by disabling nasm with a configure
flag, thus adding nasm to makedepends only for the i686 architecture.
I see you completely dropped support for x86_64 in your PKGBUILD. I
have no interest for it, but maybe I will check later if it builds.
 
Old 02-26-2009, 03:20 PM
Luk√°Ň° Jirkovsk√Ĺ
 
Default I can't update or upload packages in AUR

I've had this problem with qtcreator but suddenly after several days
of trying to upload it it uploaded.
 
Old 02-26-2009, 03:48 PM
Loui Chang
 
Default I can't update or upload packages in AUR

On Thu, Feb 26, 2009 at 05:20:43PM +0100, Luk√°Ň° Jirkovsk√Ĺ wrote:
> I've had this problem with qtcreator but suddenly after several days
> of trying to upload it it uploaded.

The problem won't be magically fixed after a few days. It was a change
in the parser that solved it.
 
Old 02-26-2009, 04:02 PM
Luk√°Ň° Jirkovsk√Ĺ
 
Default I can't update or upload packages in AUR

2009/2/26 Loui Chang <louipc.ist@gmail.com>:
> On Thu, Feb 26, 2009 at 05:20:43PM +0100, Luk√°Ň° Jirkovsk√Ĺ wrote:
>> I've had this problem with qtcreator but suddenly after several days
>> of trying to upload it it uploaded.
>
> The problem won't be magically fixed after a few days. It was a change
> in the parser that solved it.
>
>

Oh, thanks!
 

Thread Tools




All times are GMT. The time now is 04:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org