FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Pacman Development

 
 
LinkBack Thread Tools
 
Old 03-23-2011, 05:42 PM
Xyne
 
Default "pacman -Rd" still checks deps

Hi,

With pacman 3.5.1 from [testing] I get this:

pacman -Rd mimeo
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: obfilebrowser: requires mimeo>=2011.03.12

(tested with "--nodeps" too, just in case)

I couldn't find anything about this on the bugtracker but I may be looking in
the wrong place. If this is an unknown bug, please tell me where I should report
it, if not here.

Regards,
Xyne
 
Old 03-23-2011, 05:46 PM
Florian Pritz
 
Default "pacman -Rd" still checks deps

On 23.03.2011 19:42, Xyne wrote:
> Hi,
>
> With pacman 3.5.1 from [testing] I get this:
>
> pacman -Rd mimeo
> checking dependencies...
> error: failed to prepare transaction (could not satisfy dependencies)
> :: obfilebrowser: requires mimeo>=2011.03.12
>
> (tested with "--nodeps" too, just in case)
>
> I couldn't find anything about this on the bugtracker but I may be looking in
> the wrong place. If this is an unknown bug, please tell me where I should report
> it, if not here.


The behavior of -d has changed. -d now ignore the version part and -dd
also ignores the package name itself. (See manpage)

--
Florian Pritz -- {flo,bluewind}@server-speed.net
 
Old 03-23-2011, 05:53 PM
Xyne
 
Default "pacman -Rd" still checks deps

Florian Pritz wrote:

> The behavior of -d has changed. -d now ignore the version part and -dd
> also ignores the package name itself. (See manpage)

Ok, thanks.

Btw, is there any convenient way to downgrade to pacman 3.4 from 3.5, i.e. a way to reverse the changes to the local database?
 
Old 03-23-2011, 05:59 PM
Dan McGee
 
Default "pacman -Rd" still checks deps

On Wed, Mar 23, 2011 at 1:53 PM, Xyne <xyne@archlinux.ca> wrote:
> Florian Pritz wrote:
>
>> The behavior of -d has changed. -d now ignore the version part and -dd
>> also ignores the package name itself. (See manpage)
>
> Ok, thanks.
>
> Btw, is there any convenient way to downgrade to pacman 3.4 from 3.5, i.e. a way to reverse the changes to the local database?

No, or at least none that we are going to support. You can hack around
with depends -> desc symlinks but all bets are off at that point...

-Dan
 

Thread Tools




All times are GMT. The time now is 04:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org