FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Pacman Development

 
 
LinkBack Thread Tools
 
Old 03-21-2011, 12:07 PM
Dan McGee
 
Default Really pesky (and wrong!) upgrade sequence

Ignore the poppler thing for the most part, but:
1) the questions were extremely annoying (especially since you don't
know how many you have to answer). Not sure if we can do anything
here. If the package to be installed was constant, I'd say once you
agreed to it, we could assume you agree to it everywhere. Does this
hold if the package to be replaced is constant?
2) I'm definitely not removing 14 packages, nor 4106.77 MB worth
either. This should be easily fixable.

-Dan

$ sudo ./src/pacman/pacman -Syu
Password:
:: Synchronizing package databases...
testing is up to date
core is up to date
extra is up to date
community-testing is up to date
multilib is up to date
community is up to date
:: Starting full system upgrade...
:: Replace openoffice-base with testing/libreoffice-extension-ct2n? [Y/n] y
:: Replace openoffice-base with testing/libreoffice-extension-diagram? [Y/n] y
:: Replace openoffice-base with testing/libreoffice-extension-hunart? [Y/n] y
:: Replace openoffice-base with testing/libreoffice-extension-nlpsolver? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-numbertext? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-oooblogger? [Y/n] y
:: Replace openoffice-base with testing/libreoffice-extension-pdfimport? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-presentation-minimizer? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-presenter-screen? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-report-builder? [Y/n] y
:: Replace openoffice-base with testing/libreoffice-extension-typo? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-watch-window? [Y/n] y
:: Replace openoffice-base with
testing/libreoffice-extension-wiki-publisher? [Y/n]
:: Replace openoffice-base with testing/libreoffice-sdk? [Y/n]
warning: scorched3d: local (43.2-1) is newer than community (43.2a-1)
resolving dependencies...
warning: cannot resolve "poppler-glib>=0.16.3", a dependency of "evince"
:: The following package cannot be upgraded due to unresolvable dependencies:
evince

Do you want to skip the above package for this upgrade? [y/N] y
looking for inter-conflicts...

Remove (14): openoffice-base-3.3.0-1 openoffice-base-3.3.0-1
openoffice-base-3.3.0-1 openoffice-base-3.3.0-1
openoffice-base-3.3.0-1
openoffice-base-3.3.0-1 openoffice-base-3.3.0-1
openoffice-base-3.3.0-1 openoffice-base-3.3.0-1
openoffice-base-3.3.0-1
openoffice-base-3.3.0-1 openoffice-base-3.3.0-1
openoffice-base-3.3.0-1 openoffice-base-3.3.0-1

Total Removed Size: 4106.77 MB

Targets (17): inkscape-0.48.1-2 libreoffice-3.3.2rc2-1
libreoffice-extension-ct2n-3.3.2rc2-1
libreoffice-extension-diagram-3.3.2rc2-1
libreoffice-extension-hunart-3.3.2rc2-1
libreoffice-extension-nlpsolver-3.3.2rc2-1
libreoffice-extension-numbertext-3.3.2rc2-1
libreoffice-extension-oooblogger-3.3.2rc2-1
libreoffice-extension-pdfimport-3.3.2rc2-1
libreoffice-extension-presentation-minimizer-3.3.2rc2-1
libreoffice-extension-presenter-screen-3.3.2rc2-1
libreoffice-extension-report-builder-3.3.2rc2-1
libreoffice-extension-typo-3.3.2rc2-1
libreoffice-extension-watch-window-3.3.2rc2-1
libreoffice-extension-wiki-publisher-3.3.2rc2-1
libreoffice-sdk-3.3.2rc2-1
texlive-bin-2010.1-7

Total Download Size: 116.22 MB
Total Installed Size: 550.59 MB

Proceed with installation? [Y/n] ^C
Interrupt signal received
 
Old 03-21-2011, 12:23 PM
Allan McRae
 
Default Really pesky (and wrong!) upgrade sequence

On 21/03/11 23:07, Dan McGee wrote:

Ignore the poppler thing for the most part, but:
1) the questions were extremely annoying (especially since you don't
know how many you have to answer). Not sure if we can do anything
here. If the package to be installed was constant, I'd say once you
agreed to it, we could assume you agree to it everywhere. Does this
hold if the package to be replaced is constant?


I'd say that the packaging is broken... I believe that only the main
libreoffice package should replace openoffice-base, and not every split
package. And libreoffice-sdk should replace openoffice-base-sdk, etc



2) I'm definitely not removing 14 packages, nor 4106.77 MB worth
either. This should be easily fixable.


That is removing more than I have installed on my system!

Anyway, I suppose there are genuine cases where multiple packages might
replace one package, so this is still something to fix.


Allan
 

Thread Tools




All times are GMT. The time now is 02:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org