FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 03-07-2011, 08:08 PM
Allan McRae
 
Default Plurals

On 08/03/11 07:00, Nagy Gabor wrote:

Yes, this is correct (both sentence).

For testing the non-plural case, pick a sync package which is not
installed on your system (some KDE stuff, for example), and put one of
its (pulled) depends to IgnorePkg. For example, "sudo pacman -S gimp
--ignore libwmf" is good for testing here, and I should see the
non-plural form (but I can see the plural form).

NG


Wait, I should have tested with LANG=C first. :-) That is also wrong, so
probably there is a bug in the source code...



Just because this took me a whileto figure out what was going on, here
is some actual output...



> pacman -S gimp --ignore libwmf
resolving dependencies...
warning: ignoring package libwmf-0.2.8.4-8
warning: cannot resolve "libwmf", a dependency of "gimp"
:: The following packages cannot be upgraded due to unresolvable
dependencies:

gimp

Do you want to skip the above packages for this upgrade? [y/N] y
looking for inter-conflicts...
there is nothing to do


Note "packages" in two messages there.

Allan
 
Old 03-07-2011, 08:26 PM
Nagy Gabor
 
Default Plurals

> On 08/03/11 07:00, Nagy Gabor wrote:
> >> Yes, this is correct (both sentence).
> >>
> >> For testing the non-plural case, pick a sync package which is not
> >> installed on your system (some KDE stuff, for example), and put one of
> >> its (pulled) depends to IgnorePkg. For example, "sudo pacman -S gimp
> >> --ignore libwmf" is good for testing here, and I should see the
> >> non-plural form (but I can see the plural form).
> >>
> >> NG
> >
> > Wait, I should have tested with LANG=C first. :-) That is also wrong, so
> > probably there is a bug in the source code...
> >
>
> Just because this took me a whileto figure out what was going on, here
> is some actual output...
>
>
> > pacman -S gimp --ignore libwmf
> resolving dependencies...
> warning: ignoring package libwmf-0.2.8.4-8
> warning: cannot resolve "libwmf", a dependency of "gimp"
> :: The following packages cannot be upgraded due to unresolvable
> dependencies:
> gimp
>
> Do you want to skip the above packages for this upgrade? [y/N] y
> looking for inter-conflicts...
> there is nothing to do
>
>
> Note "packages" in two messages there.
>
> Allan

With the patch I've just sent, both English and Hungarian messages are
correct. Sorry for the noise.

NG
 

Thread Tools




All times are GMT. The time now is 05:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org