sodeps: makepkg patches
On Tue, Feb 1, 2011 at 3:53 AM, Dan McGee <firstname.lastname@example.org> wrote:
> I have the feeling this has been hashed/rehashed/blended before, but
> why aren't we just doing something like:
> * *provides=('myenv')
> * *libprovides=('libx.so' 'liby.so')
> To me, this seems a lot clearer and alleviates the black magic
> concerns of changing depends/provides arrays on the fly.
I got confused by 'myenv', its supposed to be a normal provision like 'cron' ?
Anyway libprovides sounds fine to me, but the question is where do we
propagate this distinction, because there is no difference for pacman.
Should there also be a libprovides in PKGINFO and %LIBPROVIDES% in db,
and pacman will just read these two and merge them with provides ?
Or can they both be merged at the PKGINFO level ?