Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux Pacman Development (http://www.linux-archive.org/archlinux-pacman-development/)
-   -   bash_completion: fix bash 3.2 incompatibility (http://www.linux-archive.org/archlinux-pacman-development/389710-bash_completion-fix-bash-3-2-incompatibility.html)

"Allan McRae" 06-23-2010 03:33 AM

bash_completion: fix bash 3.2 incompatibility
 
On 22/06/10 12:30, Andres P wrote:

To avoid errors with bash 3.2, compopt will be skipped if it's not a
shell builtin.

compopt is needed to not append slashes to package names that
coincide with directories in PWD.

This is currently not possible to fix in bash versions that do not support
compopt, so these users will have to bear that regression.

Signed-off-by: Andres P<aepd87@gmail.com>


Signed-off-by: Allan

On my working-maint branch.


All times are GMT. The time now is 01:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.