FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Pacman Development

 
 
LinkBack Thread Tools
 
Old 06-22-2010, 02:30 AM
Andres P
 
Default bash_completion: fix bash 3.2 incompatibility

To avoid errors with bash 3.2, compopt will be skipped if it's not a
shell builtin.

compopt is needed to not append slashes to package names that
coincide with directories in PWD.

This is currently not possible to fix in bash versions that do not support
compopt, so these users will have to bear that regression.

Signed-off-by: Andres P <aepd87@gmail.com>
---
contrib/bash_completion | 17 ++++++++++++-----
1 files changed, 12 insertions(+), 5 deletions(-)

diff --git a/contrib/bash_completion b/contrib/bash_completion
index 2713ba4..1ec2cd5 100644
--- a/contrib/bash_completion
+++ b/contrib/bash_completion
@@ -52,10 +52,6 @@ _pacman_pkg() {
)"
}

-_pacman_file() {
- compopt -o filenames; _filedir 'pkg.tar.*'
-}
-
_pacman() {
local common core cur database prev query remove sync upgrade o
COMPREPLY=()
@@ -102,7 +98,18 @@ _pacman() {
true
}

+if [[ $(type -t compopt) = "builtin" ]]; then
+ _pacman_file() {
+ compopt -o filenames; _filedir 'pkg.tar.*'
+ }
+ complete -F _pacman -o default pacman
+else
+ _pacman_file() {
+ _filedir 'pkg.tar.*'
+ }
+ complete -F _pacman -o filenames -o default pacman
+fi
+
complete -F _makepkg -o default makepkg
-complete -F _pacman -o default pacman

# ex:et ts=2 sw=2 ft=sh
--

If you are testing this, do it with a clean enviro please:

$ env -i HOME="$HOME" TERM="$TERM" bash3 --rcfile "/etc/bash_completion" -i

1.7.1
 

Thread Tools




All times are GMT. The time now is 07:03 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org