Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux General Discussion (http://www.linux-archive.org/archlinux-general-discussion/)
-   -   PrintScreen key doesn't launch gnome-screenshot (http://www.linux-archive.org/archlinux-general-discussion/711629-printscreen-key-doesnt-launch-gnome-screenshot.html)

fredbezies 10-11-2012 10:15 PM

PrintScreen key doesn't launch gnome-screenshot
 
Hello.

I'm searching some help, because I'm really stuck. I'm facing a weird
- I mean a very weird one - problem since I reinstalled from scratch a
few days ago my computer.

Ok. I'm using archlinux + gnome 3 with testing repo enabled and fully
up-to-date. And a fully systemd one if it is important.

1) Video : nouveau driver
2) Installed gnome 3 fully : gnome + gnome extra + gnome-utils
3) All bindings are correctly set in gnome system preferences.

When I press PrintScreen, nothing happens. Nothing. Gnome-screenshot
from command line start and also when I search it.

I tried :

1) new key for screen capture : nothing
2) binding PrintScreen to launch another program : nothing
3) another keyboard : nothing

I didn't tweak anything just installed gnome, gnome extra and gnome
utils on setup time.

If you have an idea, I'm glad to hear it.

By the way, my install is very genuine, no tweaks besides the window
button ones and date, using gnome-tweak-tool. Only extension :
alternative-status-menu.

Thanks.

--
Frederic Bezies
fredbezies@gmail.com

Rodrigo Rivas 10-12-2012 10:23 AM

PrintScreen key doesn't launch gnome-screenshot
 
On Fri, Oct 12, 2012 at 12:15 AM, fredbezies <fredbezies@gmail.com> wrote:

> Hello.
>
> I'm searching some help, because I'm really stuck. I'm facing a weird
> - I mean a very weird one - problem since I reinstalled from scratch a
> few days ago my computer.
>
> Ok. I'm using archlinux + gnome 3 with testing repo enabled and fully
> up-to-date. And a fully systemd one if it is important.
>
> 1) Video : nouveau driver
> 2) Installed gnome 3 fully : gnome + gnome extra + gnome-utils
> 3) All bindings are correctly set in gnome system preferences.
>
> When I press PrintScreen, nothing happens. Nothing. Gnome-screenshot
> from command line start and also when I search it.
>
> I tried :
>
> 1) new key for screen capture : nothing
> 2) binding PrintScreen to launch another program : nothing
> 3) another keyboard : nothing
>
> I didn't tweak anything just installed gnome, gnome extra and gnome
> utils on setup time.
>
> If you have an idea, I'm glad to hear it.
>

That very same problem happened to me. The thing is that newer
gnome-screenshot versions don't get the window by default when pressing the
PrintScreen key. Instead it saves the image into disk directly. Take a look
into your "PICTURES" directory. execute

$ xdg-user-dir PICTURES

to discover what the directory is.

Note that if for some reason that directory does not exist the capture will
fail. If so do:

$ xdg-user-dir-udate.

HTH

Rodrigo.

fredbezies 10-12-2012 10:42 AM

PrintScreen key doesn't launch gnome-screenshot
 
2012/10/12 Rodrigo Rivas <rodrigorivascosta@gmail.com>:
> On Fri, Oct 12, 2012 at 12:15 AM, fredbezies <fredbezies@gmail.com> wrote:
>
>> Hello.
>>
>> I'm searching some help, because I'm really stuck. I'm facing a weird
>> - I mean a very weird one - problem since I reinstalled from scratch a
>> few days ago my computer.
>>
>> Ok. I'm using archlinux + gnome 3 with testing repo enabled and fully
>> up-to-date. And a fully systemd one if it is important.
>>
>> 1) Video : nouveau driver
>> 2) Installed gnome 3 fully : gnome + gnome extra + gnome-utils
>> 3) All bindings are correctly set in gnome system preferences.
>>
>> When I press PrintScreen, nothing happens. Nothing. Gnome-screenshot
>> from command line start and also when I search it.
>>
>> I tried :
>>
>> 1) new key for screen capture : nothing
>> 2) binding PrintScreen to launch another program : nothing
>> 3) another keyboard : nothing
>>
>> I didn't tweak anything just installed gnome, gnome extra and gnome
>> utils on setup time.
>>
>> If you have an idea, I'm glad to hear it.
>>
>
> That very same problem happened to me. The thing is that newer
> gnome-screenshot versions don't get the window by default when pressing the
> PrintScreen key. Instead it saves the image into disk directly. Take a look
> into your "PICTURES" directory. execute
>
> $ xdg-user-dir PICTURES
>
> to discover what the directory is.
>
> Note that if for some reason that directory does not exist the capture will
> fail. If so do:
>
> $ xdg-user-dir-udate.
>
> HTH
>
> Rodrigo.

Sorry, it won't help at all. Nothing - and I mean nothing - is started
right after I push PrintScreen key. No flash, no sound.
GnomeScreenshot is working from command line.

And I ran xdg-user-dirs-update after starting my first gnome session.

It is like the key is dead. But it is not a keyboard problem, same
thing happens with another keyboard.

Thanks anyway.

--
Frederic Bezies
fredbezies@gmail.com

Jayesh Badwaik 10-12-2012 10:53 AM

PrintScreen key doesn't launch gnome-screenshot
 
On Fri, Oct 12, 2012 at 4:12 PM, fredbezies <fredbezies@gmail.com> wrote:

> It is like the key is dead. But it is not a keyboard problem, same
> thing happens with another keyboard.
>
> Use the showkey to determine, if the key is being determined by the kernel
when pressed. If it is being determined, then probably it is not mapped
correctly.
See the following links to determine how to map such keys.
https://wiki.archlinux.org/index.php/Extra_Keyboard_Keys_in_Xorg

https://wiki.archlinux.org/index.php/Extra_Keyboard_Keys#Using_xev


--
Jayesh

fredbezies 10-12-2012 11:02 AM

PrintScreen key doesn't launch gnome-screenshot
 
2012/10/12 Jayesh Badwaik <jayesh.badwaik90@gmail.com>:
> On Fri, Oct 12, 2012 at 4:12 PM, fredbezies <fredbezies@gmail.com> wrote:
>
>> It is like the key is dead. But it is not a keyboard problem, same
>> thing happens with another keyboard.
>>
>> Use the showkey to determine, if the key is being determined by the kernel
> when pressed. If it is being determined, then probably it is not mapped
> correctly.
> See the following links to determine how to map such keys.
> https://wiki.archlinux.org/index.php/Extra_Keyboard_Keys_in_Xorg

It is recognized by the kernel.

keycode 99 pressed
keycode 99 released

when I press the PrintScreen key.

With Xev :

107 Print
107 Print
107 Print
107 Print
107 Print

The weird part is that PrintScreen is recognized as such in Gnome
keyboard preferences panel.

>
> https://wiki.archlinux.org/index.php/Extra_Keyboard_Keys#Using_xev
>
>
> --
> Jayesh



--
Frederic Bezies
fredbezies@gmail.com

Laurent Carlier 10-12-2012 11:05 AM

PrintScreen key doesn't launch gnome-screenshot
 
Le vendredi 12 octobre 2012 13:02:35 fredbezies a écrit :
> It is recognized by the kernel.
>
> keycode 99 pressed
> keycode 99 released
>
> when I press the PrintScreen key.
>
> With Xev :
>
> 107 Print
> 107 Print
> 107 Print
> 107 Print
> 107 Print
>
> The weird part is that PrintScreen is recognized as such in Gnome
> keyboard preferences panel.

Just tested quickly, it's working fine with ksnapshot under kde (of course
testing is enabled)

++

Rodrigo Rivas 10-12-2012 09:40 PM

PrintScreen key doesn't launch gnome-screenshot
 
On Fri, Oct 12, 2012 at 12:42 PM, fredbezies <fredbezies@gmail.com> wrote:

> 2012/10/12 Rodrigo Rivas <rodrigorivascosta@gmail.com>:
> > On Fri, Oct 12, 2012 at 12:15 AM, fredbezies <fredbezies@gmail.com>
> wrote:
> >
> >> Hello.
> >>
> >> I'm searching some help, because I'm really stuck. I'm facing a weird
> >> - I mean a very weird one - problem since I reinstalled from scratch a
> >> few days ago my computer.
> >>
> >> Ok. I'm using archlinux + gnome 3 with testing repo enabled and fully
> >> up-to-date. And a fully systemd one if it is important.
> >>
> >> 1) Video : nouveau driver
> >> 2) Installed gnome 3 fully : gnome + gnome extra + gnome-utils
> >> 3) All bindings are correctly set in gnome system preferences.
> >>
> >> When I press PrintScreen, nothing happens. Nothing. Gnome-screenshot
> >> from command line start and also when I search it.
> >>
> >> I tried :
> >>
> >> 1) new key for screen capture : nothing
> >> 2) binding PrintScreen to launch another program : nothing
> >> 3) another keyboard : nothing
> >>
> >> I didn't tweak anything just installed gnome, gnome extra and gnome
> >> utils on setup time.
> >>
> >> If you have an idea, I'm glad to hear it.
> >>
> >
> > That very same problem happened to me. The thing is that newer
> > gnome-screenshot versions don't get the window by default when pressing
> the
> > PrintScreen key. Instead it saves the image into disk directly. Take a
> look
> > into your "PICTURES" directory. execute
> >
> > $ xdg-user-dir PICTURES
> >
> > to discover what the directory is.
> >
> > Note that if for some reason that directory does not exist the capture
> will
> > fail. If so do:
> >
> > $ xdg-user-dir-udate.
> >
> > HTH
> >
> > Rodrigo.
>
> Sorry, it won't help at all. Nothing - and I mean nothing - is started
> right after I push PrintScreen key. No flash, no sound.
> GnomeScreenshot is working from command line.
>
> And I ran xdg-user-dirs-update after starting my first gnome session.
>
> It is like the key is dead. But it is not a keyboard problem, same
> thing happens with another keyboard.
>
> Thanks anyway.


Did you check the .xsession-errors file for any hint? Run:

$ tail -f ~/.xsession-errors

And then press the PrintScreen key to see if anything is logged.

--
Rodrigo

fredbezies 10-13-2012 05:39 AM

PrintScreen key doesn't launch gnome-screenshot
 
2012/10/12 Rodrigo Rivas <rodrigorivascosta@gmail.com>:
> On Fri, Oct 12, 2012 at 12:42 PM, fredbezies <fredbezies@gmail.com> wrote:
>
[...]
>
> Did you check the .xsession-errors file for any hint? Run:
>
> $ tail -f ~/.xsession-errors
>
> And then press the PrintScreen key to see if anything is logged.
>
> --
> Rodrigo

First log I looked at. Nothing is stored. Nothing in /var/log/errors.log too.

Dmesg | tail ? Nothing.
/var/log/everything.log ? Nothing

This is really "dumb" and quiet. Far too quiet.

--
Frederic Bezies
fredbezies@gmail.com

Jayesh Badwaik 10-13-2012 05:43 AM

PrintScreen key doesn't launch gnome-screenshot
 
On Sat, Oct 13, 2012 at 11:09 AM, fredbezies <fredbezies@gmail.com> wrote:

> First log I looked at. Nothing is stored. Nothing in /var/log/errors.log
> too.
>
> Dmesg | tail ? Nothing.
> /var/log/everything.log ? Nothing
>
> This is really "dumb" and quiet. Far too quiet.
>
>
Just out of curiosity, may be the situation is a something similar to this?
http://askubuntu.com/questions/153962/why-isnt-the-printscreen-button-working-in-gnome

--
Jayesh

fredbezies 10-13-2012 05:46 AM

PrintScreen key doesn't launch gnome-screenshot
 
2012/10/13 Jayesh Badwaik <jayesh.badwaik90@gmail.com>:
> On Sat, Oct 13, 2012 at 11:09 AM, fredbezies <fredbezies@gmail.com> wrote:
>
>> First log I looked at. Nothing is stored. Nothing in /var/log/errors.log
>> too.
>>
>> Dmesg | tail ? Nothing.
>> /var/log/everything.log ? Nothing
>>
>> This is really "dumb" and quiet. Far too quiet.
>>
>>
> Just out of curiosity, may be the situation is a something similar to this?
> http://askubuntu.com/questions/153962/why-isnt-the-printscreen-button-working-in-gnome
>
> --
> Jayesh

In some way, yes. But I didn't try shutter. Same behaviour.

--
Frederic Bezies
fredbezies@gmail.com


All times are GMT. The time now is 08:06 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.