FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 09-27-2012, 12:54 PM
"Ralf Mardorf"
 
Default fglrx driver doesn't work

Hi

the fglrx driver doesn't work. Perhaps I missed a typo or some settings
are bad or are missing. IIUC RS690 is supported by the current driver.

I added the output of
# grep EE /var/log/Xorg.0.log
# hwinfo --gfxcard
# cat /etc/X11/xorg.conf
the versions of catalyst-hook, catalyst-utils and xorg-server below.
I verified that xf86-video-ati really was removed and verified that
"nomodeset" is set for the Arch Linux kernels.


"catalyst_build_module all"'s output was ok, for both kernels.

suse11-2:/home/spinymouse11.2 # ls -hAl
/media/archlinux/usr/lib/modules/extramodules-3.4-rt/fglrx.ko.gz
-rw-r--r-- 1 root root 884K 2012-09-27 12:31
/media/archlinux/usr/lib/modules/extramodules-3.4-rt/fglrx.ko.gz


suse11-2:/home/spinymouse11.2 # ls -hAl
/media/archlinux/usr/lib/modules/extramodules-3.5-ARCH/fglrx.ko.gz
-rw-r--r-- 1 root root 883K 2012-09-27 12:32
/media/archlinux/usr/lib/modules/extramodules-3.5-ARCH/fglrx.ko.gz


suse11-2:/home/spinymouse11.2 # cat /media/archlinux/root/arch_fglrx.txt
# grep EE /var/log/Xorg.0.log >> arch_fglrx.txt
[ 45.366] Current Operating System: Linux archlinux 3.4.11-rt19-1-rt #1
SMP PREEMPT RT Fri Sep 21 13:19:10 UTC 2012 x86_64

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 45.375] (II) Loading extension MIT-SCREEN-SAVER
[ 45.448] (EE) No supported AMD display adapters were found
[ 45.448] (EE) No devices detected.
# shutdown -r now
# grep EE /var/log/Xorg.0.log >> arch_fglrx.txt
[ 29.463] Current Operating System: Linux archlinux 3.5.4-1-ARCH #1 SMP
PREEMPT Sat Sep 15 08:12:04 CEST 2012 x86_64

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 29.470] (II) Loading extension MIT-SCREEN-SAVER
[ 29.541] (EE) No supported AMD display adapters were found
[ 29.541] (EE) No devices detected.
# hwinfo --gfxcard >> arch_fglrx.txt
28: PCI 105.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: ul7N.A_MYUPeZ6pD
Parent ID: vSkL.Objt6VSItgC
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
SysFS BusID: 0000:01:05.0
Hardware Class: graphics card
Model: "ATI RS690 [Radeon X1200 Series]"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x791e "RS690 [Radeon X1200 Series]"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x826d
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xfdff0000-0xfdffffff (rw,non-prefetchable)
I/O Ports: 0xce00-0xceff (rw)
Memory Range: 0xfde00000-0xfdefffff (rw,non-prefetchable)
IRQ: 18 (2 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: "pci:v00001002d0000791Esv00001043sd0000826Dbc03sc0 0i00"
Driver Info #0:
Driver Status: radeon is active
Driver Activation Cmd: "modprobe radeon"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

Primary display adapter: #28
# cat /etc/X11/xorg.conf >> arch_fglrx.txt
Section "Module"
Load "extmod"
Load "dri"
Load "dbe"
Load "dri2"
Load "glx"
Load "record"
Load "GLcore"
#Load "v4l"
EndSection
Section "Monitor"
Identifier "Monitor0"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
DisplaySize 305 230
HorizSync 29-98
VertRefresh 50-120
modeline "1152x864" 128.42 1152 1232 1360 1568 864 865 868 910
Gamma 1.0
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "VideoKey" # <i>
#Option "MergedFB" "off" #old debian/ubuntu
Identifier "Card0"
Driver "fglrx"
#Driver "radeon"
#Driver "nvidia"
#Driver "nv"
#Driver "nouveau"
#Driver "vesa"
#VendorName "nVidia Corporation"
#BoardName "G72 [GeForce 7300 SE/7200 GS]"
#BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"

Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
#Virtual 3840 1200
EndSubSection

# SubSection "Display"
# Viewport 0 0
# Depth 1
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 4
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 8
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 15
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 16
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 24
# EndSubSection
EndSection
# grep nomodeset /mnt/oz/boot/grub/menu.lst >> arch_fglrx.txt
kernel /boot/vmlinuz-linux-rt root=/dev/sda9 ro nomodeset
#kernel /boot/vmlinuz-linux-rt root=/dev/sda9 ro nomodeset
kernel /boot/vmlinuz-linux root=/dev/sda9 ro nomodeset
kernel /boot/vmlinuz-linux root=/dev/sda9 ro nomodeset
# pacman -Qi catalyst-hook | grep Ver >> arch_fglrx.txt
Version : 12.8-1
# pacman -Qi catalyst-utils | grep Ver >> arch_fglrx.txt
Version : 12.8-1
# pacman -Qi xorg-server | grep Ver >> arch_fglrx.txt
Version : 1.12.4-1
# pacman -Qi xf86-video-ati
error: package 'xf86-video-ati' was not found

Regards,
Ralf
 
Old 09-27-2012, 01:02 PM
Jameson
 
Default fglrx driver doesn't work

On Thu, Sep 27, 2012 at 8:54 AM, Ralf Mardorf
<ralf.mardorf@alice-dsl.net> wrote:
> Model: "ATI RS690 [Radeon X1200 Series]"

The X1200 series is no longer supported by current Catalyst drivers.
You will need to use a legacy driver, or the open source driver.

=-Jameson
 
Old 09-27-2012, 01:13 PM
"Ralf Mardorf"
 
Default fglrx driver doesn't work

On Thu, 27 Sep 2012 15:02:15 +0200, Jameson <imntreal@gmail.com> wrote:

On Thu, Sep 27, 2012 at 8:54 AM, Ralf Mardorf
<ralf.mardorf@alice-dsl.net> wrote:

Model: "ATI RS690 [Radeon X1200 Series]"


The X1200 series is no longer supported by current Catalyst drivers.
You will need to use a legacy driver, or the open source driver.


OK, so I misunderstood what I read about "RS690". The "radeon" driver does
work, but it might (or might not) be the cause for xruns, that's why I'll
test the proprietary driver.
Hopefully there's an outdated version supporting X1... cards and hopefully
it won't cause issues to downgrade X.


To be continued later today, or within the next days.

Thank you,
Ralf
 
Old 09-27-2012, 07:47 PM
Řyvind Heggstad
 
Default fglrx driver doesn't work

On Thu, 27 Sep 2012 15:13:00 +0200
"Ralf Mardorf" <ralf.mardorf@alice-dsl.net> wrote:

> On Thu, 27 Sep 2012 15:02:15 +0200, Jameson <imntreal@gmail.com>
> wrote:
> > On Thu, Sep 27, 2012 at 8:54 AM, Ralf Mardorf
> > <ralf.mardorf@alice-dsl.net> wrote:
> >> Model: "ATI RS690 [Radeon X1200 Series]"
> >
> > The X1200 series is no longer supported by current Catalyst drivers.
> > You will need to use a legacy driver, or the open source driver.
>
> OK, so I misunderstood what I read about "RS690". The "radeon" driver
> does work, but it might (or might not) be the cause for xruns, that's
> why I'll test the proprietary driver.
> Hopefully there's an outdated version supporting X1... cards and
> hopefully it won't cause issues to downgrade X.
>
> To be continued later today, or within the next days.
>
> Thank you,
> Ralf

I suggest switching to the free driver. It is slower, not that it
really matters that much for that card, but it will generally cause a
lot less pain when it comes to maintaining it.
 

Thread Tools




All times are GMT. The time now is 09:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org