FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 09-21-2012, 10:37 AM
"Guillermo Leira"
 
Default Can't see all my memory

Hello!

I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be seeing
just four. What have I done wrong?

Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report only 4
GB.

Best Regards

Guillermo Leira
 
Old 09-21-2012, 10:46 AM
Roel Deckers
 
Default Can't see all my memory

Does the missing memory show up in other OSs?
It can be faulty ram if it doesn't show up in any OS, recently had that problem.

On Fri, Sep 21, 2012 at 12:37 PM, Guillermo Leira <gleira@gleira.com> wrote:
> Hello!
>
> I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be seeing
> just four. What have I done wrong?
>
> Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report only 4
> GB.
>
> Best Regards
>
> Guillermo Leira
>
>
>
>
 
Old 09-21-2012, 10:47 AM
Aurko Roy
 
Default Can't see all my memory

On Fri, Sep 21, 2012 at 4:16 PM, Roel Deckers <r.deckers.93@gmail.com>wrote:

> Does the missing memory show up in other OSs?
> It can be faulty ram if it doesn't show up in any OS, recently had that
> problem.
>
> On Fri, Sep 21, 2012 at 12:37 PM, Guillermo Leira <gleira@gleira.com>
> wrote:
> > Hello!
> >
> > I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be
> seeing
> > just four. What have I done wrong?
> >
> > Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report only 4
> > GB.
> >
> > Best Regards
> >
> > Guillermo Leira
> >
> >
> >
> >
>

You could try running memtest86+ on boot and see if it detects the
additional memory.

--
Aurko Roy
GPG key: 0x20C5BC31
Fingerprint:76B4 9677 15BE 731D 1949 85BA 2A31 B442 20C5 BC31
 
Old 09-21-2012, 12:48 PM
Ralf Mardorf
 
Default Can't see all my memory

On Fri, 2012-09-21 at 16:17 +0530, Aurko Roy wrote:
> On Fri, Sep 21, 2012 at 4:16 PM, Roel Deckers <r.deckers.93@gmail.com>wrote:
>
> > Does the missing memory show up in other OSs?
> > It can be faulty ram if it doesn't show up in any OS, recently had that
> > problem.
> >
> > On Fri, Sep 21, 2012 at 12:37 PM, Guillermo Leira <gleira@gleira.com>
> > wrote:
> > > Hello!
> > >
> > > I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be
> > seeing
> > > just four. What have I done wrong?
> > >
> > > Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report only 4
> > > GB.
> > >
> > > Best Regards
> > >
> > > Guillermo Leira
> > >
> > >
> > >
> > >
> >
>
> You could try running memtest86+ on boot and see if it detects the
> additional memory.

I never heard that anybody solved this issue, but I read that many
people have this issue too.

On my computer there are only 3 GB + 768 MB of 4 MB available. The
graphics has got it's own framebuffer, 256 MB, but IIRC I once have seen
that the framebuffer is 512 MB. I guess I can see it running NVIDIA
settings, but at the moment I can't run it, because I'm using the nv
driver. IIRC memtest86+ did always show the complete memory on my
machine. I don't care, since it doesn't make a difference if I got 4GB
or 3.8GB. However, I read often about this 8GB issue, for different
distros. And it where definitive threads about 64-bit architecture, not
about 32-bit and PAE issues.

Regards,
Ralf
 
Old 09-21-2012, 01:48 PM
Kevin Chadwick
 
Default Can't see all my memory

> I never heard that anybody solved this issue, but I read that many
> people have this issue too.
>
> On my computer there are only 3 GB + 768 MB of 4 MB available. The
> graphics has got it's own framebuffer, 256 MB, but IIRC I once have seen
> that the framebuffer is 512 MB. I guess I can see it running NVIDIA
> settings, but at the moment I can't run it, because I'm using the nv
> driver. IIRC memtest86+ did always show the complete memory on my
> machine. I don't care, since it doesn't make a difference if I got 4GB
> or 3.8GB. However, I read often about this 8GB issue, for different
> distros. And it where definitive threads about 64-bit architecture, not
> about 32-bit and PAE issues.

Yes on 64 bit systems you will see the maximum memory. On 32 bit you
need a PAE enabled kernel to get any more than 4Gig. If you have less
than 4Gig you may want to use the PAE kernel in any case because if you
have a relatively modern cpu it will support hardware Non execute
protection. On a non-PAE kernel you will see NX protection disabled or
such in dmesg.

--
__________________________________________________ _____________________

'Write programs that do one thing and do it well. Write programs to work
together. Write programs to handle text streams, because that is a
universal interface'

(Doug McIlroy)
__________________________________________________ _____________________
 
Old 09-21-2012, 01:52 PM
Victor Silva
 
Default Can't see all my memory

2012/9/21 Ralf Mardorf <ralf.mardorf@alice-dsl.net>

> On Fri, 2012-09-21 at 16:17 +0530, Aurko Roy wrote:
> > On Fri, Sep 21, 2012 at 4:16 PM, Roel Deckers <r.deckers.93@gmail.com
> >wrote:
> >
> > > Does the missing memory show up in other OSs?
> > > It can be faulty ram if it doesn't show up in any OS, recently had that
> > > problem.
> > >
> > > On Fri, Sep 21, 2012 at 12:37 PM, Guillermo Leira <gleira@gleira.com>
> > > wrote:
> > > > Hello!
> > > >
> > > > I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be
> > > seeing
> > > > just four. What have I done wrong?
> > > >
> > > > Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report
> only 4
> > > > GB.
> > > >
> > > > Best Regards
> > > >
> > > > Guillermo Leira
> > > >
> > > >
> > > >
> > > >
> > >
> >
> > You could try running memtest86+ on boot and see if it detects the
> > additional memory.
>
> I never heard that anybody solved this issue, but I read that many
> people have this issue too.
>
> On my computer there are only 3 GB + 768 MB of 4 MB available. The
> graphics has got it's own framebuffer, 256 MB, but IIRC I once have seen
> that the framebuffer is 512 MB. I guess I can see it running NVIDIA
> settings, but at the moment I can't run it, because I'm using the nv
> driver. IIRC memtest86+ did always show the complete memory on my
> machine. I don't care, since it doesn't make a difference if I got 4GB
> or 3.8GB. However, I read often about this 8GB issue, for different
> distros. And it where definitive threads about 64-bit architecture, not
> about 32-bit and PAE issues.
>
> Regards,
> Ralf
>
> Ralf, if I got right you can't find the buffer memory right? Assuming you
got a gpu why don't you disable the buffer on the bios?
 
Old 09-21-2012, 02:10 PM
Ralf Mardorf
 
Default Can't see all my memory

On Fri, 2012-09-21 at 14:48 +0100, Kevin Chadwick wrote:
> > I never heard that anybody solved this issue, but I read that many
> > people have this issue too.
> >
> > On my computer there are only 3 GB + 768 MB of 4 MB available. The
> > graphics has got it's own framebuffer, 256 MB, but IIRC I once have seen
> > that the framebuffer is 512 MB. I guess I can see it running NVIDIA
> > settings, but at the moment I can't run it, because I'm using the nv
> > driver. IIRC memtest86+ did always show the complete memory on my
> > machine. I don't care, since it doesn't make a difference if I got 4GB
> > or 3.8GB. However, I read often about this 8GB issue, for different
> > distros. And it where definitive threads about 64-bit architecture, not
> > about 32-bit and PAE issues.
>
> Yes on 64 bit systems you will see the maximum memory. On 32 bit you
> need a PAE enabled kernel to get any more than 4Gig. If you have less
> than 4Gig you may want to use the PAE kernel in any case because if you
> have a relatively modern cpu it will support hardware Non execute
> protection. On a non-PAE kernel you will see NX protection disabled or
> such in dmesg.

I'm using 64-bit architecture.
[spinymouse@archlinux ~]$ uname -a
Linux archlinux 3.4.4-rt14-1-rt #1 SMP PREEMPT RT Fri Jul 20 13:16:40
UTC 2012 x86_64 GNU/Linux
[spinymouse@archlinux ~]$ hwinfo --memory
01: None 00.0: 10102 Main Memory
[Created at memory.66]
Unique ID: rdCR.CxwsZFjVASF
Hardware Class: memory
Model: "Main Memory"
Memory Range: 0x00000000-0xf7b84fff (rw)
Memory Size: 3 GB + 768 MB
 
Old 09-21-2012, 02:13 PM
Ralf Mardorf
 
Default Can't see all my memory

On Fri, 2012-09-21 at 10:52 -0300, Victor Silva wrote:
> 2012/9/21 Ralf Mardorf <ralf.mardorf@alice-dsl.net>
>
> > On Fri, 2012-09-21 at 16:17 +0530, Aurko Roy wrote:
> > > On Fri, Sep 21, 2012 at 4:16 PM, Roel Deckers <r.deckers.93@gmail.com
> > >wrote:
> > >
> > > > Does the missing memory show up in other OSs?
> > > > It can be faulty ram if it doesn't show up in any OS, recently had that
> > > > problem.
> > > >
> > > > On Fri, Sep 21, 2012 at 12:37 PM, Guillermo Leira <gleira@gleira.com>
> > > > wrote:
> > > > > Hello!
> > > > >
> > > > > I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be
> > > > seeing
> > > > > just four. What have I done wrong?
> > > > >
> > > > > Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report
> > only 4
> > > > > GB.
> > > > >
> > > > > Best Regards
> > > > >
> > > > > Guillermo Leira
> > > > >
> > > > >
> > > > >
> > > > >
> > > >
> > >
> > > You could try running memtest86+ on boot and see if it detects the
> > > additional memory.
> >
> > I never heard that anybody solved this issue, but I read that many
> > people have this issue too.
> >
> > On my computer there are only 3 GB + 768 MB of 4 MB available. The
> > graphics has got it's own framebuffer, 256 MB, but IIRC I once have seen
> > that the framebuffer is 512 MB. I guess I can see it running NVIDIA
> > settings, but at the moment I can't run it, because I'm using the nv
> > driver. IIRC memtest86+ did always show the complete memory on my
> > machine. I don't care, since it doesn't make a difference if I got 4GB
> > or 3.8GB. However, I read often about this 8GB issue, for different
> > distros. And it where definitive threads about 64-bit architecture, not
> > about 32-bit and PAE issues.
> >
> > Regards,
> > Ralf
> >
> > Ralf, if I got right you can't find the buffer memory right? Assuming you
> got a gpu why don't you disable the buffer on the bios?

It is disabled in the BIOS and in the past there where no issues. I
don't know when this issue occurred for the first time, but there where
no BIOS updates, just kernel updates.

Regards,
Ralf
 
Old 09-21-2012, 06:55 PM
"Guillermo Leira"
 
Default Can't see all my memory

> -----Mensaje original-----
> De: arch-general [mailto:arch-general-bounces@archlinux.org] En nombre de Ralf
> Mardorf
> Enviado el: viernes, 21 de septiembre de 2012 14:49
> Para: General Discussion about Arch Linux
> Asunto: Re: [arch-general] Can't see all my memory
>
> On Fri, 2012-09-21 at 16:17 +0530, Aurko Roy wrote:
> > On Fri, Sep 21, 2012 at 4:16 PM, Roel Deckers <r.deckers.93@gmail.com>wrote:
> >
> > > Does the missing memory show up in other OSs?
> > > It can be faulty ram if it doesn't show up in any OS, recently had that
> > > problem.
> > >
> > > On Fri, Sep 21, 2012 at 12:37 PM, Guillermo Leira <gleira@gleira.com>
> > > wrote:
> > > > Hello!
> > > >
> > > > I've installed an x86_64 Arch on a PC with 8 GB, but it seems to be
> > > seeing
> > > > just four. What have I done wrong?
> > > >
> > > > Bios sees 4 x 2GB Modules and reports 8 GB, but top or free report only
> 4
> > > > GB.

> > You could try running memtest86+ on boot and see if it detects the
> > additional memory.
>
> I never heard that anybody solved this issue, but I read that many
> people have this issue too.
>
> On my computer there are only 3 GB + 768 MB of 4 MB available. The
> graphics has got it's own framebuffer, 256 MB, but IIRC I once have seen
> that the framebuffer is 512 MB. I guess I can see it running NVIDIA
> settings, but at the moment I can't run it, because I'm using the nv
> driver. IIRC memtest86+ did always show the complete memory on my
> machine. I don't care, since it doesn't make a difference if I got 4GB
> or 3.8GB. However, I read often about this 8GB issue, for different
> distros. And it where definitive threads about 64-bit architecture, not
> about 32-bit and PAE issues.
>
> Regards,
> Ralf

Well... Solved. It is a new motherboard, and it has a setting (that I've never seen in any other one) that says "Memory Remap Feature". I don't understand that a motherboard has a default option that actually should appear as "Waste half of your memory".

Thanks to all. :-)

Guillermo Leira
 
Old 09-21-2012, 09:18 PM
Dave Warren
 
Default Can't see all my memory

On 9/21/2012 11:55, Guillermo Leira wrote:
Well... Solved. It is a new motherboard, and it has a setting (that
I've never seen in any other one) that says "Memory Remap Feature". I
don't understand that a motherboard has a default option that actually
should appear as "Waste half of your memory". Thanks to all. :-)
Guillermo Leira


This generally enables better x86 compatibility, at the cost of x64
memory availability.


--
Dave Warren
http://www.hireahit.com/
http://ca.linkedin.com/in/davejwarren
 

Thread Tools




All times are GMT. The time now is 10:08 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org