Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux General Discussion (http://www.linux-archive.org/archlinux-general-discussion/)
-   -   util-linux pacman error, file conflicts (safe to force?) (http://www.linux-archive.org/archlinux-general-discussion/681660-util-linux-pacman-error-file-conflicts-safe-force.html)

"David C. Rankin" 07-09-2012 04:01 PM

util-linux pacman error, file conflicts (safe to force?)
 
On 07/09/2012 10:52 AM, Mateusz Loskot wrote:

Check the ArchLinux ARM forum:

http://archlinuxarm.org/forum/viewtopic.php?t=3036&p=18467

where filesystem upgrade is suggested:

pacman -Syuf

But, I'd wait until someone confirms it is the right way to go.



Thank you Mateusz!

We will wait for the all clear from the devs before forcing. Arch Devs,
when you can confirm a force is the proper way to handle this util-linux
issue, please let us know. I'm just trying to avoid causing myself grief :)


--
David C. Rankin, J.D.,P.E.

Daniel Wallace 07-09-2012 04:11 PM

util-linux pacman error, file conflicts (safe to force?)
 
On Mon, Jul 09, 2012 at 04:52:08PM +0100, Mateusz Loskot wrote:
> On 9 July 2012 16:49, David C. Rankin <drankinatty@suddenlinkmail.com> wrote:
> > Tom, All,
> >
> > I ran into the following error regarding util-linux upgrade. I've looked
> > in the forum and the website, but nothing specific to it. The error is:
> >
> > (72/72) checking for file conflicts
> > [###########################################] 100%
> > error: failed to commit transaction (conflicting files)
> > util-linux: /bin/login exists in filesystem
>
> > [...]
>
> Check the ArchLinux ARM forum:
>
> http://archlinuxarm.org/forum/viewtopic.php?t=3036&p=18467
>
> where filesystem upgrade is suggested:
>
> pacman -Syuf
>
> But, I'd wait until someone confirms it is the right way to go.
>
> Best regards,
> --
> Mateusz Loskot, http://mateusz.loskot.net


never -Syuf
never -Suf
never force an upgrade

if anything you can do -Sf for one package at a time...
but _do not_ for an upgrade.

It will cause problems when you have upgrades like when pam had the
stuff that is in pambase... pambase was installed and took control of
the files in /etc/pam.d then when pambase upgraded, it removed those
file, causeing sudo to not work and making it so the user couldn't login

"David C. Rankin" 07-09-2012 04:28 PM

util-linux pacman error, file conflicts (safe to force?)
 
On 07/09/2012 11:10 AM, Denis A. Altoé Falqueto wrote:

One strange thing is that the files generating the conflict are owned
by the shadow package. I don't remember of any warning about forcing
updates for util-linux in arch-devel. It seems to me like a packaging
bug.


Not a bug -- if the problem is due to shadow, then I have an older shadow
package on my box. That gives me a place to start looking. I still have shadow
4.1.4.3-5 with the fudged build of shared libraries. I presume this is the
cause of the conflict. I'll have to pick though the changes to find out if I
can force the package.



--
David C. Rankin, J.D.,P.E.


All times are GMT. The time now is 09:41 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.