Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux General Discussion (http://www.linux-archive.org/archlinux-general-discussion/)
-   -   Can't suspend or hibernate (http://www.linux-archive.org/archlinux-general-discussion/677672-cant-suspend-hibernate.html)

Brock York 06-27-2012 08:37 AM

Can't suspend or hibernate
 
Hey

I haven't been able to suspend my desktop for about 6 months now. I'm not
sure what has caused it.
I haven't had any hardware changes and even a reload hasn't fixed the
problem.
I've tried reading the wiki on suspending and run some tests using
pm-suspend.
It suspends processes fine according to the guide I was following, but it
seems to get stuck at suspending hardware.
I tried disabling as many modules as possible to then get it to suspend but
still no luck.
Is anyone else having this problem or has anyone fixed this problem?

Regards Brock

Sébastien le Preste de Vauban 06-29-2012 11:48 AM

Can't suspend or hibernate
 
El 27/06/12 04:37, Brock York escribió:

Hey

I haven't been able to suspend my desktop for about 6 months now. I'm not
sure what has caused it.
I haven't had any hardware changes and even a reload hasn't fixed the
problem.
I've tried reading the wiki on suspending and run some tests using
pm-suspend.
It suspends processes fine according to the guide I was following, but it
seems to get stuck at suspending hardware.
I tried disabling as many modules as possible to then get it to suspend but
still no luck.
Is anyone else having this problem or has anyone fixed this problem?

Regards Brock

I can suspend and hibernate but my computer can't boot after a /sudo
pm-hibernate/. Not sure why, anyway If I unplug it from the power source
for a couple of seconds, then it will boot again almost normally
(sometimes I get a message like /cpu frequency error/ from the bios,
strangely nothing seems wrong when looking at the bios settings). Maybe
the hibernating process sets the computer in some bad state.

Brock York 07-04-2012 06:03 AM

Can't suspend or hibernate
 
That's interesting. In my case when I try and suspend the screen goes blank
but the fans and hdds stay running the keyboard lights are still on but
accept no input. I then have to do the same and pull the power out. Then it
will boot but complains about no hibernate image if I hibernated it. I've
removed all hardware that's not necessary to see if that's the problem next
guess will be the gfx card but I have no inbuilt card.
On Jun 29, 2012 7:48 PM, "Sébastien le Preste de Vauban" <
ulpianosonsi@gmail.com> wrote:

> El 27/06/12 04:37, Brock York escribió:
>
>> Hey
>>
>> I haven't been able to suspend my desktop for about 6 months now. I'm not
>> sure what has caused it.
>> I haven't had any hardware changes and even a reload hasn't fixed the
>> problem.
>> I've tried reading the wiki on suspending and run some tests using
>> pm-suspend.
>> It suspends processes fine according to the guide I was following, but it
>> seems to get stuck at suspending hardware.
>> I tried disabling as many modules as possible to then get it to suspend
>> but
>> still no luck.
>> Is anyone else having this problem or has anyone fixed this problem?
>>
>> Regards Brock
>>
>> I can suspend and hibernate but my computer can't boot after a /sudo
> pm-hibernate/. Not sure why, anyway If I unplug it from the power source
> for a couple of seconds, then it will boot again almost normally
> (sometimes I get a message like /cpu frequency error/ from the bios,
> strangely nothing seems wrong when looking at the bios settings). Maybe the
> hibernating process sets the computer in some bad state.
>
>

Martin Cigorraga 07-04-2012 10:05 AM

Can't suspend or hibernate
 
On 29 June 2012 08:48, Sébastien le Preste de Vauban <ulpianosonsi@gmail.com
> wrote:

>
> I can suspend and hibernate but my computer can't boot after a /sudo
> pm-hibernate/. Not sure why, anyway If I unplug it from the power source
> for a couple of seconds, then it will boot again almost normally
> (sometimes I get a message like /cpu frequency error/ from the bios,
> strangely nothing seems wrong when looking at the bios settings). Maybe the
> hibernating process sets the computer in some bad state.
>
>
Mmm, I've seen every kind of weird behaviour with ATX power supplies,
please try this: just for testing purposes switch the power supply for
another one -either a used one or a new one, it doesn't matter- and try to
reproduce the glitch.
The idea behind this is sometimes ATX power supplies 'go dumb' and you need
to fully discharge them in order to reset them (sort of) - that's why it
works right when you unplug it.

--
-msx

Brock York 07-04-2012 10:36 AM

Can't suspend or hibernate
 
That's a good idea to try atleast Martin, I have also seen some really
weird behaviour because of powersupplies that are faulty. One minute the pc
works fine then ram disappears on next boot and you think it's faulty ram,
then the hdds will disappear completely must be the board and in the end
it's faulty power :/. Short of replacing all my components I don't know why
mine won't suspend.

Intel Core 2 Quad
SSD 120gb
Nvidia 480 gtx
4gb DDR3 ram


All times are GMT. The time now is 09:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.