FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 06-16-2012, 04:36 PM
Victor Silva
 
Default Virtual Box Update Fails

Folks with the last kernel I can no longer build virtualbox,
here is the error log:
*Targets (2): virtualbox-4.1.16-1
virtualbox-modules-4.1.16-2

Total Installed Size: 66.86 MiB

Proceed with installation? [Y/n] y
(0/2) checking package integrity (1/2) checking package
integrity (2/2) checking package integrity
(0/2) loading package files (1/2) loading package
files (2/2) loading package files
(0/2) checking for file conflicts (1/2) checking for file
conflicts (2/2) checking for file conflicts
error: failed to commit transaction (conflicting files)
virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxdrv.ko.gz exists
in filesystem
virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxnetadp.ko.gz
exists in filesystem
virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxnetflt.ko.gz
exists in filesystem
virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxpci.ko.gz exists
in filesystem
Errors occurred, no packages were upgraded.*

Can I move those files?

Regards,
Victor
 
Old 06-16-2012, 04:54 PM
Victor Silva
 
Default Virtual Box Update Fails

2012/6/16 Ike Devolder <ike.devolder@gmail.com>

> Op zaterdag 16 juni 2012 13:36:17 schreef Victor Silva:
> > Folks with the last kernel I can no longer build virtualbox,
> > here is the error log:
> > *Targets (2): virtualbox-4.1.16-1
> > virtualbox-modules-4.1.16-2
> >
> > Total Installed Size: 66.86 MiB
> >
> > Proceed with installation? [Y/n] y
> > (0/2) checking package integrity (1/2) checking package
> > integrity (2/2) checking package integrity
> > (0/2) loading package files (1/2) loading package
> > files (2/2) loading package files
> > (0/2) checking for file conflicts (1/2) checking for file
> > conflicts (2/2) checking for file conflicts
> > error: failed to commit transaction (conflicting files)
> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxdrv.ko.gz
> exists
> > in filesystem
> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxnetadp.ko.gz
> > exists in filesystem
> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxnetflt.ko.gz
> > exists in filesystem
> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxpci.ko.gz
> exists
> > in filesystem
> > Errors occurred, no packages were upgraded.*
> >
> > Can I move those files?
> >
> > Regards,
> > Victor
>
> did you build the modules manually before ?
>
> you could fix your problem by issuing:
> pacman -Sf virtualbox-modules
>
> --Ike
>
Guys thanks a lot for the insigths your tips did the trick. I could not
look on the forums befor as my system got mangled by the last kernel update
and just now I was able to get an X server and internet running again.

Regards,
Victor
 
Old 06-16-2012, 08:10 PM
Victor Silva
 
Default Virtual Box Update Fails

2012/6/16 Victor Silva <vfbsilva@gmail.com>

>
>
> 2012/6/16 Ike Devolder <ike.devolder@gmail.com>
>
>> Op zaterdag 16 juni 2012 13:36:17 schreef Victor Silva:
>> > Folks with the last kernel I can no longer build virtualbox,
>> > here is the error log:
>> > *Targets (2): virtualbox-4.1.16-1
>> > virtualbox-modules-4.1.16-2
>> >
>> > Total Installed Size: 66.86 MiB
>> >
>> > Proceed with installation? [Y/n] y
>> > (0/2) checking package integrity (1/2) checking package
>> > integrity (2/2) checking package integrity
>> > (0/2) loading package files (1/2) loading package
>> > files (2/2) loading package files
>> > (0/2) checking for file conflicts (1/2) checking for file
>> > conflicts (2/2) checking for file conflicts
>> > error: failed to commit transaction (conflicting files)
>> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxdrv.ko.gz
>> exists
>> > in filesystem
>> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxnetadp.ko.gz
>> > exists in filesystem
>> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxnetflt.ko.gz
>> > exists in filesystem
>> > virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxpci.ko.gz
>> exists
>> > in filesystem
>> > Errors occurred, no packages were upgraded.*
>> >
>> > Can I move those files?
>> >
>> > Regards,
>> > Victor
>>
>> did you build the modules manually before ?
>>
>> you could fix your problem by issuing:
>> pacman -Sf virtualbox-modules
>>
>> --Ike
>>
> Guys thanks a lot for the insigths your tips did the trick. I could not
> look on the forums befor as my system got mangled by the last kernel update
> and just now I was able to get an X server and internet running again.
>
> Regards,
> Victor
>

I'm back to the issues:

VirtualBox is not currently allowed to access USB devices. You can change
this by allowing your user to access the 'usbfs' folder and files. Please
see the user manual for a more detailed explanation.

Still looking on the manual. Anyone got a quick fix?
 
Old 06-16-2012, 10:02 PM
Victor Silva
 
Default Virtual Box Update Fails

2012/6/16 Ionut Biru <ibiru@archlinux.org>

> On 06/16/2012 11:10 PM, Victor Silva wrote:
> > 2012/6/16 Victor Silva <vfbsilva@gmail.com>
> >
> >>
> >>
> >> 2012/6/16 Ike Devolder <ike.devolder@gmail.com>
> >>
> >>> Op zaterdag 16 juni 2012 13:36:17 schreef Victor Silva:
> >>>> Folks with the last kernel I can no longer build virtualbox,
> >>>> here is the error log:
> >>>> *Targets (2): virtualbox-4.1.16-1
> >>>> virtualbox-modules-4.1.16-2
> >>>>
> >>>> Total Installed Size: 66.86 MiB
> >>>>
> >>>> Proceed with installation? [Y/n] y
> >>>> (0/2) checking package integrity (1/2) checking package
> >>>> integrity (2/2) checking package integrity
> >>>> (0/2) loading package files (1/2) loading package
> >>>> files (2/2) loading package files
> >>>> (0/2) checking for file conflicts (1/2) checking for file
> >>>> conflicts (2/2) checking for file conflicts
> >>>> error: failed to commit transaction (conflicting files)
> >>>> virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxdrv.ko.gz
> >>> exists
> >>>> in filesystem
> >>>> virtualbox-modules:
> /lib/modules/extramodules-3.4-ARCH/vboxnetadp.ko.gz
> >>>> exists in filesystem
> >>>> virtualbox-modules:
> /lib/modules/extramodules-3.4-ARCH/vboxnetflt.ko.gz
> >>>> exists in filesystem
> >>>> virtualbox-modules: /lib/modules/extramodules-3.4-ARCH/vboxpci.ko.gz
> >>> exists
> >>>> in filesystem
> >>>> Errors occurred, no packages were upgraded.*
> >>>>
> >>>> Can I move those files?
> >>>>
> >>>> Regards,
> >>>> Victor
> >>>
> >>> did you build the modules manually before ?
> >>>
> >>> you could fix your problem by issuing:
> >>> pacman -Sf virtualbox-modules
> >>>
> >>> --Ike
> >>>
> >> Guys thanks a lot for the insigths your tips did the trick. I could not
> >> look on the forums befor as my system got mangled by the last kernel
> update
> >> and just now I was able to get an X server and internet running again.
> >>
> >> Regards,
> >> Victor
> >>
> >
> > I'm back to the issues:
> >
> > VirtualBox is not currently allowed to access USB devices. You can
> change
> > this by allowing your user to access the 'usbfs' folder and files. Please
> > see the user manual for a more detailed explanation.
> >
> > Still looking on the manual. Anyone got a quick fix?
> >
>
> add your user to vboxusers group, relogin and that's it.
>
> --
> IonuČ›
>

That did the trick thanks a lot!
 

Thread Tools




All times are GMT. The time now is 04:34 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org