FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 05-29-2012, 06:26 PM
 
Default cups 1.5.3-3 requires gs

It does not seem to be documented (e.g. pacman -Qi cups) but cups 1.5.3-3
requires ghostscript to be installed. This is a change for some of us who
had not otherwise needed ghostscript. FYI

T.
 
Old 05-29-2012, 06:48 PM
Leonid Isaev
 
Default cups 1.5.3-3 requires gs

On Tue, 29 May 2012 13:26:02 -0500
rara8avis@aol.com wrote:

> It does not seem to be documented (e.g. pacman -Qi cups) but cups 1.5.3-3
> requires ghostscript to be installed. This is a change for some of us who
> had not otherwise needed ghostscript. FYI
>
> T.
>

cups-filters optionally depends on ghostscript (just as cups 1.5.3-2 did).

--
Leonid Isaev
GnuPG key: 0x164B5A6D
Fingerprint: C0DF 20D0 C075 C3F1 E1BE 775A A7AE F6CB 164B 5A6D
 
Old 05-29-2012, 07:05 PM
 
Default cups 1.5.3-3 requires gs

On Tue, May 29, 2012 at 01:48:24PM -0500, Leonid Isaev wrote:
> On Tue, 29 May 2012 13:26:02 -0500
> rara8avis@aol.com wrote:
>
> > It does not seem to be documented (e.g. pacman -Qi cups) but cups 1.5.3-3
> > requires ghostscript to be installed. This is a change for some of us who
> > had not otherwise needed ghostscript. FYI
> >
> > T.
> >
>
> cups-filters optionally depends on ghostscript (just as cups 1.5.3-2 did).
>
This is not an optional dependance that I am talking about. When I tried
to print from libreoffice via cups 1.5.3-3, cups failed because it called
gs but I had no ghostscript installed. After installed gs, I print easily.
So my experience is that gs is now a necessity to print through cups.

T.
 
Old 05-29-2012, 07:59 PM
Andreas Radke
 
Default cups 1.5.3-3 requires gs

Am Tue, 29 May 2012 14:05:28 -0500
schrieb rara8avis@aol.com:

> On Tue, May 29, 2012 at 01:48:24PM -0500, Leonid Isaev wrote:
> > On Tue, 29 May 2012 13:26:02 -0500
> > rara8avis@aol.com wrote:
> >
> > > It does not seem to be documented (e.g. pacman -Qi cups) but cups
> > > 1.5.3-3 requires ghostscript to be installed. This is a change
> > > for some of us who had not otherwise needed ghostscript. FYI
> > >
> > > T.
> > >
> >
> > cups-filters optionally depends on ghostscript (just as cups
> > 1.5.3-2 did).
> >
> This is not an optional dependance that I am talking about. When I
> tried to print from libreoffice via cups 1.5.3-3, cups failed because
> it called gs but I had no ghostscript installed. After installed gs,
> I print easily. So my experience is that gs is now a necessity to
> print through cups.
>
> T.
>

Ghostscript should only be needed if your printer is not
capable to print PostScript directly. So it was in the past with pure
cups. That's also what cups-filters README says. Maybe you have to
(re)choose your driver now or try a different one.

-Andy
 
Old 05-29-2012, 08:54 PM
 
Default cups 1.5.3-3 requires gs

On Tue, May 29, 2012 at 09:59:44PM +0200, Andreas Radke wrote:
> Am Tue, 29 May 2012 14:05:28 -0500
> schrieb rara8avis@aol.com:
>
> > On Tue, May 29, 2012 at 01:48:24PM -0500, Leonid Isaev wrote:
> > > On Tue, 29 May 2012 13:26:02 -0500
> > > rara8avis@aol.com wrote:
> > >
> > > > It does not seem to be documented (e.g. pacman -Qi cups) but cups
> > > > 1.5.3-3 requires ghostscript to be installed. This is a change
> > > > for some of us who had not otherwise needed ghostscript. FYI
> > > >
> > > > T.
> > > >
> > >
> > > cups-filters optionally depends on ghostscript (just as cups
> > > 1.5.3-2 did).
> > >
> > This is not an optional dependance that I am talking about. When I
> > tried to print from libreoffice via cups 1.5.3-3, cups failed because
> > it called gs but I had no ghostscript installed. After installed gs,
> > I print easily. So my experience is that gs is now a necessity to
> > print through cups.
> >
> > T.
> >
>
> Ghostscript should only be needed if your printer is not
> capable to print PostScript directly. So it was in the past with pure
> cups. That's also what cups-filters README says. Maybe you have to
> (re)choose your driver now or try a different one.
>
> -Andy

Thanks. I have used the ppd file from Brother for years, which, as I
understand it, includes a ps emulation. Cups-filters is new with me as of
today and seems to be what requires gs. Oddly, the log shows gs is called
and then deactivated; so its installation is required (cups quits without
gs) but ultimately not used. I reselected the driver in the frontend to
cups but that didn't change the gs requirement. It would be nice not to
install unneeded software.

T.
 
Old 05-29-2012, 09:10 PM
Leonid Isaev
 
Default cups 1.5.3-3 requires gs

On Tue, 29 May 2012 14:05:28 -0500
rara8avis@aol.com wrote:

> On Tue, May 29, 2012 at 01:48:24PM -0500, Leonid Isaev wrote:
> > On Tue, 29 May 2012 13:26:02 -0500
> > rara8avis@aol.com wrote:
> >
> > > It does not seem to be documented (e.g. pacman -Qi cups) but cups 1.5.3-3
> > > requires ghostscript to be installed. This is a change for some of us
> > > who had not otherwise needed ghostscript. FYI
> > >
> > > T.
> > >
> >
> > cups-filters optionally depends on ghostscript (just as cups 1.5.3-2 did).
> >
> This is not an optional dependance that I am talking about. When I tried
> to print from libreoffice via cups 1.5.3-3, cups failed because it called
> gs but I had no ghostscript installed. After installed gs, I print easily.
> So my experience is that gs is now a necessity to print through cups.
>
> T.
>

I don't know how exactly LO submits print jobs (odt/doc -> pdf/ps?), but I am
surprised you didn't need gs before. However, the only change in cups is just
a reallocation of filters and a rebuild against new poppler, which I think is
to blame...

--
Leonid Isaev
GnuPG key: 0x164B5A6D
Fingerprint: C0DF 20D0 C075 C3F1 E1BE 775A A7AE F6CB 164B 5A6D
 
Old 05-29-2012, 09:39 PM
 
Default cups 1.5.3-3 requires gs

On Tue, May 29, 2012 at 04:10:35PM -0500, Leonid Isaev wrote:
> On Tue, 29 May 2012 14:05:28 -0500
> rara8avis@aol.com wrote:
>
> > On Tue, May 29, 2012 at 01:48:24PM -0500, Leonid Isaev wrote:
> > > On Tue, 29 May 2012 13:26:02 -0500
> > > rara8avis@aol.com wrote:
> > >
> > > > It does not seem to be documented (e.g. pacman -Qi cups) but cups 1.5.3-3
> > > > requires ghostscript to be installed. This is a change for some of us
> > > > who had not otherwise needed ghostscript. FYI
> > > >
> > > > T.
> > > >
> > >
> > > cups-filters optionally depends on ghostscript (just as cups 1.5.3-2 did).
> > >
> > This is not an optional dependance that I am talking about. When I tried
> > to print from libreoffice via cups 1.5.3-3, cups failed because it called
> > gs but I had no ghostscript installed. After installed gs, I print easily.
> > So my experience is that gs is now a necessity to print through cups.
> >
> > T.
> >
>
> I don't know how exactly LO submits print jobs (odt/doc -> pdf/ps?), but I am
> surprised you didn't need gs before. However, the only change in cups is just
> a reallocation of filters and a rebuild against new poppler, which I think is
> to blame...
>
> --
> Leonid Isaev
> GnuPG key: 0x164B5A6D
> Fingerprint: C0DF 20D0 C075 C3F1 E1BE 775A A7AE F6CB 164B 5A6D

There may be something to that: two weeks ago I somehow got hold of poppler
20.1 and printing stopped from LO though I could print from the command
prompt. When I fell back to poppler 18.4-2 then I could print fine. Once
again I'm up to poppler 20.1 with the cups update and cups-filters.
Thanks.
 

Thread Tools




All times are GMT. The time now is 07:10 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org