FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 05-29-2012, 11:38 AM
Jelle van der Waa
 
Default TK related GUI program run VERY slow, any idea?

On Tue, May 29, 2012 at 1:11 PM, <goodmenzy@gmail.com> wrote:

> Hi, all
>
> I found that on my arch (64bit), GUI program which use TK lib runs versy
> slow,
> and it also suspend the KDE for a long time to response to the keyboard.
>
> I found that when those program begin, the hard disk LED blink many many
> times.
>
> The example of that program is amsn and gitk.
>
> Any one have the same phenomena? or anyone have some idea about it?
>
>
> TK package version is 8.5.11-1, seems the most recently version.
>
> Thanks for any response!
>
> Gitk works fine for me, although my own repo can be a bit small for a
comparison test. So can you figure out if the problems are I/O bound or CPU?
Are you loading a big ~2Gb repo with gitk or just a small one?

--
Jelle van der Waa
 
Old 05-29-2012, 02:02 PM
Brock Zheng
 
Default TK related GUI program run VERY slow, any idea?

On 2012-05-29 13:38:06, Jelle van der Waa wrote:
> Date: Tue, 29 May 2012 13:38:06 +0200
> From: Jelle van der Waa <jelle@vdwaa.nl>
> To: General Discussion about Arch Linux <arch-general@archlinux.org>
> Subject: Re: [arch-general] TK related GUI program run VERY slow, any idea?
>
> On Tue, May 29, 2012 at 1:11 PM, <goodmenzy@gmail.com> wrote:
>
> > Hi, all
> >
> > I found that on my arch (64bit), GUI program which use TK lib runs versy
> > slow,
> > and it also suspend the KDE for a long time to response to the keyboard.
> >
> > I found that when those program begin, the hard disk LED blink many many
> > times.
> >
> > The example of that program is amsn and gitk.
> >
> > Any one have the same phenomena? or anyone have some idea about it?
> >
> >
> > TK package version is 8.5.11-1, seems the most recently version.
> >
> > Thanks for any response!
> >
> > Gitk works fine for me, although my own repo can be a bit small for a
> comparison test. So can you figure out if the problems are I/O bound or CPU?
> Are you loading a big ~2Gb repo with gitk or just a small one?
Just a small one --- several kb source code.
I think it has nothing todo with the GIT, it is something about TK lib.
aMSN and other GUI program using TK runs very slow, and seems they are torture
my harddisk. When starting, the keyboard nearly lost response to other programs....

>
> --
> Jelle van der Waa

--
Brock Zheng <goodmenzy@gmail.com>
郑 祎

Software Enginner
GnuPG key ID : 90C99215
GnuPg key fpr : EF09 4CD7 A64A 1034 4C6C 0078 EC76 1286 90C9 9215
Key Server : http://pgp.mit.edu
 
Old 05-29-2012, 10:00 PM
Martti Khne
 
Default TK related GUI program run VERY slow, any idea?

On Tue, May 29, 2012 at 10:02:40PM +0800, Brock Zheng wrote:
> > Are you loading a big ~2Gb repo with gitk or just a small one?
> Just a small one --- several kb source code.
> I think it has nothing todo with the GIT, it is something about TK lib.
> aMSN and other GUI program using TK runs very slow, and seems they are torture
> my harddisk. When starting, the keyboard nearly lost response to other programs....
>

you should be able to catch stuff like this with strace and kernel.log.
btw, do you have a swap partition on said "tortured" drive?

let's see if I can test in the next couple of days...

cheers!
mar77i
 
Old 05-30-2012, 12:31 AM
 
Default TK related GUI program run VERY slow, any idea?

Thanks for your kindness reply!

I'm almost sure that it is not the swap partition's problem.
My KDE runs prefectly, but when any GUI program which use TK library starts,
the hard disk will keep busy for VERY long time, and the keyboard can not input
into other program for a long time. When the TK related GUI program initialization
finished, It runs ok, except the same thing occurs when it pop up any diaglogs (for
example, aMSN automatically pop up a notice box when a new friend appear online).

I have not log info currently. And it needs some time to get more info about it...



On 2012-05-30 00:00:31, Martti K黨ne wrote:
> Date: Wed, 30 May 2012 00:00:31 +0200
> From: Martti K黨ne <mysatyre@gmail.com>
> To: General Discussion about Arch Linux <arch-general@archlinux.org>
> Subject: Re: [arch-general] TK related GUI program run VERY slow, any idea?
> User-Agent: Mutt/1.5.21 (2010-09-15)
>
> On Tue, May 29, 2012 at 10:02:40PM +0800, Brock Zheng wrote:
> > > Are you loading a big ~2Gb repo with gitk or just a small one?
> > Just a small one --- several kb source code.
> > I think it has nothing todo with the GIT, it is something about TK lib.
> > aMSN and other GUI program using TK runs very slow, and seems they are torture
> > my harddisk. When starting, the keyboard nearly lost response to other programs....
> >
>
> you should be able to catch stuff like this with strace and kernel.log.
> btw, do you have a swap partition on said "tortured" drive?
>
> let's see if I can test in the next couple of days...
>
> cheers!
> mar77i
 
Old 05-30-2012, 02:51 AM
Patrick Burroughs
 
Default TK related GUI program run VERY slow, any idea?

On Tue, May 29, 2012 at 5:31 PM, <goodmenzy@gmail.com> wrote:
> Thanks for your kindness reply!
>
> I'm *almost sure that it is not the swap partition's problem.
> My KDE runs prefectly, but when any GUI program which use TK library starts,
> the hard disk will keep busy for VERY long time, and the keyboard can not input
> into other program for a long time. When the TK related GUI program initialization
> finished, It runs ok, except the same thing occurs when it pop up any diaglogs (for
> example, aMSN automatically pop up a notice box when a new friend appear online).
>
> I have not log info currently. And it needs some time to get more info about it...

This might be a long shot, but could you have an environment variable
or something set that's triggering a debug state? Maybe lots of
logfile writing?

~Celti
 
Old 05-30-2012, 12:04 PM
 
Default TK related GUI program run VERY slow, any idea?

Hi, all the Kindly friends

Here is another new discover:

I run aMSN remotely. That is to say, I use xhost cmd to allow some remote machine can use my laptop
as the X11 server, and one the remote machine, setup DISPLAY environment variable correctly.

When run, The X11 server machine's hard disk begin to blink endless and the keyboard lost respones.

I had use strace to hacking the problem. and found that when it happen, the program is in poll.
The fd param of poll is a socket. Locally and remotely run the TK related program, the FD is created
differently:

local running is
socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC, 0) = 5

remote running is
socket(PF_INET, SOCK_STREAM|SOCK_CLOEXEC, IPPROTO_TCP) = 5

And that is right I think. X11 protocal should run on the most fast way it found.


Now, I can say that: This problem is something related to the TK and X11 library.
It has nothing to do with the GUI program's function ---- no git repo problems(when run gitk ), nor
networks problems( when run amsn ).

More testing should be done, But I can't spend too many time on this. By far, the company
can not allow me to hacking the linux system all day and all night......

Does anyone has any other GUI program that using TK library?
We can try more softwares.....


On 2012-05-29 19:51:42, Patrick Burroughs wrote:
> Date: Tue, 29 May 2012 19:51:42 -0700
> From: Patrick Burroughs <celticmadman@gmail.com>
> To: General Discussion about Arch Linux <arch-general@archlinux.org>
> Subject: Re: [arch-general] TK related GUI program run VERY slow, any idea?
>
> On Tue, May 29, 2012 at 5:31 PM, <goodmenzy@gmail.com> wrote:
> > Thanks for your kindness reply!
> >
> > I'm *almost sure that it is not the swap partition's problem.
> > My KDE runs prefectly, but when any GUI program which use TK library starts,
> > the hard disk will keep busy for VERY long time, and the keyboard can not input
> > into other program for a long time. When the TK related GUI program initialization
> > finished, It runs ok, except the same thing occurs when it pop up any diaglogs (for
> > example, aMSN automatically pop up a notice box when a new friend appear online).
> >
> > I have not log info currently. And it needs some time to get more info about it...
>
> This might be a long shot, but could you have an environment variable
> or something set that's triggering a debug state? Maybe lots of
> logfile writing?
>
> ~Celti
 
Old 05-30-2012, 12:06 PM
 
Default TK related GUI program run VERY slow, any idea?

Hi, all the Kindly friends

Here is another new discover:

I run aMSN remotely. That is to say, I use xhost cmd to allow some remote machine can use my laptop
as the X11 server, and one the remote machine, setup DISPLAY environment variable correctly.

When run, The X11 server machine's hard disk begin to blink endless and the keyboard lost respones.

I had use strace to hacking the problem. and found that when it happen, the program is in poll.
The fd param of poll is a socket. Locally and remotely run the TK related program, the FD is created
differently:

local running is
socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC, 0) = 5

remote running is
socket(PF_INET, SOCK_STREAM|SOCK_CLOEXEC, IPPROTO_TCP) = 5

And that is right I think. X11 protocal should run on the most fast way it found.


Now, I can say that: This problem is something related to the TK and X11 library.
It has nothing to do with the GUI program's function ---- no git repo problems(when run gitk ), nor
networks problems( when run amsn ).

More testing should be done, But I can't spend too many time on this. By far, the company
can not allow me to hacking the linux system all day and all night......

Does anyone has any other GUI program that using TK library?
We can try more softwares.....


On 2012-05-29 19:51:42, Patrick Burroughs wrote:
> Date: Tue, 29 May 2012 19:51:42 -0700
> From: Patrick Burroughs <celticmadman@gmail.com>
> To: General Discussion about Arch Linux <arch-general@archlinux.org>
> Subject: Re: [arch-general] TK related GUI program run VERY slow, any idea?
>
> On Tue, May 29, 2012 at 5:31 PM, <goodmenzy@gmail.com> wrote:
> > Thanks for your kindness reply!
> >
> > I'm 燼lmost sure that it is not the swap partition's problem.
> > My KDE runs prefectly, but when any GUI program which use TK library starts,
> > the hard disk will keep busy for VERY long time, and the keyboard can not input
> > into other program for a long time. When the TK related GUI program initialization
> > finished, It runs ok, except the same thing occurs when it pop up any diaglogs (for
> > example, aMSN automatically pop up a notice box when a new friend appear online).
> >
> > I have not log info currently. And it needs some time to get more info about it...
>
> This might be a long shot, but could you have an environment variable
> or something set that's triggering a debug state? Maybe lots of
> logfile writing?
>
> ~Celti
 

Thread Tools




All times are GMT. The time now is 10:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org