FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 05-13-2012, 07:52 AM
Arno Gaboury
 
Default broken zip after upgrade

Dear list,

after a whole bunch of fresh upgrades yesterday, 2012/05/12, I can not
unzip with File Roller (default app), with expanding tar.gz still working.


Here are the two error messages:

*/There is no command installed for Zip archive files.
Do you want to search for a command to open this file?/*

Then I click on search command button, it brings a new window:

*/There was an internal error trying to search for applications:
GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnkn own: The name
org.freedesktop.PackageKit was not provided by any .service files/*



I have no certitude, but I suspect the outdated polkit 0.104 could be
the culprit.


There is a new 0.105 version since a few weeks on the website:
http://cgit.freedesktop.org/polkit/snapshot/polkit-0.105.tar.gz

Following instructions, I was able to build it fine, but I don't want to
make install on my system, as I understand it is a good way to break it.


I decided to create a package following the Archwiki.

Here is my PKGBUILD file :

/*# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>

pkgname=polkit
pkgver=0.105
pkgrel=2
pkgdesc="Application development toolkit for controlling system-wide
privileges"

arch=(i686 x86_64)
license=('LGPL')
url="http://www.freedesktop.org/wiki/Software/PolicyKit"
depends=('glib2' 'pam' 'expat')
makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
replaces=('policykit')
options=('!libtool')
source=(http://cgit.freedesktop.org/polkit/snapshot/$pkgname-$pkgver.tar.gz)

md5sums=('ad070a194d444fa89f627fd54a124fad')

build() {
cd $pkgname-$pkgver
autoconf
./autogen.sh
make
}

check() {
cd $pkgname-$pkgver
make -k check
}

package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install

install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
}*/

I corrected the old 0.104 one according to the new changes. I have
problem with md5sums, and have no real idea how to write the numbers.

makepkg returns an error :

/*Validating source files with md5sums...
polkit-0.105.tar.gz ... FAILED*/


So 2 questions :
how to deal with this md5sums error?
Once this issue is solved, can I makepkg and install on my system,
whitout breaking anything?


TY for any help.
 
Old 05-13-2012, 09:07 AM
gt
 
Default broken zip after upgrade

On Sun, May 13, 2012 at 09:52:54AM +0200, Arno Gaboury wrote:
> Dear list,
>
> after a whole bunch of fresh upgrades yesterday, 2012/05/12, I can
> not unzip with File Roller (default app), with expanding tar.gz
> still working.
>
> Here are the two error messages:
>
> */There is no command installed for Zip archive files.
> Do you want to search for a command to open this file?/*
>
> Then I click on search command button, it brings a new window:
>
> */There was an internal error trying to search for applications:
> GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnkn own: The name
> org.freedesktop.PackageKit was not provided by any .service files/*
>
>
> I have no certitude, but I suspect the outdated polkit 0.104 could
> be the culprit.
>
> There is a new 0.105 version since a few weeks on the website:
> http://cgit.freedesktop.org/polkit/snapshot/polkit-0.105.tar.gz
>
> Following instructions, I was able to build it fine, but I don't
> want to make install on my system, as I understand it is a good way
> to break it.
>
> I decided to create a package following the Archwiki.
>
> Here is my PKGBUILD file :
>
> /*# $Id$
> # Maintainer: Jan de Groot <jgc@archlinux.org>
>
> pkgname=polkit
> pkgver=0.105
> pkgrel=2
> pkgdesc="Application development toolkit for controlling system-wide
> privileges"
> arch=(i686 x86_64)
> license=('LGPL')
> url="http://www.freedesktop.org/wiki/Software/PolicyKit"
> depends=('glib2' 'pam' 'expat')
> makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
> replaces=('policykit')
> options=('!libtool')
> source=(http://cgit.freedesktop.org/polkit/snapshot/$pkgname-$pkgver.tar.gz)
>
> md5sums=('ad070a194d444fa89f627fd54a124fad')
>
> build() {
> cd $pkgname-$pkgver
> autoconf
> ./autogen.sh
> make
> }
>
> check() {
> cd $pkgname-$pkgver
> make -k check
> }
>
> package() {
> cd $pkgname-$pkgver
> make DESTDIR="$pkgdir" install
>
> install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
> }*/
>
> I corrected the old 0.104 one according to the new changes. I have
> problem with md5sums, and have no real idea how to write the
> numbers.
> makepkg returns an error :
>
> /*Validating source files with md5sums...
> polkit-0.105.tar.gz ... FAILED*/
>
>
> So 2 questions :
> how to deal with this md5sums error?
> Once this issue is solved, can I makepkg and install on my system,
> whitout breaking anything?

You can temporarily skip the md5sum check using

$ makepkg --skipinteg
 
Old 05-13-2012, 09:17 AM
rafael ff1
 
Default broken zip after upgrade

2012/5/13 Arno Gaboury <arnaud.gaboury@gmail.com>:
> Dear list,
>
> after a whole bunch of fresh upgrades yesterday, 2012/05/12, I can not unzip
> with File Roller (default app), with expanding tar.gz still working.
>
> Here are the two error messages:
>
> */There is no command installed for Zip archive files.
> Do you want to search for a command to open this file?/*

Do you have the packages 'zip' and 'unzip' installed ?

> Then I click on search command button, it brings a new window:
>
> */There was an internal error trying to search for applications:
> GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnkn own: The name
> org.freedesktop.PackageKit was not provided by any .service files/*
>
>
> I have no certitude, but I suspect the outdated polkit 0.104 could be the
> culprit.
>
> There is a new 0.105 version since a few weeks on the website:
> http://cgit.freedesktop.org/polkit/snapshot/polkit-0.105.tar.gz
>
> Following instructions, I was able to build it fine, but I don't want to
> make install on my system, as I understand it is a good way to break it.
>
> I decided to create a package following the Archwiki.
>
> Here is my PKGBUILD file :
>
> /*# $Id$
> # Maintainer: Jan de Groot <jgc@archlinux.org>
>
> pkgname=polkit
> pkgver=0.105
> pkgrel=2
> pkgdesc="Application development toolkit for controlling system-wide
> privileges"
> arch=(i686 x86_64)
> license=('LGPL')
> url="http://www.freedesktop.org/wiki/Software/PolicyKit"
> depends=('glib2' 'pam' 'expat')
> makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
> replaces=('policykit')
> options=('!libtool')
> source=(http://cgit.freedesktop.org/polkit/snapshot/$pkgname-$pkgver.tar.gz)
>
> md5sums=('ad070a194d444fa89f627fd54a124fad')
>
> build() {
> *cd $pkgname-$pkgver
> *autoconf
> *./autogen.sh
> *make
> }
>
> check() {
> *cd $pkgname-$pkgver
> *make -k check
> }
>
> package() {
> *cd $pkgname-$pkgver
> *make DESTDIR="$pkgdir" install
>
> *install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
> }*/
>
> I corrected the old 0.104 one according to the new changes. I have problem
> with md5sums, and have no real idea how to write the numbers.
> makepkg returns an error :
>
> /*Validating source files with md5sums...
> * *polkit-0.105.tar.gz ... FAILED*/
>
>
> So 2 questions :
> *how to deal with this md5sums error?
> Once this issue is solved, can I makepkg and install on my system, whitout
> breaking anything?
>
> TY for any help.
>
>
>

Get the md5sum and replace in your PKGBUILD. You can do this with
'md5sum' or makepkg -g'.

$ md5sum polkit-0.105.tar.gz
53f22a353f46abc710d5992efbe2b3a3 polkit-0.105.tar.gz

$ makepkg -g
==> Retrieving Sources...
-> Found polkit-0.105.tar.gz
-> Found polkit.pam
==> Generating checksums for source files...

md5sums=('53f22a353f46abc710d5992efbe2b3a3')
 
Old 05-13-2012, 09:46 AM
Mauro Santos
 
Default broken zip after upgrade

On 13-05-2012 08:52, Arno Gaboury wrote:
> Dear list,
>
> after a whole bunch of fresh upgrades yesterday, 2012/05/12, I can not
> unzip with File Roller (default app), with expanding tar.gz still working.
>
> Here are the two error messages:
>
> */There is no command installed for Zip archive files.
> Do you want to search for a command to open this file?/*
>
> Then I click on search command button, it brings a new window:
>
> */There was an internal error trying to search for applications:
> GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnkn own: The name
> org.freedesktop.PackageKit was not provided by any .service files/*
>


File Roller and zips work just fine here and as far as I know polkit has
nothing to do with extracting compressed archives, your problem is
somewhere else. Your hint should be the message "There is no command
installed for Zip archive files." so you want to install zip and unzip
and leave polkit alone.


--
Mauro Santos
 
Old 05-13-2012, 11:02 AM
Arno Gaboury
 
Default broken zip after upgrade

On 05/13/2012 11:17 AM, rafael ff1 wrote:

2012/5/13 Arno Gaboury<arnaud.gaboury@gmail.com>:

Dear list,

after a whole bunch of fresh upgrades yesterday, 2012/05/12, I can not unzip
with File Roller (default app), with expanding tar.gz still working.

Here are the two error messages:

*/There is no command installed for Zip archive files.
Do you want to search for a command to open this file?/*

Do you have the packages 'zip' and 'unzip' installed ?


Then I click on search command button, it brings a new window:

*/There was an internal error trying to search for applications:
GDBus.Errorrg.freedesktop.DBus.Error.ServiceUnkn own: The name
org.freedesktop.PackageKit was not provided by any .service files/*


I have no certitude, but I suspect the outdated polkit 0.104 could be the
culprit.

There is a new 0.105 version since a few weeks on the website:
http://cgit.freedesktop.org/polkit/snapshot/polkit-0.105.tar.gz

Following instructions, I was able to build it fine, but I don't want to
make install on my system, as I understand it is a good way to break it.

I decided to create a package following the Archwiki.

Here is my PKGBUILD file :

/*# $Id$
# Maintainer: Jan de Groot<jgc@archlinux.org>

pkgname=polkit
pkgver=0.105
pkgrel=2
pkgdesc="Application development toolkit for controlling system-wide
privileges"
arch=(i686 x86_64)
license=('LGPL')
url="http://www.freedesktop.org/wiki/Software/PolicyKit"
depends=('glib2' 'pam' 'expat')
makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
replaces=('policykit')
options=('!libtool')
source=(http://cgit.freedesktop.org/polkit/snapshot/$pkgname-$pkgver.tar.gz)

md5sums=('ad070a194d444fa89f627fd54a124fad')

build() {
cd $pkgname-$pkgver
autoconf
./autogen.sh
make
}

check() {
cd $pkgname-$pkgver
make -k check
}

package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install

install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
}*/

I corrected the old 0.104 one according to the new changes. I have problem
with md5sums, and have no real idea how to write the numbers.
makepkg returns an error :

/*Validating source files with md5sums...
polkit-0.105.tar.gz ... FAILED*/


So 2 questions :
how to deal with this md5sums error?
Once this issue is solved, can I makepkg and install on my system, whitout
breaking anything?

TY for any help.




Get the md5sum and replace in your PKGBUILD. You can do this with
'md5sum' or makepkg -g'.

$ md5sum polkit-0.105.tar.gz
53f22a353f46abc710d5992efbe2b3a3 polkit-0.105.tar.gz

$ makepkg -g
==> Retrieving Sources...
-> Found polkit-0.105.tar.gz
-> Found polkit.pam
==> Generating checksums for source files...

md5sums=('53f22a353f46abc710d5992efbe2b3a3')


********************************

File Roller and zips work just fine here and as far as I know polkit has
nothing to do with extracting compressed archives, your problem is
somewhere else. Your hint should be the message "There is no command
installed for Zip archive files." so you want to install zip and unzip
and leave polkit alone.


*********************************

TY for answers. Will try everything asap.

As for zip and unzip, I have been able to unzip for months before the upgrade, so my first guess was the issue doesn't come from this side.

As for md5sums, let's say I manage to solve this part of PKGBUILD. Just for academic puprose, once PKGBUILD is tested suceessfully, is it sage to install this package this way?

TY.
 
Old 05-13-2012, 12:36 PM
rafael ff1
 
Default broken zip after upgrade

2012/5/13 Arno Gaboury <arnaud.gaboury@gmail.com>:
>
> TY for answers. Will try everything asap.
>
> As for zip and unzip, I have been able to unzip for months before the
> upgrade, so my first guess was the issue doesn't come from this side.
>

But can you use them now? Double check that you have them installed,
using 'pacman -Q zip unzip'. You could have it removed by accident -
it happens.

> As for md5sums, let's say I manage to solve this part of PKGBUILD. Just for
> academic puprose, once PKGBUILD is tested suceessfully, is it sage to
> install this package this way?
>
> TY.
>

Try it out. If something go wrong or nothing happen, you always can
remove and reinstall polkit from repository.

Rafael
 
Old 05-13-2012, 07:24 PM
Arno Gaboury
 
Default broken zip after upgrade

On 05/13/2012 02:36 PM, rafael ff1 wrote:

2012/5/13 Arno Gaboury<arnaud.gaboury@gmail.com>:

TY for answers. Will try everything asap.

As for zip and unzip, I have been able to unzip for months before the
upgrade, so my first guess was the issue doesn't come from this side.


But can you use them now? Double check that you have them installed,
using 'pacman -Q zip unzip'. You could have it removed by accident -
it happens.


As for md5sums, let's say I manage to solve this part of PKGBUILD. Just for
academic puprose, once PKGBUILD is tested suceessfully, is it sage to
install this package this way?

TY.


Try it out. If something go wrong or nothing happen, you always can
remove and reinstall polkit from repository.

Rafael

Shame on me, so obvious:

/*[gabx@magnolia Desktop]$ pacman -Q zip unzip
zip 3.0-3
error: package 'unzip' was not found*/


No idea how I deleted this package!!

BTW, I learned with polkit 0.105 how to create a package.
 

Thread Tools




All times are GMT. The time now is 09:30 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org