FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 05-01-2012, 07:08 PM
Norbert Zeh
 
Default PKGBUILD "provides" not handled correctly?

Hi folks,

I have just run into a weird problem. I have a machine that isn't too happy
with the 3.3.x kernel series. So I'm running linux-lts on it, but that one is
meant for servers, so isn't as responsive as one would like on a desktop system.
So I've decided to throw a little PKGBUILD together that compiles linux-lts with
CONFIG_HZ set to 1000 but is otherwise unchanged from the version in ABS.

To ensure this tweaked lts kernel does not get inadvertently overwritten by a
linux-lts upgrade, I've changed the package name in the PKGBUILD to
linux-lts-local. I've added "linux-lts" to the conflicts/provides/replaces
lists in the PKGBUILD to ensure that I do not install linux-lts and
linux-lts-local at the same time and to ensure that all packages that rely on
linux-lts continue to have their dependencies satisfied...or so I thought.

Compiling the tweaked lts kernel and installing this kernel instead of linux-lts
on my laptop with intel graphics works without problems. My office desktop is a
machine with an NVIDIA card and I'm using nvidia-lts as my graphics driver.
When trying to replace linux-lts with linux-lts-local using pacman -U, pacman
complains that nvidia-lts requires linux-lts>=3.0.0 and refuses to continue.
Now I'm confused: linux-lts-local provides linux-lts, and the version is
3.0.29-1. So why does pacman complain? Any pointers are much appreciated.

Cheers,
Norbert
 
Old 05-01-2012, 07:11 PM
Patrick Burroughs
 
Default PKGBUILD "provides" not handled correctly?

On Tue, May 1, 2012 at 12:08, Norbert Zeh <nzeh@cs.dal.ca> wrote:
> Now I'm confused: linux-lts-local provides linux-lts, and the version is
> 3.0.29-1. *So why does pacman complain? *Any pointers are much appreciated.

You need to provide a specific version of linux-lts, I believe. An
unversioned provides won't match a versioned dependency.

Try provides=(linux-lts=3.0.29)

~Celti
 
Old 05-01-2012, 07:29 PM
Martti Kühne
 
Default PKGBUILD "provides" not handled correctly?

On Tue, May 01, 2012 at 04:08:04PM -0300, Norbert Zeh wrote:
<snip>
> linux-lts-local. I've added "linux-lts" to the conflicts/provides/replaces

also, from man pkgbuild:
* replaces (array)
"Sysupgrade is currently the only pacman operation that utilizes this field. A
normal sync or upgrade will not use its value."

So, since aur packages usually find their way through -U into a user's system,
this is unnecessary.

cheers!
mar77i
 

Thread Tools




All times are GMT. The time now is 03:26 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org