FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 01-17-2012, 08:32 PM
Karol Blazewicz
 
Default Dependency: pyalpm: requires pacman<3.6 (workaround install pyalpm?)

On Tue, Jan 17, 2012 at 10:26 PM, David C. Rankin
<drankinatty@suddenlinkmail.com> wrote:
> David C. Rankin, J.D.,P.E.

This mail didn't make much sense to me untill the very last line ...

You can solve it in a number of ways e.g. remove pyalpm, update
pacman, update pyalpm if available:
https://bbs.archlinux.org/viewtopic.php?pid=1042280#p1042280
 
Old 01-17-2012, 09:20 PM
Pierre Schmitz
 
Default Dependency: pyalpm: requires pacman<3.6 (workaround install pyalpm?)

Am 17.01.2012 21:32, schrieb Karol Blazewicz:
> On Tue, Jan 17, 2012 at 10:26 PM, David C. Rankin
> <drankinatty@suddenlinkmail.com> wrote:
>> David C. Rankin, J.D.,P.E.
>
> This mail didn't make much sense to me untill the very last line ...
>
> You can solve it in a number of ways e.g. remove pyalpm, update
> pacman, update pyalpm if available:
> https://bbs.archlinux.org/viewtopic.php?pid=1042280#p1042280

The best way is to add pyalpm to SyncFirst in pacman.conf and just run
-Syu.

--
Pierre Schmitz, http://pierre-schmitz.com
 
Old 01-18-2012, 08:37 AM
Magnus Therning
 
Default Dependency: pyalpm: requires pacman<3.6 (workaround install pyalpm?)

On Tue, Jan 17, 2012 at 23:20, Pierre Schmitz <pierre@archlinux.de> wrote:
> Am 17.01.2012 21:32, schrieb Karol Blazewicz:
>> On Tue, Jan 17, 2012 at 10:26 PM, David C. Rankin
>> <drankinatty@suddenlinkmail.com> wrote:
>>> David C. Rankin, J.D.,P.E.
>>
>> This mail didn't make much sense to me untill the very last line ...
>>
>> You can solve it in a number of ways e.g. remove pyalpm, update
>> pacman, update pyalpm if available:
>> https://bbs.archlinux.org/viewtopic.php?pid=1042280#p1042280
>
> The best way is to add pyalpm to SyncFirst in pacman.conf and just run
> -Syu.

Wouldn't the best way be for pacman to not only consider updating the
packages listed in SyncFirst, but also all packages that prevent it
through it's dependencies?

/M

--
Magnus Therning * * * * * * * * * * *OpenPGP: 0xAB4DFBA4
email: magnus@therning.org * jabber: magnus@therning.org
twitter: magthe * * * * * * * http://therning.org/magnus
 
Old 01-18-2012, 01:46 PM
Thomas Bächler
 
Default Dependency: pyalpm: requires pacman<3.6 (workaround install pyalpm?)

Am 17.01.2012 23:20, schrieb Pierre Schmitz:
> Am 17.01.2012 21:32, schrieb Karol Blazewicz:
>> On Tue, Jan 17, 2012 at 10:26 PM, David C. Rankin
>> <drankinatty@suddenlinkmail.com> wrote:
>>> David C. Rankin, J.D.,P.E.
>>
>> This mail didn't make much sense to me untill the very last line ...
>>
>> You can solve it in a number of ways e.g. remove pyalpm, update
>> pacman, update pyalpm if available:
>> https://bbs.archlinux.org/viewtopic.php?pid=1042280#p1042280

It's a pacman 3.5 bug, no idea if it is solved in pacman 4.

> The best way is to add pyalpm to SyncFirst in pacman.conf and just run
> -Syu.

If I run into SyncFirst bugs, I always run
pacman -S pacman
Everything works fine then.
 
Old 01-18-2012, 01:54 PM
Magnus Therning
 
Default Dependency: pyalpm: requires pacman<3.6 (workaround install pyalpm?)

On Wed, Jan 18, 2012 at 15:46, Thomas Bächler <thomas@archlinux.org> wrote:
> Am 17.01.2012 23:20, schrieb Pierre Schmitz:
>> The best way is to add pyalpm to SyncFirst in pacman.conf and just run
>> -Syu.
>
> If I run into SyncFirst bugs, I always run
> *pacman -S pacman
> Everything works fine then.

Except of course that it didn't work in this case You'd need to
tell pacman to install pacman and ignore any dependencies of other
packages that would prevent an upgrade of pacman!

/M

--
Magnus Therning * * * * * * * * * * *OpenPGP: 0xAB4DFBA4
email: magnus@therning.org * jabber: magnus@therning.org
twitter: magthe * * * * * * * http://therning.org/magnus
 
Old 01-18-2012, 01:59 PM
Thomas Bächler
 
Default Dependency: pyalpm: requires pacman<3.6 (workaround install pyalpm?)

Am 18.01.2012 15:54, schrieb Magnus Therning:
> On Wed, Jan 18, 2012 at 15:46, Thomas Bächler <thomas@archlinux.org> wrote:
>> Am 17.01.2012 23:20, schrieb Pierre Schmitz:
>>> The best way is to add pyalpm to SyncFirst in pacman.conf and just run
>>> -Syu.
>>
>> If I run into SyncFirst bugs, I always run
>> pacman -S pacman
>> Everything works fine then.
>
> Except of course that it didn't work in this case You'd need to
> tell pacman to install pacman and ignore any dependencies of other
> packages that would prevent an upgrade of pacman!

In that case
pacman -S pacman pyalpm
helps.
 

Thread Tools




All times are GMT. The time now is 03:30 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org