FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 01-16-2012, 10:03 PM
朱格宏
 
Default I can't upgrade to pacman4

Hi,i found some problem when upgrade to pacman4
i use pacman -Syu and it told me
:: package-query: require pacman<3.6
but my pacman is 3.5.4-4,
how to slove it?
 
Old 01-16-2012, 10:05 PM
Karol Blazewicz
 
Default I can't upgrade to pacman4

2012/1/17 朱*宏 <zhugehonghn@gmail.com>:
> Hi,i found some problem when upgrade to pacman4
> i use pacman -Syu and it told me
> :: package-query: require pacman<3.6
> but my pacman is 3.5.4-4,
> how to slove it?

Update package-query.
You get the error because you're about to install a new version of
pacman, probable pacman 4.0.1-4.
 
Old 01-16-2012, 10:13 PM
Thomas Dziedzic
 
Default I can't upgrade to pacman4

On Mon, Jan 16, 2012 at 5:05 PM, Karol Blazewicz
<karol.blazewicz@gmail.com> wrote:
> 2012/1/17 朱*宏 <zhugehonghn@gmail.com>:
>> Hi,i found some problem when upgrade to pacman4
>> i use pacman -Syu and it told me
>> :: package-query: require pacman<3.6
>> but my pacman is 3.5.4-4,
>> how to slove it?
>
> Update package-query.
> You get the error because you're about to install a new version of
> pacman, probable pacman 4.0.1-4.

remove package-query and yaourt, update, install package-query and yaourt.
 
Old 01-16-2012, 10:21 PM
朱格宏
 
Default I can't upgrade to pacman4

于 2012年01月17日 07:13, Thomas Dziedzic 写道:

On Mon, Jan 16, 2012 at 5:05 PM, Karol Blazewicz
<karol.blazewicz@gmail.com> wrote:

2012/1/17 朱*宏<zhugehonghn@gmail.com>:

Hi,i found some problem when upgrade to pacman4
i use pacman -Syu and it told me
:: package-query: require pacman<3.6
but my pacman is 3.5.4-4,
how to slove it?

Update package-query.
You get the error because you're about to install a new version of
pacman, probable pacman 4.0.1-4.

remove package-query and yaourt, update, install package-query and yaourt.

It's OK ,Thanks
 
Old 01-18-2012, 01:49 AM
Diep Pham Van
 
Default I can't upgrade to pacman4

On Tue, 17 Jan 2012 07:03:38 +0800
朱*宏 <zhugehonghn@gmail.com> wrote:

> Hi,i found some problem when upgrade to pacman4
> i use pacman -Syu and it told me
> :: package-query: require pacman<3.6
> but my pacman is 3.5.4-4,
> how to slove it?

Do you use the archlinux.fr repo?
Remove package-query and rebuild it from AUR after upgrade.
 

Thread Tools




All times are GMT. The time now is 12:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org