FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 01-06-2012, 08:25 AM
Thomas Bächler
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

Am 06.01.2012 09:34, schrieb Ralf Madorf:
> regarding to the rt issues I followed the explanations at
> http://aur.archlinux.org/packages.php?ID=12132 .
> I still get an issues with
> http://aur.archlinux.org/packages.php?ID=32908 .
> It's not only the described problem. If I boot 3.1.7-1-Arch I get
> "nvidia: version magic '3.0-rt' should be '3.1.7-1-ARCH'" and if I boot
> 3.0-rt I get "WARNING: GDMDisplay[snip]", both times X doesn't start.
> FWIW I build a regular AUR kernel-rt.

Apparently, the nvidia-all PKGBUILD does it wrong. I don't know why it
exists - you can install nvidia from [extra] and create a package for
nvidia-rt. At least then you know the PKGBUILD does something that
actually works.
 
Old 01-06-2012, 09:28 AM
Thomas Bächler
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

Am 06.01.2012 11:17, schrieb Ralf Mardorf:
> Von: arch-general-bounces@archlinux.org im Auftrag von Thomas Bächler
> Gesendet: Fr 1/6/2012 10:25
>> Apparently, the nvidia-all PKGBUILD does it wrong. I don't know why it
>> exists - you can install nvidia from [extra] and create a package for
>> nvidia-rt. At least then you know the PKGBUILD does something that
>> actually works.
>
> Sorry for HTML, at the moment I'm not booted to Arch.
>
> I'm using the nvidia package again. Btw. I forgot to add a link to the rt's extramodules, but since there already was an issue for the regular kernel, I suspect it won't fix anything.
>
> How do I create a package for nvidia-rt?
>
> Should I build a dummy-package and install the module by a k option?
>
> I suspect the AUR's nvidia-rt will conflict with the package nvidia?!

No, the AUR's nvidia-rt package should be what you want (if you diff the
nvidia and nvidia-rt PKGBUILDs, the differences should be small).
 
Old 01-06-2012, 02:32 PM
Ralf Madorf
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

On Fri, 2012-01-06 at 12:03 +0100, Ralf Mardorf wrote:
> Von: arch-general-bounces@archlinux.org im Auftrag von Thomas Bächler
> Gesendet: Fr 1/6/2012 11:28
> > I suspect the AUR's nvidia-rt will conflict with the package
> nvidia?!
> >
> > No, the AUR's nvidia-rt package should be what you want (if you diff
> the
> > nvidia and nvidia-rt PKGBUILDs, the differences should be small).
> >
> Thanks, so you're referring to
>
https://wiki.archlinux.org/index.php/NVIDIA#Alternate_install:_custom_kernel ?
>
> Ok, if nvidia-rt from AUR would be up to date I could use this? But
> because the module is for another driver version, I need to build it
> using abs? Perhaps editing the nvidia-rt PKGBUILD file would be ok
> too?
>
> I simply will test it later .
>
> Ciao
>
> Ralf

Hi

I tried editing the AUR's kernel-rt (see 1. and 2. trial) and I tried to
build a package using abs (see 3. trail), all failed.

################################################## ######################
# 1. trial
################################################## ######################

I edited the PKGFILE from the tarball
http://aur.archlinux.org/packages/nv/nvidia-rt/nvidia-rt.tar.gz
by copying from
http://aur.archlinux.org/packages/nv/nvidia-all/PKGBUILD .

[spinymouse@archlinux nvidia-rt]$ diff PKGBUILD PKGBUILD.pri
8c8
< pkgver=290.10
---
> pkgver=285.05.09
11c11
< pkgdesc="NVIDIA drivers for kernel 3.0-rt."
---
> pkgdesc="NVIDIA drivers for kernel26."

[spinymouse@archlinux nvidia-rt]$ makepkg -s
==> Making package: nvidia-rt 290.10-1 (Fri Jan 6 13:44:01 CET 2012)
[snip]
==> Validating source files with md5sums...
NVIDIA-Linux-x86_64-290.10-no-compat32.run ... FAILED
nvidiart.patch ... Passed
==> ERROR: One or more files did not pass the validity check!

################################################## ######################
# 2. trial
################################################## ######################

I copied the lines for the checksums too. After installing nvidia-rt and
rebooting the kernel-ARCH, X started, but after booting kernel-rt it
finished with a black screen. I had to reset the computer.

[spinymouse@archlinux nvidia-rt]$ diff PKGBUILD PKGBUILD.pri
8c8
< pkgver=290.10
---
> pkgver=285.05.09
11c11
< pkgdesc="NVIDIA drivers for kernel 3.0-rt."
---
> pkgdesc="NVIDIA drivers for kernel26."
20,24c20,24
< _arch='x86'
< _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
<
source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
< md5sums=('50319a4b3818c12c9c7243525e0e6316')
<
---
> _arch='x86'
> _pkg="NVIDIA-Linux-${_arch}-${pkgver}" &&
md5sums=('2d469a90abef50320f548cfa8085e3a0'
'8f57481f4ae28fb1ec5a5f3af366cceb')
>
source=("http://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run"
> nvidiart.patch
> )
27,31c27,31
< _arch=$CARCH
< _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
<
source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
< md5sums=('cebfba9a7e91716a06c66bb5b38d9661')
<
---
> _arch='x86_64'
> _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32" &&
md5sums=('2f4a0e78f5560c07220b7ed6fc1e27aa'
'8f57481f4ae28fb1ec5a5f3af366cceb')
>
source=("http://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run"
> nvidiart.patch
> )

[spinymouse@archlinux nvidia-rt]$ makepkg -s
==> Making package: nvidia-rt 290.10-1 (Fri Jan 6 13:55:33 CET 2012)
[snip]
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Purging other files...
-> Compressing man and info pages...
-> Stripping unneeded symbols from binaries and libraries...
==> Creating package...
-> Generating .PKGINFO file...
-> Adding install file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: nvidia-rt 290.10-1 (Fri Jan 6 13:56:15 CET 2012)

################################################## ######################
# 3. trial
################################################## ######################

I'll followed the instructions given by
https://wiki.archlinux.org/index.php/NVIDIA#Alternate_install:_custom_kernel

There seemed to be the need to abort # abs, since nothing happened for
minutes. I tried again, fortunately then it only took some seconds.

[root@archlinux spinymouse]# pacman -Syy && pacman -S abs
[snip]
[root@archlinux spinymouse]# abs
==> Downloading tarballs...
==> core...
==> extra...
==> community...
==> multilib...
^C==> ERROR: Aborted by user! Exiting...
[root@archlinux spinymouse]# abs
==> Starting ABS sync...
receiving file list ... done
[snip]
[root@archlinux spinymouse]# exit
[spinymouse@archlinux ~]$ cd /usr/src
[spinymouse@archlinux src]$ mkdir abs
[spinymouse@archlinux src]$ cp -r /var/abs/extra/nvidia/ abs/
[spinymouse@archlinux src]$ cd abs/nvidia

I didn't run the custom kernel, so I didn't run uname.

[spinymouse@archlinux nvidia]$ ls ../..
abs linux-3.0-rt linux-3.1.7-1-ARCH #linux-rt nvidia-rt
[snip]
[spinymouse@archlinux nvidia]$ cp -p nvidia.install
nvidia.install.pri
[spinymouse@archlinux nvidia]$ cp -p PKGBUILD PKGBUILD.pri
[spinymouse@archlinux nvidia]$ diff nvidia.install
nvidia.install.pri
2c2
< EXTRAMODULES='extramodules-3.0-rt'
---
> EXTRAMODULES='extramodules-3.1-ARCH'
8c8
< EXTRAMODULES='extramodules-3.0-rt'
---
> EXTRAMODULES='extramodules-3.1-ARCH'
13c13
< EXTRAMODULES='extramodules-3.0-rt'
---
> EXTRAMODULES='extramodules-3.1-ARCH'
[spinymouse@archlinux nvidia]$ diff PKGBUILD PKGBUILD.pri
4c4
< pkgname=nvidia-3.0.14_rt31-1
---
> pkgname=nvidia
6,7c6,7
< _extramodules=extramodules-3.0-rt
< _kernver=3.0-rt
---
> _extramodules=extramodules-3.1-ARCH
> _kernver="$(cat /lib/modules/${_extramodules}/version)"
12,13c12,13
< depends=('linux>=3.0' 'linux<3.2' "nvidia-utils=${pkgver}")
< makedepends=('linux-headers>=3.0' 'linux-headers<3.2')
---
> depends=('linux>=3.1' 'linux<3.2' "nvidia-utils=${pkgver}")
> makedepends=('linux-headers>=3.1' 'linux-headers<3.2')
42c42
< #echo "blacklist nouveau" >>
"${pkgdir}/etc/modprobe.d/nouveau_blacklist.conf"
---
> echo "blacklist nouveau" >>
"${pkgdir}/etc/modprobe.d/nouveau_blacklist.conf"
[spinymouse@archlinux nvidia]$ ls /lib/modules/extra*
/lib/modules/extramodules-3.0-rt:
nvidia.ko.gz

/lib/modules/extramodules-3.1-ARCH:
nvidia.ko.gz version
[spinymouse@archlinux nvidia]$ rm *pri
[spinymouse@archlinux nvidia]$ su
[root@archlinux nvidia]# pacman -R nvidia-rt
[root@archlinux nvidia]# exit
[spinymouse@archlinux nvidia]$ makepkg -ci
==> Making package: nvidia-3.0.14_rt31-1 290.10-1 (Fri Jan 6
15:42:03 CET 2012)
[snip]
NVIDIA: calling KBUILD...
test -e include/generated/autoconf.h -a -e
include/config/auto.conf || (
echo;
echo " ERROR: Kernel configuration is invalid.";
echo " include/generated/autoconf.h or
include/config/auto.conf are missing.";
echo " Run 'make oldconfig && make prepare' on kernel
src to fix it.";
[snip]
NVIDIA: left KBUILD.
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Purging other files...
-> Compressing man and info pages...
==> Creating package...
-> Generating .PKGINFO file...
-> Adding install file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: nvidia-3.0.14_rt31-1 290.10-1 (Fri Jan 6
15:43:54 CET 2012)
==> Installing package nvidia-3.0.14_rt31-1 with pacman -U...
Password:
Sorry, try again.
Password:
Sorry, try again.
Password:
spinymouse is not in the sudoers file. This incident will be
reported.
==> WARNING: Failed to install built package(s).
==> Cleaning up...
[spinymouse@archlinux nvidia]$ su
[root@archlinux nvidia]# ls
nvidia-3.0.14_rt31-1-290.10-1-x86_64.pkg.tar.xz
NVIDIA-Linux-x86_64-290.10-no-compat32.run
nvidia.install PKGBUILD
[root@archlinux nvidia]# pacman -U
nvidia-3.0.14_rt31-1-290.10-1-x86_64.pkg.tar.xz
resolving dependencies...
looking for inter-conflicts...

Targets (1): nvidia-3.0.14_rt31-1-290.10-1

Proceed with installation? [Y/n]
(1/1) checking package
integrity
(1/1) checking for file
conflicts
error: failed to commit transaction (conflicting files)

nvidia-3.0.14_rt31-1: /lib/modules/extramodules-3.0-rt/nvidia.ko.gz
exists in filesystem
[root@archlinux nvidia]#
rm /lib/modules/extramodules-3.0-rt/nvidia.ko.gz
[root@archlinux nvidia]# pacman -U
nvidia-3.0.14_rt31-1-290.10-1-x86_64.pkg.tar.xz
resolving dependencies...
looking for inter-conflicts...

Targets (1): nvidia-3.0.14_rt31-1-290.10-1

cat: /lib/modules/extramodules-3.0-rt/version: No such file or
directory
In order to use nvidia module, reboot the system.
[root@archlinux nvidia]#
leafpad /lib/modules/extramodules-3.0-rt/version
[root@archlinux nvidia]#
cat /lib/modules/extramodules-3.0-rt/version
3.0-rt

1. Rebooted kernel-ARCH
Everything still is ok
2. Booted kernel-rt
GDM messages, no X, see log files [1], [2]

Regards,

Ralf



[1]
[spinymouse@archlinux ~]$ cat /var/log/Xorg.0.log.old
[ 8.888]
X.Org X Server 1.11.3
Release Date: 2011-12-16
[ 8.889] X Protocol Version 11, Revision 0
[ 8.889] Build Operating System: Linux 3.1.5-1-ARCH x86_64
[ 8.889] Current Operating System: Linux archlinux 3.0-rt #1 SMP
PREEMPT RT Mon Dec 26 13:03:51 CET 2011 x86_64
[ 8.889] Kernel command line: root=/dev/sda9 ro
[ 8.889] Build Date: 17 December 2011 09:17:41AM
[ 8.889]
[ 8.889] Current version of pixman: 0.24.0
[ 8.889] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 8.889] Markers: (--) probed, (**) from config file, (==) default
setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 8.889] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 6
16:00:14 2012
[ 8.957] (==) Using config file: "/etc/X11/xorg.conf"
[ 8.957] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 8.974] (==) No Layout section. Using the first Screen section.
[ 8.975] (**) |-->Screen "Screen0" (0)
[ 8.975] (**) | |-->Monitor "Monitor0"
[ 8.975] (**) | |-->Device "Card0"
[ 8.975] (==) Automatically adding devices
[ 8.975] (==) Automatically enabling devices
[ 9.002] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 9.002] Entry deleted from font path.
[ 9.002] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 9.002] Entry deleted from font path.
[ 9.017] (WW) `fonts.dir' not found (or not valid) in
"/usr/share/fonts/100dpi/".
[ 9.017] Entry deleted from font path.
[ 9.017] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 9.017] (WW) `fonts.dir' not found (or not valid) in
"/usr/share/fonts/75dpi/".
[ 9.017] Entry deleted from font path.
[ 9.017] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 9.017] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/Type1/
[ 9.017] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 9.017] (II) The server relies on udev to provide the list of input
devices.
If no devices become available, reconfigure udev or disable
AutoAddDevices.
[ 9.018] (II) Loader magic: 0x7ccae0
[ 9.018] (II) Module ABI versions:
[ 9.018] X.Org ANSI C Emulation: 0.4
[ 9.018] X.Org Video Driver: 11.0
[ 9.018] X.Org XInput driver : 13.0
[ 9.018] X.Org Server Extension : 6.0
[ 9.019] (--) PCI:*(0:1:0:0) 10de:01d3:10b0:0401 rev 161, Mem @
0xfa000000/16777216, 0xd0000000/268435456, 0xfb000000/16777216, BIOS @
0x????????/131072
[ 9.019] (II) Open ACPI successful (/var/run/acpid.socket)
[ 9.019] (II) "extmod" will be loaded. This was enabled by default
and also specified in the config file.
[ 9.019] (II) "dbe" will be loaded. This was enabled by default and
also specified in the config file.
[ 9.019] (II) "glx" will be loaded. This was enabled by default and
also specified in the config file.
[ 9.019] (II) "record" will be loaded. This was enabled by default
and also specified in the config file.
[ 9.019] (II) "dri" will be loaded. This was enabled by default and
also specified in the config file.
[ 9.019] (II) "dri2" will be loaded. This was enabled by default and
also specified in the config file.
[ 9.019] (II) LoadModule: "extmod"
[ 9.040] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 9.048] (II) Module extmod: vendor="X.Org Foundation"
[ 9.048] compiled for 1.11.3, module version = 1.0.0
[ 9.048] Module class: X.Org Server Extension
[ 9.048] ABI class: X.Org Server Extension, version 6.0
[ 9.048] (II) Loading extension MIT-SCREEN-SAVER
[ 9.048] (II) Loading extension XFree86-VidModeExtension
[ 9.048] (II) Loading extension XFree86-DGA
[ 9.048] (II) Loading extension DPMS
[ 9.048] (II) Loading extension XVideo
[ 9.048] (II) Loading extension XVideo-MotionCompensation
[ 9.048] (II) Loading extension X-Resource
[ 9.048] (II) LoadModule: "dri"
[ 9.049] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 9.064] (II) Module dri: vendor="X.Org Foundation"
[ 9.064] compiled for 1.11.3, module version = 1.0.0
[ 9.064] ABI class: X.Org Server Extension, version 6.0
[ 9.064] (II) Loading extension XFree86-DRI
[ 9.064] (II) LoadModule: "dbe"
[ 9.064] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 9.065] (II) Module dbe: vendor="X.Org Foundation"
[ 9.065] compiled for 1.11.3, module version = 1.0.0
[ 9.065] Module class: X.Org Server Extension
[ 9.065] ABI class: X.Org Server Extension, version 6.0
[ 9.065] (II) Loading extension DOUBLE-BUFFER
[ 9.065] (II) LoadModule: "dri2"
[ 9.065] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 9.066] (II) Module dri2: vendor="X.Org Foundation"
[ 9.066] compiled for 1.11.3, module version = 1.2.0
[ 9.066] ABI class: X.Org Server Extension, version 6.0
[ 9.066] (II) Loading extension DRI2
[ 9.066] (II) LoadModule: "glx"
[ 9.066] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 9.996] (II) Module glx: vendor="NVIDIA Corporation"
[ 10.003] compiled for 4.0.2, module version = 1.0.0
[ 10.003] Module class: X.Org Server Extension
[ 10.004] (II) NVIDIA GLX Module 290.10 Wed Nov 16 18:01:24 PST
2011
[ 10.004] (II) Loading extension GLX
[ 10.004] (II) LoadModule: "record"
[ 10.004] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 10.011] (II) Module record: vendor="X.Org Foundation"
[ 10.011] compiled for 1.11.3, module version = 1.13.0
[ 10.011] Module class: X.Org Server Extension
[ 10.011] ABI class: X.Org Server Extension, version 6.0
[ 10.011] (II) Loading extension RECORD
[ 10.011] (II) LoadModule: "v4l"
[ 10.019] (WW) Warning, couldn't open module v4l
[ 10.019] (II) UnloadModule: "v4l"
[ 10.020] (II) Unloading v4l
[ 10.020] (EE) Failed to load module "v4l" (module does not exist, 0)
[ 10.020] (II) LoadModule: "nvidia"
[ 10.020] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 10.092] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 10.101] compiled for 4.0.2, module version = 1.0.0
[ 10.101] Module class: X.Org Video Driver
[ 10.138] (EE) NVIDIA: Failed to load the NVIDIA kernel module.
Please check your
[ 10.138] (EE) NVIDIA: system's kernel log for additional error
messages.
[ 10.138] (II) UnloadModule: "nvidia"
[ 10.138] (II) Unloading nvidia
[ 10.138] (EE) Failed to load module "nvidia" (module-specific error,
0)
[ 10.138] (EE) No drivers available.
[ 10.138]
Fatal server error:
[ 10.138] no screens found
[ 10.138]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 10.138] Please also check the log file at "/var/log/Xorg.0.log" for
additional information.
[ 10.138]


[2]
[root@archlinux spinymouse]# grep nvidia /var/log/kernel.log
[snip]
Jan 6 15:59:13 localhost kernel: [ 5.110305] nvidia: module license
'NVIDIA' taints kernel.
Jan 6 15:59:13 localhost kernel: [ 5.358022] nvidia 0000:01:00.0:
PCI INT A -> GSI 18 (level, low) -> IRQ 18
Jan 6 15:59:13 localhost kernel: [ 5.358034] nvidia 0000:01:00.0:
setting latency timer to 64
Jan 6 16:01:24 localhost kernel: [ 5.510930] nvidia: module license
'NVIDIA' taints kernel.
Jan 6 16:01:24 localhost kernel: [ 5.759444] nvidia 0000:01:00.0:
PCI INT A -> GSI 18 (level, low) -> IRQ 18
Jan 6 16:01:24 localhost kernel: [ 5.759456] nvidia 0000:01:00.0:
setting latency timer to 64
 
Old 01-06-2012, 02:36 PM
Ralf Madorf
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

PS:
> I tried editing the AUR's kernel-rt (see 1. and 2. trial) and I tried to
should be ^^^^^^^^^ nvidia-rt PKGBUILD
> build a package using abs (see 3. trail), all failed.
 
Old 01-06-2012, 02:47 PM
Thomas Bächler
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

Am 06.01.2012 16:32, schrieb Ralf Madorf:
> [ 8.889] Current Operating System: Linux archlinux 3.0-rt #1 SMP
> PREEMPT RT Mon Dec 26 13:03:51 CET 2011 x86_64

The -rt kernel package still uses the old versioning scheme, where the
patchlevel is removed from the version string. This means that the new
nvidia PKGBUILD won't work and you need to start from an old version.

Basically, make it look like it was before this change:
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia&id=1b7954a332c32de0ef49a82806fbb18544b26949
 
Old 01-06-2012, 02:50 PM
Ralf Madorf
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

PPS:
Regarding to the 3.1 vs 3.0 issue, is there the need to use an older
version of the proprietary nvidia driver with current kernel-rt? I don't
need the latest proprietary driver for my computer.
 
Old 01-06-2012, 02:57 PM
Ralf Madorf
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

On Fri, 2012-01-06 at 16:47 +0100, Thomas Bächler wrote:
> Am 06.01.2012 16:32, schrieb Ralf Madorf:
> > [ 8.889] Current Operating System: Linux archlinux 3.0-rt #1 SMP
> > PREEMPT RT Mon Dec 26 13:03:51 CET 2011 x86_64
>
> The -rt kernel package still uses the old versioning scheme, where the
> patchlevel is removed from the version string. This means that the new
> nvidia PKGBUILD won't work and you need to start from an old version.
>
> Basically, make it look like it was before this change:
> https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia&id=1b7954a332c32de0ef49a82806fbb18544b26949

Thank you

I'll try it tonight or tomorrow. OTOH I guess I can use 285.05.09-1
( http://aur.archlinux.org/packages.php?ID=12132 ) with $ uname -r
3.1.7-1-ARCH instead of doing this for 290.10?!

Regards,

Ralf
 
Old 01-06-2012, 03:02 PM
Thomas Bächler
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

Am 06.01.2012 16:57, schrieb Ralf Madorf:
> On Fri, 2012-01-06 at 16:47 +0100, Thomas Bächler wrote:
>> Am 06.01.2012 16:32, schrieb Ralf Madorf:
>>> [ 8.889] Current Operating System: Linux archlinux 3.0-rt #1 SMP
>>> PREEMPT RT Mon Dec 26 13:03:51 CET 2011 x86_64
>>
>> The -rt kernel package still uses the old versioning scheme, where the
>> patchlevel is removed from the version string. This means that the new
>> nvidia PKGBUILD won't work and you need to start from an old version.
>>
>> Basically, make it look like it was before this change:
>> https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia&id=1b7954a332c32de0ef49a82806fbb18544b26949
>
> Thank you
>
> I'll try it tonight or tomorrow. OTOH I guess I can use 285.05.09-1
> ( http://aur.archlinux.org/packages.php?ID=12132 ) with $ uname -r
> 3.1.7-1-ARCH instead of doing this for 290.10?!

No, you can't, you need a version that matches your nvidia-utils package.

These module PKGBUILDs are a mess since I changed the external kernel
module handling in 3.1 - some AUR kernels use the new scheme, some use
the old one (hence the problems with nvidia-all).
 
Old 01-07-2012, 11:52 AM
Ralf Madorf
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

On Fri, 2012-01-06 at 16:47 +0100, Thomas Bächler wrote:
> Basically, make it look like it was before this change:
>
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia&id=1b7954a332c32de0ef49a82806fbb18544b26949

Hi Thomas,

this caused a black screen for the kernel-rt. For kernel-ARCH everything
kept ok.

Sometimes the proprietary nvidia driver with kernel-rt (even with a
faked licence) didn't/doesn't work for some Linux installs, than I added

$ cat /mnt/maverick/etc/rcS.d/S69switch_xorg.conf
#! /bin/sh
# /etc/rcS.d/Switch_xorg_conf

rm /etc/X11/xorg.conf
case $(uname -r) in
*rt*)
cp /etc/X11/xorg.conf.nv /etc/X11/xorg.conf
;;
*)
cp /etc/X11/xorg.conf.nvidia /etc/X11/xorg.conf
;;
esac

Regards,

Ralf

# cd /usr/src/abs/nvidia
# ls
nvidia-3.0.14_rt31-1-290.10-1-x86_64.pkg.tar.xz
NVIDIA-Linux-x86_64-290.10-no-compat32.run
nvidia.install
PKGBUILD
# pacman -R nvidia-3.0.14_rt31-1
# exit
$ cd /usr/src/abs/nvidia
$ rm *.pkg.tar.xz
$ cp -p nvidia.install nvidia.install.old
$ cp -p PKGBUILD PKGBUILD.old
$ diff PKGBUILD PKGBUILD.old
6c6
<
---
> _extramodules=extramodules-3.0-rt
12,13c12,13
< -depends=('linux>=3.0' 'linux<3.1' "nvidia-utils=${pkgver}")
< -makedepends=('linux-headers>=3.0' 'linux-headers<3.1')
---
> depends=('linux>=3.0' 'linux<3.2' "nvidia-utils=${pkgver}")
> makedepends=('linux-headers>=3.0' 'linux-headers<3.2')
40c40
<
"${pkgdir}/lib/modules/${_kernver}/kernel/drivers/video/nvidia.ko"
---
> "${pkgdir}/lib/modules/${_extramodules}/nvidia.ko"
44c44
< gzip
"${pkgdir}/lib/modules/${_kernver}/kernel/drivers/video/nvidia.ko"
---
> gzip "${pkgdir}/lib/modules/${_extramodules}/nvidia.ko"
$ grep _kernver= PKGBUILD
_kernver=3.0-rt
$ diff nvidia.install nvidia.install.old
2,3c2,3
< KERNEL_VERSION='3.0-rt'
< depmod $KERNEL_VERSION
---
> EXTRAMODULES='extramodules-3.0-rt'
> depmod $(cat /lib/modules/$EXTRAMODULES/version)
8,9c8,9
< KERNEL_VERSION='3.0-rt'
< depmod $KERNEL_VERSION
---
> EXTRAMODULES='extramodules-3.0-rt'
> depmod $(cat /lib/modules/$EXTRAMODULES/version)
13,14c13,14
< KERNEL_VERSION='3.0-rt'
< depmod $KERNEL_VERSION
---
> EXTRAMODULES='extramodules-3.0-rt'
> depmod $(cat /lib/modules/$EXTRAMODULES/version)

$ cat /lib/modules/extramodules-3.0-rt/version
3.0-rt

*chuckle*

$ rm *old
$ makepkg -c
/usr/src/abs/nvidia/PKGBUILD: line 12: syntax error near unexpected
token `'linux>=3.0'

;D Yep, as you can see above, I copied the "-" signs from the diff.

$ makepkg -c
==> Making package: nvidia-3.0.14_rt31-1 290.10-1 (Sat Jan 7 13:11:04
CET 2012)
==> Checking runtime dependencies...
==> Missing Dependencies:
-> linux<3.1
==> Checking buildtime dependencies...
==> Missing Dependencies:
-> linux-headers<3.1
==> ERROR: Could not resolve all dependencies.

That's strange. I re-edited to <3.2.

$ makepkg -c
==> Making package: nvidia-3.0.14_rt31-1 290.10-1 (Sat Jan 7 13:15:35
CET 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found NVIDIA-Linux-x86_64-290.10-no-compat32.run
==> Validating source files with md5sums...
NVIDIA-Linux-x86_64-290.10-no-compat32.run ... Passed
==> Extracting Sources...
==> Starting build()...
Creating directory NVIDIA-Linux-x86_64-290.10-no-compat32
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64
290.10............................................ .................................................. ..........................................
NVIDIA: calling KBUILD...
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (

echo;
echo " ERROR: Kernel configuration is invalid.";
echo " include/generated/autoconf.h or include/config/auto.conf
are missing.";
echo " Run 'make oldconfig && make prepare' on kernel src to fix
it.";
echo;
[snip]
NVIDIA: left KBUILD.
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
-> Purging other files...
-> Compressing man and info pages...
==> Creating package...
-> Generating .PKGINFO file...
-> Adding install file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: nvidia-3.0.14_rt31-1 290.10-1 (Sat Jan 7 13:16:03
CET 2012)
==> Cleaning up...
$ su
# pacman -U nvidia-3.0.14_rt31-1-290.10-1-x86_64.pkg.tar.xz
[snip]
In order to use nvidia module, reboot the system.
 
Old 01-08-2012, 06:29 AM
Ralf Madorf
 
Default Proprietary nvidia driver for kernel-ARCH and kernel-rt

On Sat, 2012-01-07 at 07:10 +0800, Oon-Ee Ng wrote:
> On Jan 7, 2012 12:02 AM, "Thomas Bächler" <thomas@archlinux.org> wrote:
> >
> > Am 06.01.2012 16:57, schrieb Ralf Madorf:
> > > On Fri, 2012-01-06 at 16:47 +0100, Thomas Bächler wrote:
> > >> Am 06.01.2012 16:32, schrieb Ralf Madorf:
> > >>> [ 8.889] Current Operating System: Linux archlinux 3.0-rt #1 SMP
> > >>> PREEMPT RT Mon Dec 26 13:03:51 CET 2011 x86_64
> > >>
> > >> The -rt kernel package still uses the old versioning scheme, where the
> > >> patchlevel is removed from the version string. This means that the new
> > >> nvidia PKGBUILD won't work and you need to start from an old version.
> > >>
> > >> Basically, make it look like it was before this change:
> > >>
> https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia&id=1b7954a332c32de0ef49a82806fbb18544b26949
> > >
> > > Thank you
> > >
> > > I'll try it tonight or tomorrow. OTOH I guess I can use 285.05.09-1
> > > ( http://aur.archlinux.org/packages.php?ID=12132 ) with $ uname -r
> > > 3.1.7-1-ARCH instead of doing this for 290.10?!
> >
> > No, you can't, you need a version that matches your nvidia-utils package.
> >
> > These module PKGBUILDs are a mess since I changed the external kernel
> > module handling in 3.1 - some AUR kernels use the new scheme, some use
> > the old one (hence the problems with nvidia-all).
> >
> >
>
> I'll try and accommodate both in nvidia-beta-all by next week actually, it
> doesn't seem too hard

As a workaround I now use kernel-rt with the FLOSS nv driver, so for 3D
acceleration I need to boot kernel-ARCH.

# pacman -Syu xf86-video-nv

# grep DAEMONS= /etc/rc.conf
DAEMONS=(69switch_xorg.conf hwclock syslog-ng !network !netfs crond
acpid dbus)

# cat /etc/rc.d/69switch_xorg.conf
#! /bin/sh
# /etc/rcS.d/Switch_xorg_conf

rm /etc/X11/xorg.conf
case $(uname -r) in
*rt*)
cp /etc/X11/xorg.conf.nv /etc/X11/xorg.conf
;;
*)
cp /etc/X11/xorg.conf.nvidia /etc/X11/xorg.conf
;;
esac

# grep nv /etc/X11/xorg.conf.nv
#Driver "nvidia"
Driver "nv"

# grep nv /etc/X11/xorg.conf.nvidia
Driver "nvidia"
#Driver "nv"
 

Thread Tools




All times are GMT. The time now is 09:28 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org