FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 12-23-2011, 07:53 PM
Paul Fox
 
Default Issue with monolithic gcc-libs package

Hello,

I have been looking into GNUStep and Etoile development recently, and
I ran into an Arch packaging issue that I'm not sure how to address.

Essentially, Etoile requires the experimental GNUStep libobjc runtime
(libobjc2 or GNUStep runtime) that has additional features from
Objective 2.0. However, libobjc on Arch is part of the gcc-libs
package making it hard to replace without removing libobjc.so manually
and breaking the package.

It puzzles me that gcc-libs includes runtimes for all the major
languages supported by gcc. Might it not be better to have each
library be its own package (so, for example, libstdc++, libgomp,
libfortran, and so forth) and only have gcc-libs include libgcc_s?

This would allow more flexibility to selectively install or replace
runtime libs (for example, I might not need fortran, so why should I
have it installed?)
 

Thread Tools




All times are GMT. The time now is 01:47 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org