FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 11-26-2011, 01:30 PM
"David C. Rankin"
 
Default Fwd: Avantfax 3.3.3 Stopped Working? require_once(): Failed opening required 'NULL.php' line 22 classes.php

Guys,

If you use the Avantfax fax server, you will have problems with the recent
versions of PHP. The follow is the fix implemented by the Avantfax developer
which you will need to incorporate until a new version of Avantfax is released:

-------- Original Message --------
Subject: Re: Avantfax 3.3.3 Stopped Working? require_once(): Failed opening
required 'NULL.php' line 22 classes.php
Date: Wed, 23 Nov 2011 21:36:59 +0100
From: David Mimms
To: David C.Rankin J.D.P.E.

Hi David,

It's an issue with PHP 5.3. I logged in and changed the following in
includes/classes.php:

function __autoload($class_name) {
if (file_exists($class_name.'.php')) // <------
require_once $class_name.'.php';
}

And added " & ~E_DEPRECATED" to the error_reporting function in config.php to
stopped all of the warnings about deprecated code from appearing. I need to get
a new release out for all of the new PHP 5.3 users!

Please let me know if you have any other problems.

Thanks!

David


--
David C. Rankin, J.D.,P.E.
 

Thread Tools




All times are GMT. The time now is 05:00 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org