FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 10-28-2011, 06:37 AM
Alex Ferrando
 
Default Can't upgrade GCC from testing, clang requires 4.6.1

With the last push of GCC in testing, I have some kind of trouble to get
pacman to update it. It seems that clang, which I'm using fro
vim-clang-complete from AUR requires a fixed version of GCC ( and LLVM,
but this now is not the my main concern) which makes me impossible to
update GCC:


error: failed to prepare transaction (could not satisfy dependencies)
:: clang: requires gcc=4.6.1

So, my question now is if it is safe to rebuild clang without the fixed
version dependencie on GCC and then upgrade. Would clang break if the
GCC version is different from 4.6.1?
 
Old 10-28-2011, 06:50 AM
Gaetan Bisson
 
Default Can't upgrade GCC from testing, clang requires 4.6.1

[2011-10-28 08:37:56 +0200] Alex Ferrando:
> So, my question now is if it is safe to rebuild clang without the
> fixed version dependencie on GCC and then upgrade. Would clang break
> if the GCC version is different from 4.6.1?

I wouldn't think it would. Try it out and let us know.

--
Gaetan
 
Old 10-28-2011, 10:40 AM
Alex Ferrando
 
Default Can't upgrade GCC from testing, clang requires 4.6.1

On 28/10/11 08:50, Gaetan Bisson wrote:

[2011-10-28 08:37:56 +0200] Alex Ferrando:

So, my question now is if it is safe to rebuild clang without the
fixed version dependencie on GCC and then upgrade. Would clang break
if the GCC version is different from 4.6.1?

I wouldn't think it would. Try it out and let us know.

I've rebuild llvm and clang using gcc 4.6.2 and then reinstalled
vim-clang-complete. It seems to work.


Now second question, why the fixed version as clang dep?
 
Old 10-28-2011, 02:23 PM
Gaetan Bisson
 
Default Can't upgrade GCC from testing, clang requires 4.6.1

[2011-10-28 12:40:38 +0200] Alex Ferrando:
> On 28/10/11 08:50, Gaetan Bisson wrote:
> >[2011-10-28 08:37:56 +0200] Alex Ferrando:
> >>So, my question now is if it is safe to rebuild clang without the
> >>fixed version dependencie on GCC and then upgrade. Would clang break
> >>if the GCC version is different from 4.6.1?
> >I wouldn't think it would. Try it out and let us know.
> >
> I've rebuild llvm and clang using gcc 4.6.2 and then reinstalled
> vim-clang-complete. It seems to work.
>
> Now second question, why the fixed version as clang dep?

Because our clang-2.9-6 package won't work with any other gcc than
4.6.1?

--
Gaetan
 

Thread Tools




All times are GMT. The time now is 08:05 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org