FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 10-13-2011, 07:31 PM
Karol Blazewicz
 
Default pacman 4.0.0-2

I don't have the permissions to post to [arch-dev-public] so I'm
posting it here.


On Thu, Oct 13, 2011 at 8:22 PM, Dan McGee <dpmcgee@gmail.com> wrote:
> The most anticipated release EVER has landed in [testing]. Do I expect
> it to make it out before we need a 4.0.1? Not really.
>
> Questions? Concerns? Comments? I'm telling you as little as possible
> about this release and how to make things work to put more people in
> the "standard user who doesn't follow development like a hawk" shoes.
>
> -Dan

A question about the manpage and '-xx' switches e.g.:
-u, --sysupgrade
<snip>
Pass this option twice to enable package downgrade; in this
case pacman will select
sync packages whose version does not match with the local
version. This can be
useful when the user switches from a testing repo to a stable one.
<snip>

People often overlook it - especially for '-dd'. Compare this with
'pacman -Sh' output:
<snip>
-u, --sysupgrade upgrade installed packages (-uu allows downgrade)
<snip>
'-uu' is explicitly mentioned.

Do you think pacman manpage should be made more scannable (i.e. you
can just glance over and know what to do) / searchable - the '-uu'
switch is not exp[licitly mentioned anywhere, you can't grep it.

On the other hand 'pacman -Sh' doesn't tell you about '-yy':
-y, --refresh download fresh package databases from the server


What do you think about such changes? Do you want them at all and if
yes, will you write them or do you prefer I come up with a proposal /
patch?

-Karol
 
Old 10-14-2011, 01:42 PM
Karol Blazewicz
 
Default pacman 4.0.0-2

On Fri, Oct 14, 2011 at 2:52 PM, Pierre Schmitz <pierre@archlinux.de> wrote:
> I see my text was probably hard to read, but it was not about some
> packages not being updated for pacman 4.0 yet but a possible bug (or
> two) in pacman itself.
>
> --
> Pierre Schmitz, https://users.archlinux.de/~pierre
>

Same thing happened when I installed yaourt:

[2011-10-14 14:36] Running 'pacman -S yaourt'
[2011-10-14 14:36] warning: /etc/pacman.conf installed as
/etc/pacman.conf.pacnew
[2011-10-14 14:36] warning: /etc/makepkg.conf installed as
/etc/makepkg.conf.pacnew
[2011-10-14 14:36] upgraded pacman (4.0.0-2 -> 3.5.4-4)
[2011-10-14 14:36] installed package-query (0.9-1)
[2011-10-14 14:36] installed yaourt (0.10.2-1)

Now when I want to upgrade to pacman 4 it behaves as expected:

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<3.6
 
Old 10-14-2011, 03:33 PM
Denis A. Altoé Falqueto
 
Default pacman 4.0.0-2

On Fri, Oct 14, 2011 at 10:42 AM, Karol Blazewicz
<karol.blazewicz@gmail.com> wrote:
> On Fri, Oct 14, 2011 at 2:52 PM, Pierre Schmitz <pierre@archlinux.de> wrote:
>> I see my text was probably hard to read, but it was not about some
>> packages not being updated for pacman 4.0 yet but a possible bug (or
>> two) in pacman itself.
>>
>> --
>> Pierre Schmitz, https://users.archlinux.de/~pierre
>>
>
> Same thing happened when I installed yaourt:
>
> [2011-10-14 14:36] Running 'pacman -S yaourt'
> [2011-10-14 14:36] warning: /etc/pacman.conf installed as
> /etc/pacman.conf.pacnew
> [2011-10-14 14:36] warning: /etc/makepkg.conf installed as
> /etc/makepkg.conf.pacnew
> [2011-10-14 14:36] upgraded pacman (4.0.0-2 -> 3.5.4-4)
> [2011-10-14 14:36] installed package-query (0.9-1)
> [2011-10-14 14:36] installed yaourt (0.10.2-1)
>
> Now when I want to upgrade to pacman 4 it behaves as expected:
>
> resolving dependencies...
> looking for inter-conflicts...
> error: failed to prepare transaction (could not satisfy dependencies)
> :: package-query: requires pacman<3.6
>

You'll have to wait until package-query is updated to pacman 4 or just
uninstall it. I had that problem too and decided to uninstall yaourt.

--
A: Because it obfuscates the reading.
Q: Why is top posting so bad?

-------------------------------------------
Denis A. Altoe Falqueto
Linux user #524555
-------------------------------------------
 
Old 10-14-2011, 03:41 PM
Karol Blazewicz
 
Default pacman 4.0.0-2

On Fri, Oct 14, 2011 at 5:33 PM, Denis A. Altoé Falqueto
<denisfalqueto@gmail.com> wrote:
> On Fri, Oct 14, 2011 at 10:42 AM, Karol Blazewicz
> <karol.blazewicz@gmail.com> wrote:
>> On Fri, Oct 14, 2011 at 2:52 PM, Pierre Schmitz <pierre@archlinux.de> wrote:
>>> I see my text was probably hard to read, but it was not about some
>>> packages not being updated for pacman 4.0 yet but a possible bug (or
>>> two) in pacman itself.
>>>
>>> --
>>> Pierre Schmitz, https://users.archlinux.de/~pierre
>>>
>>
>> Same thing happened when I installed yaourt:
>>
>> [2011-10-14 14:36] Running 'pacman -S yaourt'
>> [2011-10-14 14:36] warning: /etc/pacman.conf installed as
>> /etc/pacman.conf.pacnew
>> [2011-10-14 14:36] warning: /etc/makepkg.conf installed as
>> /etc/makepkg.conf.pacnew
>> [2011-10-14 14:36] upgraded pacman (4.0.0-2 -> 3.5.4-4)
>> [2011-10-14 14:36] installed package-query (0.9-1)
>> [2011-10-14 14:36] installed yaourt (0.10.2-1)
>>
>> Now when I want to upgrade to pacman 4 it behaves as expected:
>>
>> resolving dependencies...
>> looking for inter-conflicts...
>> error: failed to prepare transaction (could not satisfy dependencies)
>> :: package-query: requires pacman<3.6
>>
>
> You'll have to wait until package-query is updated to pacman 4 or just
> uninstall it. I had that problem too and decided to uninstall yaourt.
>
> --
> A: Because it obfuscates the reading.
> Q: Why is top posting so bad?
>
> -------------------------------------------
> Denis A. Altoe Falqueto
> Linux user #524555
> -------------------------------------------
>

My question is why pacman decided to downgrade itself to satisfy
package-query's dependency?
I think it should fail due to unresolvable dependencies:

warning: cannot resolve "pacman<3.6", a dependency of "package-query"
:: The following package cannot be upgraded due to unresolvable dependencies:
yaourt
 

Thread Tools




All times are GMT. The time now is 10:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org