Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux General Discussion (http://www.linux-archive.org/archlinux-general-discussion/)
-   -   updating xorg packages and nvidia packages, now x doesn't start (http://www.linux-archive.org/archlinux-general-discussion/467660-updating-xorg-packages-nvidia-packages-now-x-doesnt-start.html)

"Jeffrey Lynn Parke Jr." 12-20-2010 05:30 AM

updating xorg packages and nvidia packages, now x doesn't start
 
I did a big update on my main arch machine and rebooted, I can't start X
anymore. I saw that xorg-xinit and xorg-xauth as well as the nvidia packages
were upgraded. Startx gives me a blank screen and switching to the first
login (ctrl-alt-F1) shows a never ending "No Protocol Specified" message
which finally fails with "xinit: unable to connect to X server: Connection
refused" and "Xauth: error in locking authority file /home/user/.Xauthority"

I checked my Xorg.0.log file and I see this message listed:

(II) NVIDIA(0): Setting mode "nvidia-auto-select" (II) NVIDIA(0): ACPI:
> failed to connect to the ACPI event daemon; the daemon (II) NVIDIA(0): may
> not be running or the "AcpidSocketPath" X (II) NVIDIA(0): configuration
> option may not be set correctly. When the (II) NVIDIA(0): ACPI event daemon
> is available, the NVIDIA X driver will (II) NVIDIA(0): try to use it to
> receive ACPI event notifications. For (II) NVIDIA(0): details, please see
> the "ConnectToAcpid" and (II) NVIDIA(0): "AcpidSocketPath" X configuration
> options in Appendix B: X (II) NVIDIA(0): Config Options in the README


what could be the problem here?


All times are GMT. The time now is 08:45 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.