FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 10-24-2010, 02:57 PM
Baho Utot
 
Default devtools:mkarchroot fails under sudo

Following Building in a clean chroot I have encountered the following
issue, which is related to using sudo mkarchroot
The full path is not included (code posted from mkarchroot) should this
be fixed?

After patching mkarchroot it works with sudo.

BUILD=/home/devtools

$ sudo mkdir -vp ${BUILD}
mkdir: created directory `/home/devtools'

$ sudo /usr/sbin/mkarchroot "${BUILD}/root" base base-devel sudo
:: Synchronizing package databases...
....
[putolin]
....
/usr/sbin/mkarchroot: line 178: ldconfig: command not found
/usr/sbin/mkarchroot: line 191: chroot: command not found

/usr/sbin/mkarchroot

line 178:
if [ -d "${working_dir}/lib/modules" ]; then
ldconfig -r "${working_dir}"
fi

if [ -d "${working_dir}/lib/modules" ]; then
/sbin/ldconfig -r "${working_dir}"
fi


line 191:
if [ -e "${working_dir}/etc/locale.gen" ]; then
echo -e 'en_US.UTF-8 UTF-8
de_DE.UTF-8 UTF-8' >
"${working_dir}/etc/locale.gen"

chroot "${working_dir}" locale-gen

if [ -e "${working_dir}/etc/locale.gen" ]; then
echo -e 'en_US.UTF-8 UTF-8
de_DE.UTF-8 UTF-8' >
"${working_dir}/etc/locale.gen"

/usr/sbin/chroot "${working_dir}" /usr/sbin/locale-gen
 

Thread Tools




All times are GMT. The time now is 04:58 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org