Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux General Discussion (http://www.linux-archive.org/archlinux-general-discussion/)
-   -   ath9k wifi hanged when network manager connect to the AP (http://www.linux-archive.org/archlinux-general-discussion/443385-ath9k-wifi-hanged-when-network-manager-connect-ap.html)

BOYPT 10-23-2010 11:31 AM

ath9k wifi hanged when network manager connect to the AP
 
I'm not sure if this should report to the upstream kernel, want to know any
of you have same experiances.

Since last kernel update, when i boot my laptop to the desktop, the wifi
dead while network manager trying associate to the AP, can't build any
connection.

I check dmesg at once:

wlan0: authenticate with 00:25:86:75:30:06 (try 1)
wlan0: authenticated
wlan0: associate with 00:25:86:75:30:06 (try 1)
wlan0: RX AssocResp from 00:25:86:75:30:06 (capab=0x431 status=0 aid=2)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
ata1.00: configured for UDMA/133
ata1: EH complete
EXT4-fs (sda5): re-mounted. Opts: commit=0
EXT4-fs (sda7): re-mounted. Opts: commit=0
fuse init (API version 7.14)
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM ver 1.11
lo: Disabled Privacy Extensions
irq 17: nobody cared (try booting with the "irqpoll" option)
Pid: 5134, comm: cairo-dock Tainted: P 2.6.35-ARCH #1
Call Trace:
[<c12e64dd>] ? printk+0x18/0x1b
[<c1097037>] __report_bad_irq.clone.1+0x27/0x90
[<c1095b94>] ? handle_IRQ_event+0x44/0x1a0
[<c10971f2>] note_interrupt+0x152/0x190
[<c1097d0b>] handle_fasteoi_irq+0x9b/0xc0
[<c1005d68>] handle_irq+0x18/0x30
[<c1005a47>] do_IRQ+0x47/0xc0
[<c1106fc4>] ? sys_poll+0x54/0xd0
[<c1003d30>] common_interrupt+0x30/0x38
[<c12e0000>] ? detect_extended_topology+0x7d/0x182
handlers:
[<fa3eb1a0>] (ath_isr+0x0/0x1f0 [ath9k])
Disabling IRQ #17
No probe response from AP 00:25:86:75:30:06 after 500ms, disconnecting.
cfg80211: Calling CRDA to update world regulatory domain
wlan0: authenticate with 00:25:86:75:30:06 (try 1)
wlan0: authenticate with 00:25:86:75:30:06 (try 2)
wlan0: authenticate with 00:25:86:75:30:06 (try 3)
wlan0: authentication with 00:25:86:75:30:06 timed out



Oh, a crash track, and IRQ #17(to the wireless?) is disabled, then wlan no
more reply to any request to associatings.

Acroding to the log, the wireless work the first time it associated to my
AP, this is done by the /etc/rc.d/network, i configured in rc.conf.

the second time it associate is when entered the desktop, network-manager
begin to control the netwok stuff. then the ath9k module crashed.

Reboot the system won't help, only turn out that system can't find my
wireless. I have to compeletely shutdown the conputer, unplug power and
battery, then boot again, and maybe run into a normal situaiton, none of
above happend.


--
Arch Linuxer, Pythoner, Geek
--> Blog: http://apt-blog.net


All times are GMT. The time now is 07:48 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.