FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 10-19-2010, 02:50 PM
Fess
 
Default python3 update

I think this is useful information: all soft installed from aur need to be reinstalled with changing line like "python setup.py blah-blah" to line "python2 setup.py blah-blah". Because some packages still aren't touched(e.g. charm).
So, something like that.
--
 
Old 10-19-2010, 04:54 PM
Clément Démoulins
 
Default python3 update

Le 19/10/2010 16:50, Fess a écrit :
> I think this is useful information: all soft installed from aur need to be reinstalled with changing line like "python setup.py blah-blah" to line "python2 setup.py blah-blah". Because some packages still aren't touched(e.g. charm).
> So, something like that.

And the dependencies must be updated from python to python2.
 
Old 10-19-2010, 05:00 PM
C Anthony Risinger
 
Default python3 update

2010/10/19 Clément Démoulins <clement@archivel.fr>:
> Le 19/10/2010 16:50, Fess a écrit :
>> I think this is useful information: all soft installed from aur need to be reinstalled with changing line like "python setup.py blah-blah" to line "python2 setup.py blah-blah". Because some packages still aren't touched(e.g. charm).
>> So, something like that.
>
> And the dependencies must be updated from python to python2.

ugh, the impending doom, why didn't i prepare!!!

all my development with pyjamas has halted until i get pyjamas itself
working under py3k (or 2.7 even...)

:-(

oh well, most things seemed to have gone smooth; thanks guys. hakuna
matata, it means no worries :-), i should have been working on py3k
compliance awhile back, no one to blame but me!

/whips self and hopes it's not too much work

C Anthony
 
Old 10-19-2010, 05:13 PM
Heiko Baums
 
Default python3 update

Am Tue, 19 Oct 2010 18:54:16 +0200
schrieb Clément Démoulins <clement@archivel.fr>:

> Le 19/10/2010 16:50, Fess a écrit :
> > I think this is useful information: all soft installed from aur
> > need to be reinstalled with changing line like "python setup.py
> > blah-blah" to line "python2 setup.py blah-blah". Because some
> > packages still aren't touched(e.g. charm). So, something like that.
>
> And the dependencies must be updated from python to python2.

It would probably make sense to discuss this on aur-general instead of
arch-general.

And for the affected packages you should probably write comments in the
AUR in case a maintainer doesn't read the mailing list or has forgotten
to updating a package.

Heiko
 
Old 10-19-2010, 07:12 PM
Nicolás Reynolds
 
Default python3 update

El 19/10/10 07:13, Heiko Baums dijo:
> Am Tue, 19 Oct 2010 18:54:16 +0200
> schrieb Clément Démoulins <clement@archivel.fr>:
>
> > Le 19/10/2010 16:50, Fess a écrit :
> > > I think this is useful information: all soft installed from aur
> > > need to be reinstalled with changing line like "python setup.py
> > > blah-blah" to line "python2 setup.py blah-blah". Because some
> > > packages still aren't touched(e.g. charm). So, something like that.
> >
> > And the dependencies must be updated from python to python2.
>
> It would probably make sense to discuss this on aur-general instead of
> arch-general.
>
> And for the affected packages you should probably write comments in the
> AUR in case a maintainer doesn't read the mailing list or has forgotten
> to updating a package.

maybe making a query to post a new comment on every AUR package that
depends on python?

--
Salud!
Nicolás Reynolds,
xmpp:fauno@kiwwwi.com.ar
omb:http://identi.ca/fauno
blog:http://selfdandi.com.ar/
gnu/linux user #455044

http://librecultivo.org.ar
http://parabolagnulinux.org
 
Old 10-20-2010, 06:00 PM
solsTiCe d'Hiver
 
Default python3 update

Le mardi 19 octobre 2010 à 18:54 +0200, Clément Démoulins a écrit :
>
> And the dependencies must be updated from python to python2.
>
also I guess something like python>2.6.5 should become python2>2.6.5
which does not make any sense since python2 in archlinux is >= 2.7
and then could be shortened into python2 , no ?
 
Old 10-20-2010, 06:13 PM
cantabile
 
Default python3 update

Le 20/10/2010 21:00, solsTiCe d'Hiver a écrit :

Le mardi 19 octobre 2010 à 18:54 +0200, Clément Démoulins a écrit :


And the dependencies must be updated from python to python2.


also I guess something like python>2.6.5 should become python2>2.6.5
which does not make any sense since python2 in archlinux is>= 2.7
and then could be shortened into python2 , no ?



Actually the last 2.6 version we had in extra provided 'python2', so you
could still end up with a python2 dependency satisfied by 2.6.x on an
outdated system
 

Thread Tools




All times are GMT. The time now is 09:52 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org