FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 10-15-2010, 01:56 PM
Nilesh Govindarajan
 
Default Anybody else having trouble with Virtualbox after upgrade

On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer <picogeyer@gmail.com> wrote:
> Hi all.
>
> I hope this is the right place for me to raise my issue.
> After doing a pacman -Syu and then rebooting I noticed that I could no
> longer start my VirtualBox vms
>
> I get the following error: Failed to open a session for the virtual
> machine My_VM
> Callee RC: NS_ERROR_INVALID_ARG (0x80070057)
> Virtualbox then crashes (segmentation fault).
>
> I had the testing repo enabled, so I thought that one of the packages
> from testing might have broken it.
> So I disabled the testing repo in pacman.conf and removed all testing
> packages with:
> pacman -Syy
> pacamn -Suu
>
> I then recompiled my virtualbox drivers and rebooted.
> But that did not help at all.
>
> I created a core dump file by following these instructions:
> http://www.virtualbox.org/wiki/Core_dump
>
> So the stack trace is 41000 lines long :-|
> I'll paste just the first and last few lines:
> #0 *0xb5cad825 in ?? () from /usr/lib/libQtGui.so.4
> #1 *0xb5ca7b27 in ?? () from /usr/lib/libQtGui.so.4
> #2 *0xb5ca9760 in QTextEngine::itemize() const () from /usr/lib/libQtGui.so.4
> #3 *0xb5caeca8 in QTextLayout::beginLayout() () from /usr/lib/libQtGui.so.4
> #4 *0xb5b9b550 in ?? () from /usr/lib/libQtGui.so.4
> #5 *0xb5b9c1b1 in ?? () from /usr/lib/libQtGui.so.4
> [snip]
> #41537 0xb5a36407 in QApplication::exec() () from /usr/lib/libQtGui.so.4
> #41538 0xb6b5405b in TrustedMain () from /usr/lib/virtualbox/VirtualBox.so
> #41539 0x08048d9f in ?? ()
> #41540 0xb76ccc76 in __libc_start_main () from /lib/libc.so.6
> #41541 0x08048c81 in ?? ()
>
>
> Any advice?
> Should I file a bug in the arch bug tracker?
> Thanks in advance.
> Pico
>

Did you rebuild the module using /etc/rc.d/vboxdrv setup?

--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
VPS Hosting: http://www.itech7.com/a/vps
 
Old 10-15-2010, 02:20 PM
Pico Geyer
 
Default Anybody else having trouble with Virtualbox after upgrade

On Fri, Oct 15, 2010 at 3:56 PM, Nilesh Govindarajan <lists@itech7.com> wrote:
> On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer <picogeyer@gmail.com> wrote:
>> Hi all.
>>
>> I hope this is the right place for me to raise my issue.
>> After doing a pacman -Syu and then rebooting I noticed that I could no
>> longer start my VirtualBox vms
>>
>> I get the following error: Failed to open a session for the virtual
>> machine My_VM
>> Callee RC: NS_ERROR_INVALID_ARG (0x80070057)
>> Virtualbox then crashes (segmentation fault).
>>
>> I had the testing repo enabled, so I thought that one of the packages
>> from testing might have broken it.
>> So I disabled the testing repo in pacman.conf and removed all testing
>> packages with:
>> pacman -Syy
>> pacamn -Suu
>>
>> I then recompiled my virtualbox drivers and rebooted.
>> But that did not help at all.
>>
>> I created a core dump file by following these instructions:
>> http://www.virtualbox.org/wiki/Core_dump
>>
>> So the stack trace is 41000 lines long :-|
>> I'll paste just the first and last few lines:
>> #0 *0xb5cad825 in ?? () from /usr/lib/libQtGui.so.4
>> #1 *0xb5ca7b27 in ?? () from /usr/lib/libQtGui.so.4
>> #2 *0xb5ca9760 in QTextEngine::itemize() const () from /usr/lib/libQtGui.so.4
>> #3 *0xb5caeca8 in QTextLayout::beginLayout() () from /usr/lib/libQtGui.so.4
>> #4 *0xb5b9b550 in ?? () from /usr/lib/libQtGui.so.4
>> #5 *0xb5b9c1b1 in ?? () from /usr/lib/libQtGui.so.4
>> [snip]
>> #41537 0xb5a36407 in QApplication::exec() () from /usr/lib/libQtGui.so.4
>> #41538 0xb6b5405b in TrustedMain () from /usr/lib/virtualbox/VirtualBox.so
>> #41539 0x08048d9f in ?? ()
>> #41540 0xb76ccc76 in __libc_start_main () from /lib/libc.so.6
>> #41541 0x08048c81 in ?? ()
>>
>>
>> Any advice?
>> Should I file a bug in the arch bug tracker?
>> Thanks in advance.
>> Pico
>>
>
> Did you rebuild the module using /etc/rc.d/vboxdrv setup?
>

Yeah, that's the first thing I tried.

Pico
 
Old 10-15-2010, 03:31 PM
Nilesh Govindarajan
 
Default Anybody else having trouble with Virtualbox after upgrade

On Fri, Oct 15, 2010 at 7:50 PM, Pico Geyer <picogeyer@gmail.com> wrote:
> On Fri, Oct 15, 2010 at 3:56 PM, Nilesh Govindarajan <lists@itech7.com> wrote:
>> On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer <picogeyer@gmail.com> wrote:
>>> Hi all.
>>>
>>> I hope this is the right place for me to raise my issue.
>>> After doing a pacman -Syu and then rebooting I noticed that I could no
>>> longer start my VirtualBox vms
>>>
>>>
>>
>> Did you rebuild the module using /etc/rc.d/vboxdrv setup?
>>
>
> Yeah, that's the first thing I tried.

Try reinstalling it, because its working here [arch64, dual core 2
ghz]. I'm using VirtualBox OSE.
Also, reinstall the dependencies too.

--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
VPS Hosting: http://www.itech7.com/a/vps
 
Old 10-15-2010, 04:08 PM
Pico Geyer
 
Default Anybody else having trouble with Virtualbox after upgrade

On Fri, Oct 15, 2010 at 5:31 PM, Nilesh Govindarajan <lists@itech7.com> wrote:
> On Fri, Oct 15, 2010 at 7:50 PM, Pico Geyer <picogeyer@gmail.com> wrote:
>> On Fri, Oct 15, 2010 at 3:56 PM, Nilesh Govindarajan <lists@itech7.com> wrote:
>>> On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer <picogeyer@gmail.com> wrote:
>>>> Hi all.
>>>>
>>>> I hope this is the right place for me to raise my issue.
>>>> After doing a pacman -Syu and then rebooting I noticed that I could no
>>>> longer start my VirtualBox vms
>>>>
>>>>
>>>
>>> Did you rebuild the module using /etc/rc.d/vboxdrv setup?
>>>
>>
>> Yeah, that's the first thing I tried.
>
> Try reinstalling it, because its working here [arch64, dual core 2
> ghz]. I'm using VirtualBox OSE.
> Also, reinstall the dependencies too.

So I did:
sudo pacman -S libxml2 libxcursor libidl2 libxinerama sdl libxmu
curl libvncserver kernel26-headers qt virtualbox-ose
warning: libxml2-2.7.7-1 is up to date -- reinstalling
warning: libxcursor-1.1.10-1 is up to date -- reinstalling
warning: libidl2-0.8.14-1 is up to date -- reinstalling
warning: libxinerama-1.1-1 is up to date -- reinstalling
warning: sdl-1.2.14-5 is up to date -- reinstalling
warning: libxmu-1.0.5-1 is up to date -- reinstalling
warning: curl-7.21.2-1 is up to date -- reinstalling
warning: libvncserver-0.9.7-3 is up to date -- reinstalling
warning: kernel26-headers-2.6.35.7-1 is up to date -- reinstalling
warning: qt-4.7.0-4 is up to date -- reinstalling
warning: virtualbox-ose-3.2.10-1 is up to date -- reinstalling

>sudo /etc/rc.d/vboxdrv setup
>sudo rmmod vboxnetflt vboxdrv
>sudo modprobe -v vboxnetflt
>VirtualBox

Still the same problem.

Do you think you could compare your package version to those listed above.

Thanks Nilesh

Regards,
Pico
 
Old 10-15-2010, 05:03 PM
Pico Geyer
 
Default Anybody else having trouble with Virtualbox after upgrade

On Fri, Oct 15, 2010 at 6:16 PM, Ionuț Bîru <ibiru@archlinux.org> wrote:
> On 10/15/2010 07:08 PM, Pico Geyer wrote:
>>
>> On Fri, Oct 15, 2010 at 5:31 PM, Nilesh Govindarajan<lists@itech7.com>
>> *wrote:
>>>
>>> On Fri, Oct 15, 2010 at 7:50 PM, Pico Geyer<picogeyer@gmail.com> *wrote:
>>>>
>>>> On Fri, Oct 15, 2010 at 3:56 PM, Nilesh Govindarajan<lists@itech7.com>
>>>> *wrote:
>>>>>
>>>>> On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer<picogeyer@gmail.com>
>>>>> *wrote:
>>>>>>
>>>>>> Hi all.
>>>>>>
>>>>>> I hope this is the right place for me to raise my issue.
>>>>>> After doing a pacman -Syu and then rebooting I noticed that I could no
>>>>>> longer start my VirtualBox vms
>>>>>>
>>>>>>
>>>>>
>>>>> Did you rebuild the module using /etc/rc.d/vboxdrv setup?
>>>>>
>>>>
>>>> Yeah, that's the first thing I tried.
>>>
>>> Try reinstalling it, because its working here [arch64, dual core 2
>>> ghz]. I'm using VirtualBox OSE.
>>> Also, reinstall the dependencies too.
>>
>> So I did:
>> sudo pacman -S libxml2 *libxcursor *libidl2 *libxinerama *sdl *libxmu
>> curl *libvncserver *kernel26-headers qt virtualbox-ose
>> warning: libxml2-2.7.7-1 is up to date -- reinstalling
>> warning: libxcursor-1.1.10-1 is up to date -- reinstalling
>> warning: libidl2-0.8.14-1 is up to date -- reinstalling
>> warning: libxinerama-1.1-1 is up to date -- reinstalling
>> warning: sdl-1.2.14-5 is up to date -- reinstalling
>> warning: libxmu-1.0.5-1 is up to date -- reinstalling
>> warning: curl-7.21.2-1 is up to date -- reinstalling
>> warning: libvncserver-0.9.7-3 is up to date -- reinstalling
>> warning: kernel26-headers-2.6.35.7-1 is up to date -- reinstalling
>> warning: qt-4.7.0-4 is up to date -- reinstalling
>> warning: virtualbox-ose-3.2.10-1 is up to date -- reinstalling
>>
>>> sudo /etc/rc.d/vboxdrv setup
>>> sudo rmmod vboxnetflt vboxdrv
>>> sudo modprobe -v vboxnetflt
>>> VirtualBox
>>
>> Still the same problem.
>>
>> Do you think you could compare your package version to those listed above.
>>
>> Thanks Nilesh
>>
>> Regards,
>> Pico
>
> you didn't said if you are on i686 or x86_64. is kinda important for me.
> also do a cat /proc/cpuinfo.
>
> next you can get rid of virtualbox-ose and install virtualbox_bin and see if
> is crashing there too, mostly to find out if is our problem or their.

Hi Ionut

Sorry about that.
I'm on i686.

cat /proc/cpuinfo:
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
stepping : 2
cpu MHz : 3197.717
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm
constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf
pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr
pdcm sse4_1 sse4_2 popcnt aes lahf_lm ida arat tpr_shadow vnmi
flexpriority ept vpid
bogomips : 6397.91
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
stepping : 2
cpu MHz : 3197.717
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 2
cpu cores : 2
apicid : 4
initial apicid : 4
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm
constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf
pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr
pdcm sse4_1 sse4_2 popcnt aes lahf_lm ida arat tpr_shadow vnmi
flexpriority ept vpid
bogomips : 6397.71
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 2
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
stepping : 2
cpu MHz : 3197.717
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm
constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf
pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr
pdcm sse4_1 sse4_2 popcnt aes lahf_lm ida arat tpr_shadow vnmi
flexpriority ept vpid
bogomips : 6397.70
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 3
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
stepping : 2
cpu MHz : 3197.717
cache size : 4096 KB
physical id : 0
siblings : 4
core id : 2
cpu cores : 2
apicid : 5
initial apicid : 5
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm
constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf
pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr
pdcm sse4_1 sse4_2 popcnt aes lahf_lm ida arat tpr_shadow vnmi
flexpriority ept vpid
bogomips : 6397.71
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

virtualbox_bin (3.2.10-1) from the Aur package works correctly.

Regards,
Pico
 
Old 10-18-2010, 04:19 PM
Matthew Gyurgyik
 
Default Anybody else having trouble with Virtualbox after upgrade

On 10/15/2010 10:20 AM, Pico Geyer wrote:

On Fri, Oct 15, 2010 at 3:56 PM, Nilesh Govindarajan<lists@itech7.com> wrote:

On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer<picogeyer@gmail.com> wrote:

Hi all.

I hope this is the right place for me to raise my issue.
After doing a pacman -Syu and then rebooting I noticed that I could no
longer start my VirtualBox vms

I get the following error: Failed to open a session for the virtual
machine My_VM
Callee RC: NS_ERROR_INVALID_ARG (0x80070057)
Virtualbox then crashes (segmentation fault).

I had the testing repo enabled, so I thought that one of the packages
from testing might have broken it.
So I disabled the testing repo in pacman.conf and removed all testing
packages with:
pacman -Syy
pacamn -Suu

I then recompiled my virtualbox drivers and rebooted.
But that did not help at all.

I created a core dump file by following these instructions:
http://www.virtualbox.org/wiki/Core_dump

So the stack trace is 41000 lines long :-|
I'll paste just the first and last few lines:
#0 0xb5cad825 in ?? () from /usr/lib/libQtGui.so.4
#1 0xb5ca7b27 in ?? () from /usr/lib/libQtGui.so.4
#2 0xb5ca9760 in QTextEngine::itemize() const () from /usr/lib/libQtGui.so.4
#3 0xb5caeca8 in QTextLayout::beginLayout() () from /usr/lib/libQtGui.so.4
#4 0xb5b9b550 in ?? () from /usr/lib/libQtGui.so.4
#5 0xb5b9c1b1 in ?? () from /usr/lib/libQtGui.so.4
[snip]
#41537 0xb5a36407 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#41538 0xb6b5405b in TrustedMain () from /usr/lib/virtualbox/VirtualBox.so
#41539 0x08048d9f in ?? ()
#41540 0xb76ccc76 in __libc_start_main () from /lib/libc.so.6
#41541 0x08048c81 in ?? ()


Any advice?
Should I file a bug in the arch bug tracker?
Thanks in advance.
Pico


Did you rebuild the module using /etc/rc.d/vboxdrv setup?


Yeah, that's the first thing I tried.

Pico

Did you reload the modules after rebuilding them?
rmmod vboxdrv; rmmod vboxnetflt; modprobe vboxdrv; modprobe vboxnetflt;
etc...
 
Old 10-19-2010, 04:37 AM
Pico Geyer
 
Default Anybody else having trouble with Virtualbox after upgrade

On Mon, Oct 18, 2010 at 6:19 PM, Matthew Gyurgyik <pyther@pyther.net> wrote:
> *On 10/15/2010 10:20 AM, Pico Geyer wrote:
>>
>> On Fri, Oct 15, 2010 at 3:56 PM, Nilesh Govindarajan<lists@itech7.com>
>> *wrote:
>>>
>>> On Fri, Oct 15, 2010 at 5:38 PM, Pico Geyer<picogeyer@gmail.com> *wrote:
>>>>
>>>> Hi all.
>>>>
>>>> I hope this is the right place for me to raise my issue.
>>>> After doing a pacman -Syu and then rebooting I noticed that I could no
>>>> longer start my VirtualBox vms
>>>>
>>>> I get the following error: Failed to open a session for the virtual
>>>> machine My_VM
>>>> Callee RC: NS_ERROR_INVALID_ARG (0x80070057)
>>>> Virtualbox then crashes (segmentation fault).
>>>>
>>>> I had the testing repo enabled, so I thought that one of the packages
>>>> from testing might have broken it.
>>>> So I disabled the testing repo in pacman.conf and removed all testing
>>>> packages with:
>>>> pacman -Syy
>>>> pacamn -Suu
>>>>
>>>> I then recompiled my virtualbox drivers and rebooted.
>>>> But that did not help at all.
>>>>
>>>> I created a core dump file by following these instructions:
>>>> http://www.virtualbox.org/wiki/Core_dump
>>>>
>>>> So the stack trace is 41000 lines long :-|
>>>> I'll paste just the first and last few lines:
>>>> #0 *0xb5cad825 in ?? () from /usr/lib/libQtGui.so.4
>>>> #1 *0xb5ca7b27 in ?? () from /usr/lib/libQtGui.so.4
>>>> #2 *0xb5ca9760 in QTextEngine::itemize() const () from
>>>> /usr/lib/libQtGui.so.4
>>>> #3 *0xb5caeca8 in QTextLayout::beginLayout() () from
>>>> /usr/lib/libQtGui.so.4
>>>> #4 *0xb5b9b550 in ?? () from /usr/lib/libQtGui.so.4
>>>> #5 *0xb5b9c1b1 in ?? () from /usr/lib/libQtGui.so.4
>>>> [snip]
>>>> #41537 0xb5a36407 in QApplication::exec() () from /usr/lib/libQtGui.so.4
>>>> #41538 0xb6b5405b in TrustedMain () from
>>>> /usr/lib/virtualbox/VirtualBox.so
>>>> #41539 0x08048d9f in ?? ()
>>>> #41540 0xb76ccc76 in __libc_start_main () from /lib/libc.so.6
>>>> #41541 0x08048c81 in ?? ()
>>>>
>>>>
>>>> Any advice?
>>>> Should I file a bug in the arch bug tracker?
>>>> Thanks in advance.
>>>> Pico
>>>>
>>> Did you rebuild the module using /etc/rc.d/vboxdrv setup?
>>>
>> Yeah, that's the first thing I tried.
>>
>> Pico
>
> Did you reload the modules after rebuilding them?
> rmmod vboxdrv; rmmod vboxnetflt; modprobe vboxdrv; modprobe vboxnetflt;
> etc...
>

Hi Matthew,

Yes I did. I've also rebooted just in case. I'm pretty sure it's not
the modules that are causing the problem.

Regards,
Pico
 

Thread Tools




All times are GMT. The time now is 10:21 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org