FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 07-05-2010, 04:45 PM
"Joe(theWordy)Philbrook"
 
Default I think...

It would appear that on Jul 5, Joe(theWordy)Philbrook did say:

> I'm still hoping that the issues I'm having with mc etc... are related to
> nomodeset rather than deeper issues. I ran a few empirical tests BTW and
> fount that if I start mc before I access more than 2 or 3 tty[1-6] consoles
> it will start. And I discovered that if I don't try to execute a subshell
> at all from any of them I can log in to all six console screens and have
> my .bash_profile get processed. But once I start spawning subshells, all
> bets are off.
--<<snip>>--
> But anyway since it doesn't look like nouveau will work properly in
> console mode for me, I tried black listing it... Then probably, I thought,
> I'll have to follow the instructions in the Nvidia wiki entry when I try
> to get x working. But I found that I'm still having issues in the
> consoles with respect to subshells and mc. I'm beginning to think I'd be
> better off reinstalling with the 64 bit iso... It won't likely solve the
> nouveau issue, but I might get back fully functional console logins.

Well I did that. But the 64 bit version was having the same problem with
the consoles... UNTIL: After I installed nvidia (which required the xorg
server) So I went right on ahead and added all the pacman -S commands
suggested in the beginners guide for installing X plus xfce4, then
followed the install instructions in the enlightenment & e17 wiki
pages... added a couple of things I was sure to need and rebooted

All the console issues with failed .bash_profile executions and problems
with subshells and mc all went away. Probably they were symptoms of not
having a working video card driver in place???
On another note however, I had managed, just prior to installing nvidia,
to get gpm working in the console via "gpm -m /dev/psaux/mice -t ps2"
And accordingly edited the /etc/conf.d/gpm file to include:
GPM_ARGS="-m /dev/psaux/mice -t ps2"
But after rebooting with a working nvidia driver the CONSOLEFONT:
"sun12x22.psfu.gz" still fails to load. (No problem there I'm getting
an 80 column display so I don't need to load larger console fonts...)
But more irritatingly: Now GPM fails to start. And I can't start it manually
either... Could it be that the nvidia drivers xorg dependency is blocking
gpm in the console??? Too bad, I like using gpm's copy/paste functions, and
wouldn't have minded setting up a /root/bin GPM init command with the
correct string to activate it when wanted, even if I needed to gpm -k
before running startx...

One other odd thing. When I tried to "man gpm" it complained that
/usr/bin/less didn't exist. So I symlinked it to /bin/less and man started
working... ???? ...

Anyway I set my {user} ~/.xinitrc for a minimal e17 start-up and startx got
me there. And the mouse worked as expected there... But I'm too tired of
all this to bother configuring all my e17 keyboard shortcuts etc... So I'm
done for now.

Thank You one and all for the kind hearted suggestions!

--
| --- ___
| <0> <-> Joe (theWordy) Philbrook
| ^ J(tWdy)P
| ~\___/~ <<jtwdyp@ttlc.net>>
 

Thread Tools




All times are GMT. The time now is 12:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org