Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux General Discussion (http://www.linux-archive.org/archlinux-general-discussion/)
-   -   Why no phonon in Qt (http://www.linux-archive.org/archlinux-general-discussion/391785-why-no-phonon-qt.html)

Shridhar Daithankar 06-28-2010 02:53 AM

Why no phonon in Qt
 
Hello,

I have removed flash after the latest problem with x86_64 release and I want
to get youtube working ASAP.

To that end, I downloaded nightly sources of webkit(not wanting to download
the entire svn checkout) and built the qt port. However the video element is
still missing, as tested on http://html5test.com.

Digging into webkit build system, I discovered that it has disabled
video/audio element support for qt port because the installed qt does not
support phonon.

from http://repos.archlinux.org/wsvn/packages/qt/repos/extra-i686/PKGBUILD,
phonon support is explicitly disabled during qt build.

I searched around but could not find a reason for the same. I really do not
want to build(more importantly maintain) my own qt build.

So why is phonon support disabled in Qt?

--
Regards
Shridhar

Caleb Cushing 06-28-2010 12:36 PM

Why no phonon in Qt
 
On Sun, Jun 27, 2010 at 10:53 PM, Shridhar Daithankar
<ghodechhap@ghodechhap.net> wrote:
> So why is phonon support disabled in Qt?
>
if memory serves correct from gentoo days it has to do with qt phonon
an kde phonon stepping on each others toes... however it might be for
different reasons in arch.


--
Caleb Cushing

http://xenoterracide.blogspot.com

Peter Lewis 06-28-2010 01:41 PM

Why no phonon in Qt
 
On Monday 28 Jun 2010 at 13:36 Caleb Cushing wrote:
> On Sun, Jun 27, 2010 at 10:53 PM, Shridhar Daithankar
>
> <ghodechhap@ghodechhap.net> wrote:
> > So why is phonon support disabled in Qt?
>
> if memory serves correct from gentoo days it has to do with qt phonon
> an kde phonon stepping on each others toes... however it might be for
> different reasons in arch.

No idea really, but a quick query tells me that phonon is provided as a
separate package:

% pacman -Qs phonon
local/phonon 4.4.2-1
The multimedia API for KDE4
local/phonon-gstreamer 4.4.2-1
Phonon Gstreamer backend

So I'm guessing that you could rebuild Qt with phonon and remove the
standalone phonon package(s) - but that might break other things that this
approach is designed to make work.

Or alternatively, can you tell webkit to look for the separate phonon that's
not provided with Qt when it builds?

Pete.

Shridhar Daithankar 06-28-2010 01:54 PM

Why no phonon in Qt
 
On Monday 28 June 2010 19:11:09 Peter Lewis wrote:
> Or alternatively, can you tell webkit to look for the separate phonon
> that's not provided with Qt when it builds?

Thats not possible. The webkit build system for qt port, looks for qt config
only. There is no way to provide it. OK, this can be forced but I am
interested in getting it working in a maintainable way)

--
Regards
Shridhar

Damjan Georgievski 06-28-2010 06:38 PM

Why no phonon in Qt
 
> I have removed flash after the latest problem with x86_64 release and I want
> to get youtube working ASAP.
>
> To that end, I downloaded nightly sources of webkit(not wanting to download
> the entire svn checkout) and built the qt port. However the video element is
> still missing, as tested on http://html5test.com.

There are 2 more options you could try too:
- use aur/minitube a really nice standalone app for watching YouTube
- use a nightly build of Firefox 3.7a/4.0 which supports WebM - its
faster and will support html5 + webM on Youtube (but afaik it's only
available on some videos)


--
damjan

Caleb Cushing 06-28-2010 08:25 PM

Why no phonon in Qt
 
On Sun, Jun 27, 2010 at 10:53 PM, Shridhar Daithankar
<ghodechhap@ghodechhap.net> wrote:
> I have removed flash after the latest problem with x86_64 release and I want
> to get youtube working ASAP.

chromium 5 suppport h264 and 6 (if you want to go there) supports
webm... I've read KDE 4.5 is supposed to have webkit support in
konqueror so maybe that will work too.

--
Caleb Cushing

http://xenoterracide.blogspot.com

Shridhar Daithankar 06-29-2010 02:53 AM

Why no phonon in Qt
 
On Tuesday 29 June 2010 00:08:15 Damjan Georgievski wrote:
> > I have removed flash after the latest problem with x86_64 release and I
> > want to get youtube working ASAP.
> >
> > To that end, I downloaded nightly sources of webkit(not wanting to
> > download the entire svn checkout) and built the qt port. However the
> > video element is still missing, as tested on http://html5test.com.
>
> There are 2 more options you could try too:
> - use aur/minitube a really nice standalone app for watching YouTube

But you need to know URL beforehand IIRC. Too much for my wife.

> - use a nightly build of Firefox 3.7a/4.0 which supports WebM - its
> faster and will support html5 + webM on Youtube (but afaik it's only
> available on some videos)
In general I use firefox only when I have to, because it does not integrate
well with KDE and I really don't like GTK looks.

--
Regards
Shridhar

Shridhar Daithankar 06-29-2010 02:54 AM

Why no phonon in Qt
 
On Tuesday 29 June 2010 01:55:39 Caleb Cushing wrote:
> On Sun, Jun 27, 2010 at 10:53 PM, Shridhar Daithankar
>
> <ghodechhap@ghodechhap.net> wrote:
> > I have removed flash after the latest problem with x86_64 release and I
> > want to get youtube working ASAP.
>
> chromium 5 suppport h264 and 6 (if you want to go there) supports
> webm... I've read KDE 4.5 is supposed to have webkit support in
> konqueror so maybe that will work too.

Why do I need yet another GTK browser when I am already tolerating firefox ?
:)

I also have kde-webkitpart installed so my konqueror and rekonq are at same
level of webkit support, i.e. what is supported by Qt4.6. So that path is not
a gain for now.
--
Regards
Shridhar

Josť M. Prieto 06-29-2010 05:35 PM

Why no phonon in Qt
 
2010/6/29 Shridhar Daithankar <ghodechhap@ghodechhap.net>:
>> chromium 5 suppport h264 and 6 (if you want to go there) supports
>> webm... I've read KDE 4.5 is supposed to have webkit support in
>> konqueror so maybe that will work too.
>
> Why do I need yet another GTK browser when I am already tolerating firefox ?
> :)
>
> I also have kde-webkitpart installed so my konqueror and rekonq are at same
> level of webkit support, i.e. what is supported by Qt4.6. So that path is not
> a gain for now.

You have to enable html5 by clicking the apropriate link in
http://www.youtube.com/html5. I can see (some) Youtube videos in
Chromium that way (Damjan is right, it is not available for all
videos).

David Rosenstrauch 06-29-2010 05:53 PM

Why no phonon in Qt
 
On 06/28/2010 10:53 PM, Shridhar Daithankar wrote:

In general I use firefox only when I have to, because it does not integrate
well with KDE and I really don't like GTK looks.


Try using gtk-qt-engine.

DR


All times are GMT. The time now is 06:44 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.