FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 06-18-2010, 12:38 PM
Nilesh Govindarajan
 
Default Upgrading from Arch 0.8 O.o

I recently got a VPS and installed arch from their control panel just to
know that it was arch 0.8 !!!

How do I upgrade from arch 0.8 to the latest ?

--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
Cheap and Reliable VPS Hosting: http://j.mp/arHk5e
 
Old 06-18-2010, 12:40 PM
Angel Velásquez
 
Default Upgrading from Arch 0.8 O.o

pacman -Syu

On Fri, Jun 18, 2010 at 9:38 AM, Nilesh Govindarajan <lists@itech7.com> wrote:
> I recently got a VPS and installed arch from their control panel just to
> know that it was arch 0.8 !!!
> How do I upgrade from arch 0.8 to the latest ?
>
> --
> Regards,
> Nilesh Govindarajan
> Facebook: http://www.facebook.com/nilesh.gr
> Twitter: http://twitter.com/nileshgr
> Website: http://www.itech7.com
> Cheap and Reliable VPS Hosting: http://j.mp/arHk5e
>
>



--
Angel Velásquez
angvp @ irc.freenode.net
Arch Linux Trusted User
Linux Counter: #359909
http://www.angvp.com
 
Old 06-18-2010, 12:44 PM
Ionuț Bîru
 
Default Upgrading from Arch 0.8 O.o

On 06/18/2010 03:38 PM, Nilesh Govindarajan wrote:

I recently got a VPS and installed arch from their control panel just to
know that it was arch 0.8 !!!
How do I upgrade from arch 0.8 to the latest ?



you should ask them to get the latest openvz template:

http://download.openvz.org/contrib/template/precreated/arch-2010.05-i686-minimal.tar.gz
http://download.openvz.org/contrib/template/precreated/arch-2010.05-x86_64-minimal.tar.gz

those are created by me and mostly because nobody cared for so many years

--
IonuÈ›
 
Old 06-18-2010, 12:49 PM
Nilesh Govindarajan
 
Default Upgrading from Arch 0.8 O.o

On 06/18/2010 06:10 PM, Angel Velásquez wrote:

pacman -Syu

On Fri, Jun 18, 2010 at 9:38 AM, Nilesh Govindarajan<lists@itech7.com> wrote:

I recently got a VPS and installed arch from their control panel just to
know that it was arch 0.8 !!!
How do I upgrade from arch 0.8 to the latest ?

--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
Cheap and Reliable VPS Hosting: http://j.mp/arHk5e







In order to refresh the db, I ran pacman -Sy which gives this error:
config: line 1: all directives must belong to a section
config: line 1: all directives must belong to a section
config: line 1: all directives must belong to a section
:: Synchronizing package databases...
failed to synchronize current
failed to synchronize extra
error: could not open sync database: current
have you used --refresh yet?


--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
Cheap and Reliable VPS Hosting: http://j.mp/arHk5e
 
Old 06-18-2010, 12:50 PM
Nilesh Govindarajan
 
Default Upgrading from Arch 0.8 O.o

On 06/18/2010 06:14 PM, Ionuț Bîru wrote:

On 06/18/2010 03:38 PM, Nilesh Govindarajan wrote:

I recently got a VPS and installed arch from their control panel just to
know that it was arch 0.8 !!!
How do I upgrade from arch 0.8 to the latest ?



you should ask them to get the latest openvz template:

http://download.openvz.org/contrib/template/precreated/arch-2010.05-i686-minimal.tar.gz

http://download.openvz.org/contrib/template/precreated/arch-2010.05-x86_64-minimal.tar.gz


those are created by me and mostly because nobody cared for so many
years

I managed to get arch with them after a lot of push, anyway, leave that
part.


--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
Cheap and Reliable VPS Hosting: http://j.mp/arHk5e
 
Old 06-18-2010, 01:07 PM
Fabiano Furtado Pessoa Coelho
 
Default Upgrading from Arch 0.8 O.o

Well... there's a problem because the arch's package format has
changed (from .pkg.tar.gz to .pkg.tar.xz)!

Try yourself to install pacman's package manually (and his dependencies).

It should work!

Sorry about my english.

On Fri, Jun 18, 2010 at 9:38 AM, Nilesh Govindarajan <lists@itech7.com> wrote:
> I recently got a VPS and installed arch from their control panel just to
> know that it was arch 0.8 !!!
> How do I upgrade from arch 0.8 to the latest ?
>
> --
> Regards,
> Nilesh Govindarajan
> Facebook: http://www.facebook.com/nilesh.gr
> Twitter: http://twitter.com/nileshgr
> Website: http://www.itech7.com
> Cheap and Reliable VPS Hosting: http://j.mp/arHk5e
 
Old 06-18-2010, 01:26 PM
Thomas Bächler
 
Default Upgrading from Arch 0.8 O.o

Am 18.06.2010 14:38, schrieb Nilesh Govindarajan:
> I recently got a VPS and installed arch from their control panel just to
> know that it was arch 0.8 !!!
> How do I upgrade from arch 0.8 to the latest ?
>

I don't think you can:
http://mailman.archlinux.org/pipermail/arch-dev-public/2010-June/017096.html
 
Old 06-18-2010, 02:26 PM
Nilesh Govindarajan
 
Default Upgrading from Arch 0.8 O.o

Its over finally. Some tar -xf stuff, etc. made it possible
Basically upgraded pacman and its deps directly from archlinux.org as
someone suggested. Thanks to that one !


--
Regards,
Nilesh Govindarajan
Facebook: http://www.facebook.com/nilesh.gr
Twitter: http://twitter.com/nileshgr
Website: http://www.itech7.com
Cheap and Reliable VPS Hosting: http://j.mp/arHk5e
 
Old 06-18-2010, 02:43 PM
Damjan Georgievski
 
Default Upgrading from Arch 0.8 O.o

>> I recently got a VPS and installed arch from their control panel just to
>> know that it was arch 0.8 !!!
>> How do I upgrade from arch 0.8 to the latest ?
>>
>
> you should ask them to get the latest openvz template:
>
> http://download.openvz.org/contrib/template/precreated/arch-2010.05-i686-minimal.tar.gz
> http://download.openvz.org/contrib/template/precreated/arch-2010.05-x86_64-minimal.tar.gz
>
> those are created by me and mostly because nobody cared for so many years

is there anything OpenVZ specific or it will work under LXC too?



--
damjan
 
Old 06-18-2010, 02:45 PM
Ionuț Bîru
 
Default Upgrading from Arch 0.8 O.o

On 06/18/2010 05:43 PM, Damjan Georgievski wrote:

I recently got a VPS and installed arch from their control panel just to
know that it was arch 0.8 !!!
How do I upgrade from arch 0.8 to the latest ?



you should ask them to get the latest openvz template:

http://download.openvz.org/contrib/template/precreated/arch-2010.05-i686-minimal.tar.gz
http://download.openvz.org/contrib/template/precreated/arch-2010.05-x86_64-minimal.tar.gz

those are created by me and mostly because nobody cared for so many years


is there anything OpenVZ specific or it will work under LXC too?





no idea what LXC is. just try it

--
IonuÈ›
 

Thread Tools




All times are GMT. The time now is 08:36 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org