FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 06-12-2010, 09:22 AM
 
Default help with synce?

Greetings,
I recently migrated to archlinux and over-all find it quite good. I have had much success using the wiki to get my system set up and configured to my liking.

So far, I only have one issue I can't resolve. I am trying to get SynCE working on my system so I can transfer material between my laptop and a mobile device.

Some potentially useful information: I'm running 32-bitt archlinux with the gnome desktop. I received the mobile device (a Braillenote) in the summer of 2001, so it's running an old version of WindowsCE (and slightly modified to interact with the braille input/output). I used to have synCE working on a previous Linux installation (*not* archlinux) using synce-serial and odccm to connect through a USB-serial bridge.

I used pacman to install synce-libsynce, synce-librapi, synce-serial and synce-odccm (the packages required to get the connection to work on my old system). I ran synce-serial-config ttyUSB0 which, from the output, appeared to work correctly. But when I run odccm and try to connect with synce-serial-start, it appears the connection is established and dropped again in an instant. Synce-serialstart provides the basic message that I'm used to seeing when it makes a connection, nd my mobile device chirps to indicate it's connected, but it quickly makes the disconnect tone right after, and any subsequent attempt to interact with the mobile device using pcp, pls etc produce failure messages that neither hal nor odccm can find a connection.

The resulting message from odccm is:

$ sudo odccm -f -l 6
Password:
** (odccm:2550): DEBUG: _odccm_interface_address: waiting for IP address on ppp0
** (odccm:2550): DEBUG: _odccm_interface_address: waiting for IP address on ppp0
** (odccm:2550): DEBUG: _odccm_interface_address: waiting for IP address on ppp0
** (odccm:2550): DEBUG: _odccm_interface_address: waiting for IP address on ppp0
** (odccm:2550): DEBUG: _odccm_interface_address: waiting for IP address on ppp0
process 2550: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 278.
This is normally a bug in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
Aborted

I'm working with the synce-users list to trouble-shoot the issue, but thought maybe someon on the arch mailing list might have insight into the problem.
__________________________________________________ _______________
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail.
http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLM TAGL:ON:WL:en-US:WM_HMP:042010_5
 

Thread Tools




All times are GMT. The time now is 08:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org