FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 04-02-2010, 01:31 AM
Nilesh Govindarajan
 
Default An amazing disk problem !

Hi,

I'm having an amazing disk problem. My disk has LVM configured. /home
and swap sits on LVM, while / is direct.


USELVM=yes is enabled in /etc/rc.conf and also it is there in
mkinitcpio.conf


The problem is that, sometimes when I boot, fsck complains that it
wasn't able to find a ext2 superblock, and drops me to a sulogin shell.
Now if I run fsck -vyf /home, it works. Even if fsck isn't run, it
mounts properly using the command mount /home.


Now again when I restart, it will say the same thing or boot properly
(seems like a random choice ).


At last fed up, I issued the following commands at the sulogin shell:

mount -o remount,rw /
hostname Linux (yeah that's my hostname)
mount /home
init 5

And it worked successfully.

Any ideas about this AMAZING problem ??!?!?

--
Nilesh Govindarajan
Site & Server Administrator
www.itech7.com
मेरा *ारत महान !
मम *ारत: महत्तम *वतु !
 

Thread Tools




All times are GMT. The time now is 02:53 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org