FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 03-17-2010, 09:15 PM
"Joe(theWordy)Philbrook"
 
Default fdisk vs cfdisk... And is my drive borked or what?

I'm new to Arch. I recently dumped a very bloated Sabayon installation
which left me enough room on my laptop for two other distros... I went with
PCLinuxOS AND Arch because both sounded like reinstalling from scratch
wasn't a twice a year thing...

Actually I tried installing PCLinuxOS on a usb drive before I dumped Sabayon.
But something went wrong in the first attempt when the installer formatted
the new PCLinuxOS root partition on /dev/sda (as it called my usb drive)
and promptly wrote the partition table to /dev/hdb (as it called my
laptop's internal drive... ARGH! Fortunately after a send attempt succeeded
in installing to usb drive succeeded some tool called "testdisk: was able
to restore my laptop's partition table. And every thing worked again...
(That was the last time I'll ever let an installer format anything.
Strictly pre-partition and pre-mkfs from now on...)

Any way I only mention it because When I got around to installing Arch on
one of the two partitions I recovered from Sabayon, I skipped the
installation step of letting cfdisk touch my partitions and simply selected
the partition I previously prepared for it with mkfs.ext3. But later as
working my way through the beginners guide in the wiki, the clear
explanation of why distro's like to use UUID instead of /dev/Xdx# sold me
on using persistent (BUT HUMAN READABLE!!!) entries like:
"/dev/disk/by-label/Arch_lap-7" & "/dev/disk/by-label/SWP_lap-12"
Especially since there was a wealth of how-to info right there in the
wiki... But in the process I happened to do an:
fdisk /dev/sda

Which complained about a dos compatibility flag and that I should
change the display/entry units to sectors. This showed me a small bit of unused
space above my last logical partition (/dev/sda12)...

Anyway I decided to look at it with cfdisk (which I haven't used in years
but remembered as being easier to work with than fdisk...) But all I got
from cfdisk was.

=> FATAL ERROR: Bad primary partition 3: Partition ends after end-of-disk
=> Press any key to exit cfdisk

Which considering the recent "testdisk" repair, frightened be a bit. But it
also frustrated me. Especially since fdisk didn't show anything like that...

Unless maybe: When "cfdisk /dev/sda" says "partition 3:" is it counting from 0?
That is, does it mean "/dev/sda4" ???

Because that's my extended partition... And a close look at the ending
cylinder/sector of /dev/sda4 is a slightly higher number than it reports
the total cylinders/sectors to be...

I've pasted both the sector and cylinder views of my part table below, Is
this anything I should be worried about??? Is there a way to fix this
without destroying everything in the extended partition??? (That's a LOT of
backing up to dvd, and I don't have room anyplace else...)

--
| ~^~ ~^~
| <?> <?> Joe (theWordy) Philbrook
| ^ J(tWdy)P
| \___/ <<jtwdyp@ttlc.net>>


Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4573c650

Device Boot Start End Blocks Id System
/dev/sda1 * 63 55456379 27728158+ 7 HPFS/NTFS
/dev/sda2 55456380 68372639 6458130 c W95 FAT32 (LBA)
/dev/sda3 68372640 70332569 979965 83 Linux
/dev/sda4 70332570 234452609 82060020 f W95 Ext'd (LBA)
/dev/sda5 70332633 103538924 16603146 83 Linux
/dev/sda6 103538988 136745279 16603146 83 Linux
/dev/sda7 136745343 169951634 16603146 83 Linux
/dev/sda8 169951698 175815359 2931831 83 Linux
/dev/sda9 175815423 183622949 3903763+ 83 Linux
/dev/sda10 183623013 195334334 5855661 83 Linux
/dev/sda11 195334398 232444484 18555043+ 83 Linux
/dev/sda12 232444548 234436544 995998+ 82 Linux swap / Solaris


Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4573c650

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3452 27728158+ 7 HPFS/NTFS
/dev/sda2 3453 4256 6458130 c W95 FAT32 (LBA)
/dev/sda3 4257 4378 979965 83 Linux
/dev/sda4 4379 14594 82060020 f W95 Ext'd (LBA)
/dev/sda5 4379 6445 16603146 83 Linux
/dev/sda6 6446 8512 16603146 83 Linux
/dev/sda7 8513 10579 16603146 83 Linux
/dev/sda8 10580 10944 2931831 83 Linux
/dev/sda9 10945 11430 3903763+ 83 Linux
/dev/sda10 11431 12159 5855661 83 Linux
/dev/sda11 12160 14469 18555043+ 83 Linux
/dev/sda12 14470 14593 995998+ 82 Linux swap / Solaris
 

Thread Tools




All times are GMT. The time now is 09:54 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org