FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux General Discussion

 
 
LinkBack Thread Tools
 
Old 03-11-2010, 01:42 PM
Nezmer
 
Default .pyo files in twisted package

Hi,

I don't know If this has been brought up before.

The PKGBUILD includes "--optimize=1". So .pyo files are included in
the package and they conflict with existing ones.

Is there a reason to do this for twisted specifically? Or did I miss a
change in python packaging policies?
 
Old 03-11-2010, 03:23 PM
Pierre Chapuis
 
Default .pyo files in twisted package

On Thu, 11 Mar 2010 16:42:08 +0200, Nezmer <arch@nezmer.info> wrote:
> Hi,
>
> I don't know If this has been brought up before.
>
> The PKGBUILD includes "--optimize=1". So .pyo files are included in
> the package and they conflict with existing ones.
>
> Is there a reason to do this for twisted specifically? Or did I miss a
> change in python packaging policies?

You missed a change in the packaging policy:
http://bugs.archlinux.org/task/17376

--
catwell
 
Old 03-11-2010, 03:33 PM
Nezmer
 
Default .pyo files in twisted package

On Thu, Mar 11, 2010 at 05:23:40PM +0100, Pierre Chapuis wrote:
> On Thu, 11 Mar 2010 16:42:08 +0200, Nezmer <arch@nezmer.info> wrote:
> > Hi,
> >
> > I don't know If this has been brought up before.
> >
> > The PKGBUILD includes "--optimize=1". So .pyo files are included in
> > the package and they conflict with existing ones.
> >
> > Is there a reason to do this for twisted specifically? Or did I miss a
> > change in python packaging policies?
>
> You missed a change in the packaging policy:
> http://bugs.archlinux.org/task/17376
>
I missed that indeed.
Thank you for the reply.
 
Old 03-11-2010, 08:10 PM
Allan McRae
 
Default .pyo files in twisted package

On 12/03/10 02:33, Nezmer wrote:

On Thu, Mar 11, 2010 at 05:23:40PM +0100, Pierre Chapuis wrote:

On Thu, 11 Mar 2010 16:42:08 +0200, Nezmer<arch@nezmer.info> wrote:

Hi,

I don't know If this has been brought up before.

The PKGBUILD includes "--optimize=1". So .pyo files are included in
the package and they conflict with existing ones.

Is there a reason to do this for twisted specifically? Or did I miss a
change in python packaging policies?


You missed a change in the packaging policy:
http://bugs.archlinux.org/task/17376


I missed that indeed.
Thank you for the reply.



I plan to make that more universal when we transition from python-2.x to
python-3.x (when python-2.7 is released).
 

Thread Tools




All times are GMT. The time now is 09:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org