Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux Development (http://www.linux-archive.org/archlinux-development/)
-   -   Xorg-server 1.13/Mesa move to testing (http://www.linux-archive.org/archlinux-development/710117-xorg-server-1-13-mesa-move-testing.html)

Andreas Radke 10-06-2012 07:07 PM

Xorg-server 1.13/Mesa move to testing
 
The driver rebuilds in staging are done. So far these two drivers won't
build with the new 1.13 server (xaa acceleration has been removed):

sisimedia, unichrome

If we won't find a fix these will be removed from our repos. All other
drivers need some testing when they hit the testing repo. I'm going to
push all Xorg/Mesa packages to testing even when Mesa is still not
released. This will happen pretty soon and shouldn't harm our real life
testing. I'll keep updating mesa in testing then.

Xorg-xfs is useless nowadays and will be removed from the repos when
new Xorg hits extra.

-Andy

Thomas Bächler 10-10-2012 12:23 PM

Xorg-server 1.13/Mesa move to testing
 
Am 06.10.2012 21:07, schrieb Andreas Radke:
> The driver rebuilds in staging are done. So far these two drivers won't
> build with the new 1.13 server (xaa acceleration has been removed):

I get font rendering issues since this upgrade:

removed libva-driver-intel (1.0.18-1)
upgraded bind (9.9.1.P3-1 -> 9.9.2-1)
upgraded dnsutils (9.9.1.P3-1 -> 9.9.2-1)
upgraded firefox (15.0.1-1 -> 16.0-1)
upgraded firefox-i18n-de (15.0.1-1 -> 16.0-1)
upgraded libglapi (8.99.git_20121006-1 -> 9.0-1)
upgraded libgl (8.99.git_20121006-1 -> 9.0-1)
upgraded intel-dri (8.99.git_20121006-1 -> 9.0-1)
upgraded khrplatform-devel (8.99.git_20121006-1 -> 9.0-1)
upgraded lib32-dbus-core (1.6.4-1 -> 1.6.8-1)
upgraded lib32-gcc-libs (4.7.1-6 -> 4.7.2-1)
upgraded lib32-libltdl (2.4.2-6 -> 2.4.2-7)
upgraded lib32-libtiff (4.0.2-1 -> 4.0.3-1)
upgraded libgbm (8.99.git_20121006-1 -> 9.0-1)
upgraded libegl (8.99.git_20121006-1 -> 9.0-1)
upgraded libgles (8.99.git_20121006-1 -> 9.0-1)
upgraded libva (1.1.0-1 -> 1.1.0-2)
installed libva-intel-driver (1.0.18-1)
upgraded mesa (8.99.git_20121006-1 -> 9.0-1)
upgraded subversion (1.7.6-1 -> 1.7.7-1)
upgraded wine (1.5.14-1 -> 1.5.14-2)

Sometimes, font is not rendered at all, sometimes replaces with
hyroglyph-like stuff: http://i.imgur.com/A5JcX.png

I can reproduce and fix this by forcing it to render text again (marking
text, switching desktops, printing new text, scrolling).

This mostly happens on firefox and thunderbird, but on occasion also in KDE.

I didn't see this problem with the 8.99 mesa version, but I only used
that for about a day.

Thomas Bächler 10-11-2012 04:18 PM

Xorg-server 1.13/Mesa move to testing
 
Am 10.10.2012 14:23, schrieb Thomas Bächler:
> Am 06.10.2012 21:07, schrieb Andreas Radke:
>> The driver rebuilds in staging are done. So far these two drivers won't
>> build with the new 1.13 server (xaa acceleration has been removed):
>
> I get font rendering issues since this upgrade:

I can't reproduce those problems anymore.


All times are GMT. The time now is 02:28 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.