FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 06-26-2012, 08:10 PM
Rémy Oudompheng
 
Default TeXlive 2012 packages

Hello,

I am going to put Texlive 2012 packages in [testing]. Texlive 2012 is
not yet released, but it is frozen, so I do not expect changes to
these packages except to fix packaging errors.
Please try them and complain on mailing lists. Don't hesitate to
compile your own theses, memoirs or books.

Regards,
Rémy.
 
Old 06-26-2012, 08:10 PM
Rémy Oudompheng
 
Default TeXlive 2012 packages

Hello,

I am going to put Texlive 2012 packages in [testing]. Texlive 2012 is
not yet released, but it is frozen, so I do not expect changes to
these packages except to fix packaging errors.
Please try them and complain on mailing lists. Don't hesitate to
compile your own theses, memoirs or books.

Regards,
Rémy.
 
Old 06-27-2012, 01:21 AM
Eric Bélanger
 
Default TeXlive 2012 packages

On Tue, Jun 26, 2012 at 4:10 PM, Rémy Oudompheng
<remyoudompheng@gmail.com> wrote:
> Hello,
>
> I am going to put Texlive 2012 packages in [testing]. Texlive 2012 is
> not yet released, but it is frozen, so I do not expect changes to
> these packages except to fix packaging errors.
> Please try them and complain on mailing lists. Don't hesitate to
> compile your own theses, memoirs or books.
>
> Regards,
> Rémy.

When updating, I'm getting this error. I don't know if it's an error
with the package or a config on my system:

>>> texlive: updating the fontmap files with updmap...
updmap: generated map uptex-noEmbed.map (from
uptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating
it!
updmap: generated map otf-noEmbed.map (from otf-@kanjiEmbed@.map) does
not exists, not activating it!
updmap: generated map otf-up-noEmbed.map (from
otf-up-@kanjiEmbed@.map) does not exists, not activating it!
updmap: generated map ptex-noEmbed.map (from
ptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating
it!

ERROR: The following map file(s) couldn't be found:
arabi.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
arabtex.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
arevvn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
bkaiu.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
bsmiu.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
burmese.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
cbgreek-full.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
chartervn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
cjhebrew.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
cmbrightvn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
cmcyr.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
concretevn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
dgj.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
dmj.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
dvng.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
ethiop.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
garuda-c90.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
gbsnu.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
gfsbaskerville.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
gfsporson.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
gkaiu.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
grotesqvn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
grverb.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
iby.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
kerkis.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
mc2j.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
mcj.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
mongolian.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
morisawa.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
mr2j.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
mrj.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
norasi-c90.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
otf-cktx.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
skt.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
tlwg.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
txttvn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
umj.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
urwvn.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
vnrother.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
vnrtext.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
vntopia.map (in /usr/share/texmf-dist/web2c/updmap.cfg)

Did you run mktexlsr?

You can disable non-existent map entries using the option
--syncwithtrees.

done.
 
Old 06-27-2012, 01:29 AM
Dan McGee
 
Default TeXlive 2012 packages

On Tue, Jun 26, 2012 at 8:21 PM, Eric Bélanger <snowmaniscool@gmail.com> wrote:
> On Tue, Jun 26, 2012 at 4:10 PM, Rémy Oudompheng
> <remyoudompheng@gmail.com> wrote:
>> Hello,
>>
>> I am going to put Texlive 2012 packages in [testing]. Texlive 2012 is
>> not yet released, but it is frozen, so I do not expect changes to
>> these packages except to fix packaging errors.
>> Please try them and complain on mailing lists. Don't hesitate to
>> compile your own theses, memoirs or books.
>>
>> Regards,
>> Rémy.
>
> When updating, I'm getting this error. I don't know if it's an error
> with the package or a config on my system:
>
>>>> texlive: updating the fontmap files with updmap...
> updmap: generated map uptex-noEmbed.map (from
> uptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating
> it!

I got this same thing just now. I had to move the udpmap.cfg.pacnew
file in /etc/ to the original name and then reinstall texlive-bin in
order to get this working.

With that said, this was less than intuitive and not very
user-friendly to expect all our users to figure this out on their
own...

-Dan
 
Old 06-27-2012, 02:00 AM
Eric Bélanger
 
Default TeXlive 2012 packages

On Tue, Jun 26, 2012 at 9:29 PM, Dan McGee <dpmcgee@gmail.com> wrote:
> On Tue, Jun 26, 2012 at 8:21 PM, Eric Bélanger <snowmaniscool@gmail.com> wrote:
>> On Tue, Jun 26, 2012 at 4:10 PM, Rémy Oudompheng
>> <remyoudompheng@gmail.com> wrote:
>>> Hello,
>>>
>>> I am going to put Texlive 2012 packages in [testing]. Texlive 2012 is
>>> not yet released, but it is frozen, so I do not expect changes to
>>> these packages except to fix packaging errors.
>>> Please try them and complain on mailing lists. Don't hesitate to
>>> compile your own theses, memoirs or books.
>>>
>>> Regards,
>>> Rémy.
>>
>> When updating, I'm getting this error. I don't know if it's an error
>> with the package or a config on my system:
>>
>>>>> texlive: updating the fontmap files with updmap...
>> updmap: generated map uptex-noEmbed.map (from
>> uptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating
>> it!
>
> I got this same thing just now. I had to move the udpmap.cfg.pacnew
> file in /etc/ to the original name and then reinstall texlive-bin in
> order to get this working.

I did that but I still have this error for some texlive packages:

texlive-core
texlive-fontsextra
texlive-games
texlive-latexextra
texlive-music
texlive-pictures
texlive-science


>
> With that said, this was less than intuitive and not very
> user-friendly to expect all our users to figure this out on their
> own...
>
> -Dan
 
Old 06-27-2012, 03:10 AM
Genes MailLists
 
Default TeXlive 2012 packages

On 06/26/2012 04:10 PM, Rémy Oudompheng wrote:
...


Please try them and complain on mailing lists. Don't hesitate to
compile your own theses, memoirs or books.


Getting several errors some similar to others some different

gene/

===========

recreating all formats...Error: `pdftex -ini -jobname=eplain
-progname=eplain -translate-file=cp227.tcx *eplain.ini' failed
Error: `pdftex -ini -jobname=jadetex -progname=jadetex *jadetex.ini'
failed
Error: `pdftex -ini -jobname=pdfjadetex -progname=pdfjadetex
*pdfjadetex.ini' failed
Error: `pdftex -ini -jobname=latex -progname=latex
-translate-file=cp227.tcx *latex.ini' failed
Error: `pdftex -ini -jobname=pdflatex -progname=pdflatex
-translate-file=cp227.tcx *pdflatex.ini' failed
Error: `pdftex -ini -jobname=mllatex -progname=mllatex
-translate-file=cp227.tcx -mltex mllatex.ini' failed
Error: `pdftex -ini -jobname=pdftex -progname=pdftex
-translate-file=cp227.tcx *pdfetex.ini' failed
Error: `pdftex -ini -jobname=etex -progname=etex
-translate-file=cp227.tcx *etex.ini' failed
Error: `pdftex -ini -jobname=pdfetex -progname=pdfetex
-translate-file=cp227.tcx *pdfetex.ini' failed

Error: `xetex -ini -jobname=xetex -progname=xetex -etex xetex.ini' failed
Error: `xetex -ini -jobname=xelatex -progname=xelatex -etex
xelatex.ini' failed

Error: `pdftex -ini -jobname=xmltex -progname=xmltex *xmltex.ini' failed
Error: `pdftex -ini -jobname=pdfxmltex -progname=pdfxmltex
*pdfxmltex.ini' failed


################################################## #############################


fmtutil: Error! Not all formats have been built successfully.
Visit the log files in directory
/var/lib/texmf/web2c
for details.
################################################## #############################



ERROR: The following map file(s) couldn't be found:
CountriesOfEurope.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
aspectratio.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
mdsymbol.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
ntx.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
sansmathaccent.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
tlwg.map (in /usr/share/texmf-dist/web2c/updmap.cfg)

ERROR: The following map file(s) couldn't be found:
tlwg.map (in /usr/share/texmf-dist/web2c/updmap.cfg)

Did you run mktexlsr?
 
Old 06-27-2012, 03:21 AM
Genes MailLists
 
Default TeXlive 2012 packages

Update:

After installing and getting errors - I re-installed all the texlive
2012 packages again - this time there are no errors - and now I can use
texlive (it was totally broken before the second install).


gene
 
Old 06-27-2012, 05:06 AM
Vladimir Lomov
 
Default TeXlive 2012 packages

Hello,
** Rémy Oudompheng [2012-06-26 22:10:11 +0200]:

[I don't have permission to post on arch-dev- ML, so I reply to general
hoping that Rémy will see it]

> Hello,

> I am going to put Texlive 2012 packages in [testing]. Texlive 2012 is
> not yet released, but it is frozen, so I do not expect changes to
> these packages except to fix packaging errors.
> Please try them and complain on mailing lists. Don't hesitate to
> compile your own theses, memoirs or books.

> Regards,
> Rémy.

I already saw several replies on problem with installation of 2012
packages but I didn't face any problem on my side. This may be because I
fixed earlier the problem with updmap.cfg (/etc/texmf/web2c/updmap.cfg)
or may be because I have separately installed TL 2012.

Small note: I suggest to add that line
unset TEXMFCNF
in .install file for any texlive package.

---
WBR, Vladimir Lomov

--
XXXVI:
The thickness of the proposal required to win a multimillion dollar
contract is about one millimeter per million dollars. If all the
proposals conforming to this standard were piled on top of each other
at the bottom of the Grand Canyon it would probably be a good idea.
XXXVII:
Ninety percent of the time things will turn out worse than you expect.
The other 10 percent of the time you had no right to expect so much.
XXXVIII:
The early bird gets the worm.
The early worm ... gets eaten.
XXXIX:
Never promise to complete any project within six months of the end of
the year -- in either direction.
XL:
Most projects start out slowly -- and then sort of taper off.
-- Norman Augustine
 
Old 06-27-2012, 06:16 AM
Rémy Oudompheng
 
Default TeXlive 2012 packages

On 2012/6/27 Eric Bélanger <snowmaniscool@gmail.com> wrote:
> When updating, I'm getting this error. I don't know if it's an error
> with the package or a config on my system:
>
>>>> texlive: updating the fontmap files with updmap...
> updmap: generated map uptex-noEmbed.map (from
> uptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating
> it!

There is conflict between /etc/texmf/web2c/updmap.cfg and
/usr/share/texmf-dist/web2c/updmap.cfg. The latter refers to all map
files (even uninstalled ones) and is proposed by upstream. Since we
use our own version, I think we should not ship the upstream one.

updmap.cfg is auto-generated at install time nd should not create a
.pacnew anyway.

Rémy.
 
Old 06-27-2012, 06:18 AM
Rémy Oudompheng
 
Default TeXlive 2012 packages

On 2012/6/27 Genes MailLists <lists@sapience.com> wrote:
> Update:
>
> * * * *After installing and getting errors - I re-installed all the texlive
> 2012 packages again - this time there are no errors - and now I can use
> texlive (it was totally broken before the second install).
>
> *gene

I would have needed the logs of failed format generation to debug.
Smooth upgrade paths have always been an issue with Texlive packages.
I'll try a bit more.

Rémy.
 

Thread Tools




All times are GMT. The time now is 07:07 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org