FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 05-01-2012, 11:24 AM
Pierre Schmitz
 
Default PHP updated to version 5.4.1

Here is a news draft for the move of the php packages to [extra] which
should happen later this week. Let me know if I miss anything or how I
could improve this news item.

---
PHP has been updated to its latest major release 5.4. The upstream
changelog can be found at http://php.net/ChangeLog-5.php, a detailed
migration guide is at http://de.php.net/migration54.

In addition to this the following packaging changes have been made:
* The Suhosin patch and extension have been removed. Learn more about
the reasoning behind this decision at
https://pierre-schmitz.com/php-5-4-1-in-suhosin-out/
* The json module is now built into PHP itself. Therefor remove the
"extension=json.so" directive from your php.ini file.
* The gd extension has been built with webp support using the libvpx
library.

Make sure to merge the changes of php.ini into your local copy; or
probably easier: adjust the new php.ini to your needs.

Last but not least: especially if you are running old scripts make sure
they do not rely on features like Safe Mode or Magic Quotes. As these
features were removed an update to PHP 5.4 will result in serious
security holes.

--
Pierre Schmitz, https://pierre-schmitz.com
 
Old 05-01-2012, 11:29 AM
Pierre Schmitz
 
Default PHP updated to version 5.4.1

Am 01.05.2012 13:24, schrieb Pierre Schmitz:
> * The Suhosin patch and extension have been removed.

Great, here is what I forgot:
---

If you had used the suhosin extension before remove the php-suhosin
package as it is no longer compatible with PHP 5.4

* Note that the extension API has been changed. If you are using any
third party extensions that are not in our repositories you have to at
least recompile them or update to a compatible version.

--
Pierre Schmitz, https://pierre-schmitz.com
 
Old 05-01-2012, 05:06 PM
Eric Bélanger
 
Default PHP updated to version 5.4.1

On Tue, May 1, 2012 at 7:24 AM, Pierre Schmitz <pierre@archlinux.de> wrote:
> Here is a news draft for the move of the php packages to [extra] which
> should happen later this week. Let me know if I miss anything or how I
> could improve this news item.
>
> ---
> PHP has been updated to its latest major release 5.4. The upstream
> changelog can be found at http://php.net/ChangeLog-5.php, a detailed
> migration guide is at http://de.php.net/migration54.
>
> In addition to this the following packaging changes have been made:
> * The Suhosin patch and extension have been removed. Learn more about
> the reasoning behind this decision at
> https://pierre-schmitz.com/php-5-4-1-in-suhosin-out/
> * The json module is now built into PHP itself. Therefor remove the

typo, add comma:
Therefor -> Therefore,


> "extension=json.so" directive from your php.ini file.
> * The gd extension has been built with webp support using the libvpx
> library.
>
> Make sure to merge the changes of php.ini into your local copy; or
> probably easier: adjust the new php.ini to your needs.
>
> Last but not least: especially if you are running old scripts make sure

maybe add comma:

old scripts -> old scripts,

> they do not rely on features like Safe Mode or Magic Quotes. As these
> features were removed an update to PHP 5.4 will result in serious


add comma:

were removed -> were removed,

> security holes.
>
> --
> Pierre Schmitz, https://pierre-schmitz.com
 

Thread Tools




All times are GMT. The time now is 05:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org