FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 12-19-2011, 05:19 PM
Andrea Scarpino
 
Default + qtwebkit package

AndreaOn Monday 19 December 2011 19:17:08 Scarpino wrote:
> Hi all,
> the last Qt major release is in [testing].
> For the upstream changes see the Qt ChangeLog[1].
>
> About the Arch Linux packaging, the libqtwebkit library isn't shipped with
the
> qt package anymore, but with the new qtwebkit package.
>
> We rebuilt our packages in [extra] and [community] to add this new
dependence.
> If you find a package which links to libQtWebKit.so.4, but doesn't depend on
> qtwebkit, please report us the bug using bugs.archlinux.org.
>
> AUR maintainers are encouraged to check their packages to see if they links
to
> libQtWebKit.so.4, then add the new dependence.
>
> [1] http://labs.qt.nokia.com/2011/12/15/qt-4-8-0-released/
I forgot to say that mixxx cannot be rebuilt ATM[1], so until this isn't fixed
mixxx users have to install qtwebkit too.

Also, qtscriptgenerator doesn't build too.

[1] https://bugs.archlinux.org/task/26603
[2] https://bugs.archlinux.org/task/26604

--
Andrea
 
Old 12-19-2011, 06:04 PM
Andrea Scarpino
 
Default + qtwebkit package

On Monday 19 December 2011 20:22:53 Ionut Biru wrote:
> How much time to you estimate it will stay in testing?
>
> I don't want to block again other rebuilds
The plasma crash on logout is gone, but I don't know about the font bug
(FS#26624). I guess that a couple of days is fine if that is fixed too.

--
Andrea
 
Old 12-19-2011, 07:33 PM
Andrea Scarpino
 
Default + qtwebkit package

On Monday 19 December 2011 20:42:12 Pierre Schmitz wrote:
> Font rendering is still broken with the final version of Qt 4.8. Both
> upstream bug reports are still open.
Can you confirm that checking "Enable Bi-Directional text rendering" in the
kopete settings is a workaround?
I just tried it and it works for me.

--
Andrea
 
Old 12-20-2011, 08:01 AM
Andrea Scarpino
 
Default + qtwebkit package

On Tuesday 20 December 2011 01:19:12 Peter Lewis wrote:
> Hey Andrea,
>
> Nice work.
>
> But - HTML5 video and audio tags aren't working for me. I tried it in
> konqueror, rekonq and aurora. The first frame of the video loads, but it
won't
> play. This is with either gstreamer or vlc phonon backends.
>
> I tried youtube in HTML5 mode and also http://tinyvid.tv/. Same result.
>
> html5test.com reports that everything is fine for video except subtitles.
>
> I tried rebuilding a few related packages (phonon, phonon-gstreamer, etc.),
> but nothing seemed to change the behaviour.
>
> Any ideas?
Is kwebkitpart installed?
Also, try re-installing it if you had the previous one (the one built with qt
4.8rc1).

I can reproduce any video in the website you linked above. (ReKonq + phonon-
vlc here)

There's no need to rebuild phonon, I'm using 1.6.0 right now and that is built
upon [extra]. Indeed, you can try rebuilding kwebkitpart if html5 video still
don't work.

--
Andrea
 
Old 12-21-2011, 08:01 PM
Andrea Scarpino
 
Default + qtwebkit package

On Monday 19 December 2011 20:22:53 Ionut Biru wrote:
> How much time to you estimate it will stay in testing?
>
> I don't want to block again other rebuilds
Moved to [extra].

--
Andrea
 

Thread Tools




All times are GMT. The time now is 03:45 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org