FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 10-14-2011, 04:36 PM
Leonid Isaev
 
Default pacman 4.0.0-2

On (10/14/11 17:41), Karol Blazewicz wrote:
-~> On Fri, Oct 14, 2011 at 5:33 PM, Denis A. Altoé Falqueto
-~> <denisfalqueto@gmail.com> wrote:
-~> > On Fri, Oct 14, 2011 at 10:42 AM, Karol Blazewicz
-~> > <karol.blazewicz@gmail.com> wrote:
-~> >> On Fri, Oct 14, 2011 at 2:52 PM, Pierre Schmitz <pierre@archlinux.de> wrote:
-~> >>> I see my text was probably hard to read, but it was not about some
-~> >>> packages not being updated for pacman 4.0 yet but a possible bug (or
-~> >>> two) in pacman itself.
-~> >>>
-~> >>> --
-~> >>> Pierre Schmitz, https://users.archlinux.de/~pierre
-~> >>>
-~> >>
-~> >> Same thing happened when I installed yaourt:
-~> >>
-~> >> [2011-10-14 14:36] Running 'pacman -S yaourt'
-~> >> [2011-10-14 14:36] warning: /etc/pacman.conf installed as
-~> >> /etc/pacman.conf.pacnew
-~> >> [2011-10-14 14:36] warning: /etc/makepkg.conf installed as
-~> >> /etc/makepkg.conf.pacnew
-~> >> [2011-10-14 14:36] upgraded pacman (4.0.0-2 -> 3.5.4-4)
-~> >> [2011-10-14 14:36] installed package-query (0.9-1)
-~> >> [2011-10-14 14:36] installed yaourt (0.10.2-1)
-~> >>
-~> >> Now when I want to upgrade to pacman 4 it behaves as expected:
-~> >>
-~> >> resolving dependencies...
-~> >> looking for inter-conflicts...
-~> >> error: failed to prepare transaction (could not satisfy dependencies)
-~> >> :: package-query: requires pacman<3.6
-~> >>
-~> >
-~> > You'll have to wait until package-query is updated to pacman 4 or just
-~> > uninstall it. I had that problem too and decided to uninstall yaourt.
-~> >
-~> > --
-~> > A: Because it obfuscates the reading.
-~> > Q: Why is top posting so bad?
-~> >
-~> > -------------------------------------------
-~> > Denis A. Altoe Falqueto
-~> > Linux user #524555
-~> > -------------------------------------------
-~> >
-~>
-~> My question is why pacman decided to downgrade itself to satisfy
-~> package-query's dependency?
-~> I think it should fail due to unresolvable dependencies:
-~>
-~> warning: cannot resolve "pacman<3.6", a dependency of "package-query"
-~> :: The following package cannot be upgraded due to unresolvable dependencies:
-~> yaourt

This is what IgnorePkg is for, isn't it? After all, pacman is just another
package, and will be upgraded or downgraded as required by the %DEPENDS%
entries.

--
Leonid Isaev
GnuPG key ID: 164B5A6D
Key fingerprint: C0DF 20D0 C075 C3F1 E1BE 775A A7AE F6CB 164B 5A6D
 

Thread Tools




All times are GMT. The time now is 04:42 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org