This is a little "heads up" email to all the package maintainers out there.
Pacman 3.1 has support for versioned provisions. But what this also
means is that there's going to be some breakages in packages.
Let me explain by way of example:
package foo depends=(bar>=1.2)
package omg provides=(bar)
In the past, you could install both foo and omg at the same time and
everything would be satisfied. Not now. Now, the provision of "omg"
will fail, because it's not providing the right version.
What does this mean? Well, a few things. First and foremost, versioned
provisions are a little broken in 3.1.0, but 3.1.1 will fix all this
py allowing you to say:
Did I get this right? Dan, Xavier?