FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 04-07-2010, 04:23 PM
Dan McGee
 
Default broken due to openssl and heimdal rebuilds

On Wed, Apr 7, 2010 at 10:16 AM, Allan McRae <allan@archlinux.org> wrote:
> On 08/04/10 00:54, Florian Pritz wrote:
>>
>> On 07.04.2010 16:10, Allan McRae wrote:
>>>
>>> This would really not help here. *Pacman does not directly link openssl,
>>> but does through libarchive and libfetch. *Adding versioned libarchive
>>> and libfetch to pacman's deps and using sodeps on openssl in those
>>> packages would prevent pacman's SyncFirst from working.
>>>
>>
>> Don't add depends=(libfetch.sp libarchive.so) to the pacman PKGBUILD and
>> it won't be a problem. (Also see #2 below)
>
> Adding those or not is the same as adding versioned deps or not. *Both cause
> bad issues.
>
>>> no versioned deps in pacman for lib{archive,fetch} = bad as between the
>>> openssl and lib{archive,fetch} updates vercmp is broken and so is
>>> install files.
>>
>> sodeps would ensure that pacman updates libfetch and libarchive directly
>> after openssl.
>
> Not directly after, but in the same transaction. * That is the same as the
> current issue we have. *Using sodeps is no improvement over versioned deps
> here.

Allan and I talked a bit on IRC and we both came to some idea that a
vercmp without any deps would probably be a good solution. We can hack
this up for now, file attached to do so.

If this goes into the pacman package dir in SVN and we just add a "gcc
-O2 -o vercmp vercmp.c" in there and put it in the right place, we can
avoid a lot of hassle with everything here.

-Dan
 
Old 04-07-2010, 04:23 PM
Dan McGee
 
Default broken due to openssl and heimdal rebuilds

On Wed, Apr 7, 2010 at 10:16 AM, Allan McRae <allan@archlinux.org> wrote:
> On 08/04/10 00:54, Florian Pritz wrote:
>>
>> On 07.04.2010 16:10, Allan McRae wrote:
>>>
>>> This would really not help here. *Pacman does not directly link openssl,
>>> but does through libarchive and libfetch. *Adding versioned libarchive
>>> and libfetch to pacman's deps and using sodeps on openssl in those
>>> packages would prevent pacman's SyncFirst from working.
>>>
>>
>> Don't add depends=(libfetch.sp libarchive.so) to the pacman PKGBUILD and
>> it won't be a problem. (Also see #2 below)
>
> Adding those or not is the same as adding versioned deps or not. *Both cause
> bad issues.
>
>>> no versioned deps in pacman for lib{archive,fetch} = bad as between the
>>> openssl and lib{archive,fetch} updates vercmp is broken and so is
>>> install files.
>>
>> sodeps would ensure that pacman updates libfetch and libarchive directly
>> after openssl.
>
> Not directly after, but in the same transaction. * That is the same as the
> current issue we have. *Using sodeps is no improvement over versioned deps
> here.

Allan and I talked a bit on IRC and we both came to some idea that a
vercmp without any deps would probably be a good solution. We can hack
this up for now, file attached to do so.

If this goes into the pacman package dir in SVN and we just add a "gcc
-O2 -o vercmp vercmp.c" in there and put it in the right place, we can
avoid a lot of hassle with everything here.

-Dan
 

Thread Tools




All times are GMT. The time now is 01:16 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org