Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   ArchLinux Development (http://www.linux-archive.org/archlinux-development/)
-   -   [arch-dev-public] Packages with files in /opt (http://www.linux-archive.org/archlinux-development/3081-arch-dev-public-packages-files-opt.html)

"Jeff Mickey" 11-22-2007 04:21 PM

[arch-dev-public] Packages with files in /opt
 
After reading Aaron's status report, I figured this would be an easy
thing to take care of.

Here is the script I used to find these packages:
#!/bin/zsh

dirs=('/home/ftp/core/os/i686' '/home/ftp/extra/os/i686')

for dir in $dirs; do
for pkg in `ls $dir`; do
tar -tzf $dir/$pkg | egrep '^opt' > /dev/null
if [[ $? < 1 ]]; then
print $pkg
fi
done
done

I figured I'd post the list of packages that have /opt files. I'm
gonna do some of these packages while I'm here on break, but if you
see a package _you_ would rather take care of, just reply to the
thread. I also think that filesystem should be the very last package
that we do.. if we ever do it. It's probably best to keep it there so
that way packages don't add and remove the /opt folder, it is always
owned by the filesystem package.

If you think I missed a package or one of these is wrong, just reply
and let me know. And here is the list of the offending packages:
filesystem-2007.11-2-i686.pkg.tar.gz
acroread-8.1.1-1-i686.pkg.tar.gz
amarok-base-1.4.7-1.pkg.tar.gz
amarok-engine-xine-1.4.7-1.pkg.tar.gz
apollon-1.0.2.1-3.pkg.tar.gz
arts-1.5.8-1-i686.pkg.tar.gz
basket-1.0.2-1.pkg.tar.gz
boo-0.7.6.2237-1.pkg.tar.gz
chkrootkit-0.47-1.pkg.tar.gz
digikam-0.9.3beta2-1-i686.pkg.tar.gz
djvulibre-3.5.19-1.pkg.tar.gz
drscheme-371-1.pkg.tar.gz
eclipse-3.2.2-1.pkg.tar.gz
eclipse-cdt-3.1.2-1.pkg.tar.gz
filelight-1.0-2-i686.pkg.tar.gz
firefox-2.0.0.9-1-i686.pkg.tar.gz
firefox-i18n-2.0.0.9-1-i686.pkg.tar.gz
flashplugin-9.0.48.0-1.pkg.tar.gz
freenx-0.7.1-3-i686.pkg.tar.gz
gconf-2.20.1-1-i686.pkg.tar.gz
gnash-gtk-0.8.1-1.pkg.tar.gz
gnash-kde-0.8.1-2-i686.pkg.tar.gz
gtk-qt-engine-0.8-1.pkg.tar.gz
gwenview-1.4.2-1-i686.pkg.tar.gz
gwenview-i18n-1.4.2-1-i686.pkg.tar.gz
gxine-0.5.11-1.pkg.tar.gz
java-gcj-compat-1.0.76-5-i686.pkg.tar.gz
jdk-6u3-1-i686.pkg.tar.gz
jetty-6.1.1-1.pkg.tar.gz
jre-6u3-1-i686.pkg.tar.gz
k3b-1.0.4-1-i686.pkg.tar.gz
k3b-i18n-1.0.4-1-i686.pkg.tar.gz
kaffeine-0.8.5-1.pkg.tar.gz
kde-common-3.5.8-1-i686.pkg.tar.gz
kde-i18n-af-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ar-3.5.8-1-i686.pkg.tar.gz
kde-i18n-az-3.5.8-1-i686.pkg.tar.gz
kde-i18n-bg-3.5.8-1-i686.pkg.tar.gz
kde-i18n-bn-3.5.8-1-i686.pkg.tar.gz
kde-i18n-br-3.5.8-1-i686.pkg.tar.gz
kde-i18n-bs-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ca-3.5.8-1-i686.pkg.tar.gz
kde-i18n-cs-3.5.8-1-i686.pkg.tar.gz
kde-i18n-cy-3.5.8-1-i686.pkg.tar.gz
kde-i18n-da-3.5.8-1-i686.pkg.tar.gz
kde-i18n-de-3.5.8-1-i686.pkg.tar.gz
kde-i18n-el-3.5.8-1-i686.pkg.tar.gz
kde-i18n-en_gb-3.5.8-1-i686.pkg.tar.gz
kde-i18n-eo-3.5.8-1-i686.pkg.tar.gz
kde-i18n-es-3.5.8-1-i686.pkg.tar.gz
kde-i18n-et-3.5.8-1-i686.pkg.tar.gz
kde-i18n-eu-3.5.8-1-i686.pkg.tar.gz
kde-i18n-fa-3.5.8-1-i686.pkg.tar.gz
kde-i18n-fi-3.5.8-1-i686.pkg.tar.gz
kde-i18n-fr-3.5.8-1-i686.pkg.tar.gz
kde-i18n-fy-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ga-3.5.8-1-i686.pkg.tar.gz
kde-i18n-gl-3.5.8-1-i686.pkg.tar.gz
kde-i18n-he-3.5.8-1-i686.pkg.tar.gz
kde-i18n-hi-3.5.8-1-i686.pkg.tar.gz
kde-i18n-hr-3.5.8-1-i686.pkg.tar.gz
kde-i18n-hu-3.5.8-1-i686.pkg.tar.gz
kde-i18n-is-3.5.8-1-i686.pkg.tar.gz
kde-i18n-it-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ja-3.5.8-1-i686.pkg.tar.gz
kde-i18n-kk-3.5.8-1-i686.pkg.tar.gz
kde-i18n-km-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ko-3.5.8-1-i686.pkg.tar.gz
kde-i18n-lt-3.5.8-1-i686.pkg.tar.gz
kde-i18n-lv-3.5.8-1-i686.pkg.tar.gz
kde-i18n-mk-3.5.8-1-i686.pkg.tar.gz
kde-i18n-mn-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ms-3.5.8-1-i686.pkg.tar.gz
kde-i18n-nb-3.5.8-1-i686.pkg.tar.gz
kde-i18n-nds-3.5.8-1-i686.pkg.tar.gz
kde-i18n-nl-3.5.8-1-i686.pkg.tar.gz
kde-i18n-nn-3.5.8-1-i686.pkg.tar.gz
kde-i18n-pa-3.5.8-1-i686.pkg.tar.gz
kde-i18n-pl-3.5.8-1-i686.pkg.tar.gz
kde-i18n-pt-3.5.8-1-i686.pkg.tar.gz
kde-i18n-pt_br-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ro-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ru-3.5.8-1-i686.pkg.tar.gz
kde-i18n-rw-3.5.8-1-i686.pkg.tar.gz
kde-i18n-se-3.5.8-1-i686.pkg.tar.gz
kde-i18n-sk-3.5.8-1-i686.pkg.tar.gz
kde-i18n-sl-3.5.8-1-i686.pkg.tar.gz
kde-i18n-sr-3.5.8-1-i686.pkg.tar.gz
kde-i18n-ss-3.5.8-1-i686.pkg.tar.gz
kde-i18n-sv-3.5.8-2-i686.pkg.tar.gz
kde-i18n-ta-3.5.8-1-i686.pkg.tar.gz
kde-i18n-te-3.5.8-1-i686.pkg.tar.gz
kde-i18n-tg-3.5.8-1-i686.pkg.tar.gz
kde-i18n-th-3.5.8-1-i686.pkg.tar.gz
kde-i18n-tr-3.5.8-1-i686.pkg.tar.gz
kde-i18n-uk-3.5.8-1-i686.pkg.tar.gz
kde-i18n-uz-3.5.8-1-i686.pkg.tar.gz
kde-i18n-vi-3.5.8-1-i686.pkg.tar.gz
kde-i18n-wa-3.5.8-1-i686.pkg.tar.gz
kde-i18n-zh_cn-3.5.8-1-i686.pkg.tar.gz
kde-i18n-zh_tw-3.5.8-1-i686.pkg.tar.gz
kdeaccessibility-3.5.8-1-i686.pkg.tar.gz
kdeaddons-3.5.8-1-i686.pkg.tar.gz
kdeadmin-3.5.8-1-i686.pkg.tar.gz
kdeartwork-3.5.8-1-i686.pkg.tar.gz
kdebase-3.5.8-1-i686.pkg.tar.gz
kdebindings-3.5.8-1-i686.pkg.tar.gz
kdebluetooth-1.0_beta8-1-i686.pkg.tar.gz
kdeedu-3.5.8-1-i686.pkg.tar.gz
kdegames-3.5.8-1-i686.pkg.tar.gz
kdegraphics-3.5.8-1-i686.pkg.tar.gz
kdelibs-3.5.8-3-i686.pkg.tar.gz
kdemultimedia-3.5.8-1-i686.pkg.tar.gz
kdenetwork-3.5.8-1-i686.pkg.tar.gz
kdepim-3.5.8-1-i686.pkg.tar.gz
kdesdk-3.5.8-1-i686.pkg.tar.gz
kdetoys-3.5.8-1-i686.pkg.tar.gz
kdetv-0.8.9-1.pkg.tar.gz
kdeutils-3.5.8-1-i686.pkg.tar.gz
kdevelop-3.5.0-2-i686.pkg.tar.gz
kdewebdev-3.5.8-1-i686.pkg.tar.gz
kdmtheme-1.2.1-1-i686.pkg.tar.gz
kile-1.9.3-1.pkg.tar.gz
kiosktool-1.0-2.pkg.tar.gz
kipi-plugins-0.1.5beta1-1-i686.pkg.tar.gz
kkbswitch-1.4.3-2.pkg.tar.gz
klogic-1.63-1.pkg.tar.gz
kmobiletools-0.4.3.3-1.pkg.tar.gz
kmplayer-0.10.0.a-1-i686.pkg.tar.gz
kmyfirewall-1.0.1-2.pkg.tar.gz
knetload-2.3-3.pkg.tar.gz
koffice-1.6.3-2.pkg.tar.gz
koffice-doc-1.6.3-2.pkg.tar.gz
koffice-l10n-bg-1.6.3-2.pkg.tar.gz
koffice-l10n-ca-1.6.3-2.pkg.tar.gz
koffice-l10n-cs-1.6.3-2.pkg.tar.gz
koffice-l10n-cy-1.6.3-2.pkg.tar.gz
koffice-l10n-da-1.6.3-2.pkg.tar.gz
koffice-l10n-de-1.6.3-2.pkg.tar.gz
koffice-l10n-el-1.6.3-2.pkg.tar.gz
koffice-l10n-en_gb-1.6.3-2.pkg.tar.gz
koffice-l10n-es-1.6.3-2.pkg.tar.gz
koffice-l10n-et-1.6.3-2.pkg.tar.gz
koffice-l10n-eu-1.6.3-2.pkg.tar.gz
koffice-l10n-fa-1.6.3-2.pkg.tar.gz
koffice-l10n-fi-1.6.3-2.pkg.tar.gz
koffice-l10n-fr-1.6.3-2.pkg.tar.gz
koffice-l10n-ga-1.6.3-2.pkg.tar.gz
koffice-l10n-gl-1.6.3-2.pkg.tar.gz
koffice-l10n-hu-1.6.3-2.pkg.tar.gz
koffice-l10n-it-1.6.3-2.pkg.tar.gz
koffice-l10n-ja-1.6.3-2.pkg.tar.gz
koffice-l10n-lv-1.6.3-2.pkg.tar.gz
koffice-l10n-ms-1.6.3-2.pkg.tar.gz
koffice-l10n-nb-1.6.3-2.pkg.tar.gz
koffice-l10n-nds-1.6.3-2.pkg.tar.gz
koffice-l10n-ne-1.6.3-2.pkg.tar.gz
koffice-l10n-nl-1.6.3-2.pkg.tar.gz
koffice-l10n-pl-1.6.3-2.pkg.tar.gz
koffice-l10n-pt-1.6.3-2.pkg.tar.gz
koffice-l10n-pt_br-1.6.3-2.pkg.tar.gz
koffice-l10n-ru-1.6.3-2.pkg.tar.gz
koffice-l10n-sk-1.6.3-2.pkg.tar.gz
koffice-l10n-sl-1.6.3-2.pkg.tar.gz
koffice-l10n-sr-1.6.3-2.pkg.tar.gz
koffice-l10n-sv-1.6.3-2.pkg.tar.gz
koffice-l10n-tr-1.6.3-2.pkg.tar.gz
koffice-l10n-uk-1.6.3-2.pkg.tar.gz
koffice-l10n-zh_cn-1.6.3-2.pkg.tar.gz
koffice-l10n-zh_tw-1.6.3-2.pkg.tar.gz
konversation-1.0.1-1.pkg.tar.gz
kradio-0.3.0-4.pkg.tar.gz
krusader-1.80.0-1.pkg.tar.gz
ksensors-0.7.3-2.pkg.tar.gz
kshutdown-1.0.1-1.pkg.tar.gz
ktorrent-2.2.3-1-i686.pkg.tar.gz
labplot-1.5.1.5-1.pkg.tar.gz
libkdcraw-0.1.2-1-i686.pkg.tar.gz
libkexif-0.2.5-1.pkg.tar.gz
libkexiv2-0.1.6-1-i686.pkg.tar.gz
libkipi-0.1.5-1.pkg.tar.gz
metatheme-0.0.6-2.pkg.tar.gz
mozilla-common-1.1-1.pkg.tar.gz
mozillaqs-0.6-3.pkg.tar.gz
mplayer-plugin-3.45-1.pkg.tar.gz
nx-common-3.0.0-3-i686.pkg.tar.gz
nxclient-3.0.0.84-2-i686.pkg.tar.gz
nxserver-3.0.0-1-i686.pkg.tar.gz
oooqs2-1.0-1.pkg.tar.gz
openoffice-base-2.3.0-4-i686.pkg.tar.gz
openoffice-de-2.3.0-1-i686.pkg.tar.gz
openoffice-es-2.3.0-1-i686.pkg.tar.gz
openoffice-fr-2.3.0-1-i686.pkg.tar.gz
openoffice-it-2.3.0-1-i686.pkg.tar.gz
openoffice-ja-2.3.0-1-i686.pkg.tar.gz
openoffice-ko-2.3.0-1-i686.pkg.tar.gz
openoffice-nl-2.3.0-1-i686.pkg.tar.gz
openoffice-pt_br-2.3.0-1-i686.pkg.tar.gz
openoffice-spell-de-20051111-3.pkg.tar.gz
openoffice-spell-en-20060411-3.pkg.tar.gz
openoffice-spell-es-20061104-1.pkg.tar.gz
openoffice-spell-fr-20050609-3.pkg.tar.gz
openoffice-spell-nl-20050720-4-i686.pkg.tar.gz
openoffice-spell-pt-20040425-4-i686.pkg.tar.gz
openoffice-spell-ru-20040425-3.pkg.tar.gz
openoffice-spell-sv-20040425-3.pkg.tar.gz
openoffice-sv-2.3.0-1-i686.pkg.tar.gz
openoffice-zh_cn-2.3.0-1-i686.pkg.tar.gz
openoffice-zh_tw-2.3.0-1-i686.pkg.tar.gz
potracegui-1.3.4-1.pkg.tar.gz
qca-tls-1.0-3.pkg.tar.gz
qscintilla-1.7.1-1.pkg.tar.gz
qt-3.3.8-5.pkg.tar.gz
qt-doc-3.3.8-1.pkg.tar.gz
qtella-0.6.5-1.pkg.tar.gz
qtiplot-0.8.9-1.pkg.tar.gz
qwt-5.0.1-1.pkg.tar.gz
qwtplot3d-0.2.6-3.pkg.tar.gz
rosegarden-4.1.5.1-1.pkg.tar.gz
schafkopf-0.7-1.pkg.tar.gz
scim-tables-0.5.7-2.pkg.tar.gz
seamonkey-1.1.5-2-i686.pkg.tar.gz
sim-0.9.4.3-1.pkg.tar.gz
skim-1.4.5-2.pkg.tar.gz
smb4k-0.8.6-1-i686.pkg.tar.gz
smtpprox-1.2-4.pkg.tar.gz
spassgen-1.5-4.pkg.tar.gz
speedcrunch-0.5.4-2.pkg.tar.gz
swfdec-mozilla-0.5.4-1-i686.pkg.tar.gz
thunderbird-2.0.0.9-1-i686.pkg.tar.gz
thunderbird-i18n-2.0.0.9-1-i686.pkg.tar.gz
tmda-1.1.11-1.pkg.tar.gz
tomcat-5.5.23-1.pkg.tar.gz
totem-plugin-2.20.1-1-i686.pkg.tar.gz
usermin-1.310-1-i686.pkg.tar.gz
webmin-1.380-1-i686.pkg.tar.gz
xfcalendar-4.2.3-1.pkg.tar.gz
xfce4-cpu-freq-plugin-0.0.1-2.pkg.tar.gz
xfce4-minicmd-plugin-0.3.0-2.pkg.tar.gz
xfce4-taskbar-plugin-0.2.2-2.pkg.tar.gz
xfce4-toys-4.2.3-1.pkg.tar.gz
xfce4-trigger-launcher-4.2.3-1.pkg.tar.gz
xfce4-windowlist-plugin-0.1.0-3.pkg.tar.gz
xffm-4.2.3-1.pkg.tar.gz
xulrunner-1.8.1.9-1-i686.pkg.tar.gz
yakuake-2.8-1-i686.pkg.tar.gz
zope-3.3.1-1.pkg.tar.gz
zope2-2.10.4-1.pkg.tar.gz

Happy Thanksgiving to you and yours! Have a great time with your
family and friends, and enjoy some great food.

// jeff
--
. : [ + carpe diem totus tuus + ] : .

_______________________________________________
arch-dev-public mailing list
arch-dev-public@archlinux.org
http://archlinux.org/mailman/listinfo/arch-dev-public

Eric Belanger 11-22-2007 05:48 PM

[arch-dev-public] Packages with files in /opt
 
On Thu, 22 Nov 2007, Jeff Mickey wrote:

> After reading Aaron's status report, I figured this would be an easy
> thing to take care of.
>
> Here is the script I used to find these packages:
> #!/bin/zsh
>
> dirs=('/home/ftp/core/os/i686' '/home/ftp/extra/os/i686')
>
> for dir in $dirs; do
> for pkg in `ls $dir`; do
> tar -tzf $dir/$pkg | egrep '^opt' > /dev/null
> if [[ $? < 1 ]]; then
> print $pkg
> fi
> done
> done
>
> I figured I'd post the list of packages that have /opt files. I'm
> gonna do some of these packages while I'm here on break, but if you
> see a package _you_ would rather take care of, just reply to the
> thread. I also think that filesystem should be the very last package
> that we do.. if we ever do it. It's probably best to keep it there so
> that way packages don't add and remove the /opt folder, it is always
> owned by the filesystem package.
>
> If you think I missed a package or one of these is wrong, just reply
> and let me know. And here is the list of the offending packages:
> acroread-8.1.1-1-i686.pkg.tar.gz

acroread is my package. I'll do the change myself.

> chkrootkit-0.47-1.pkg.tar.gz

I am not a security expert but isn't the reason that chkrootkit is not
being installed in a directory in the PATH a security reason so that
malware can't find the executables to modify/delete them? Maybe keeping
it out of /usr would accomplish this better.

BTW, my understanding was that we were waiting for kde4 before moving KDE
packages to /usr.

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


_______________________________________________
arch-dev-public mailing list
arch-dev-public@archlinux.org
http://archlinux.org/mailman/listinfo/arch-dev-public

Eric Belanger 11-22-2007 05:56 PM

[arch-dev-public] Packages with files in /opt
 
On Thu, 22 Nov 2007, Andreas Radke wrote:

> Am Thu, 22 Nov 2007 12:21:08 -0500
> schrieb "Jeff Mickey" <jeff@archlinux.org>:
>
>> If you think I missed a package or one of these is wrong, just reply
>> and let me know. And here is the list of the offending packages:
>
> hey, you should run pacman -Qm and cleanup you installation before ;)
>
> all these Xfce packages are damn old and have been removed/replaced for
> long.
>
> Andy
>

I haven't checked all of them, but these xfce4 packages seems to be no
longer in the repo. They're probably old packages that needs to be
removed from the ftp directory.

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


_______________________________________________
arch-dev-public mailing list
arch-dev-public@archlinux.org
http://archlinux.org/mailman/listinfo/arch-dev-public

Andreas Radke 11-22-2007 05:58 PM

[arch-dev-public] Packages with files in /opt
 
Am Thu, 22 Nov 2007 12:21:08 -0500
schrieb "Jeff Mickey" <jeff@archlinux.org>:

> If you think I missed a package or one of these is wrong, just reply
> and let me know. And here is the list of the offending packages:

hey, you should run pacman -Qm and cleanup you installation before ;)

all these Xfce packages are damn old and have been removed/replaced for
long.

Andy

_______________________________________________
arch-dev-public mailing list
arch-dev-public@archlinux.org
http://archlinux.org/mailman/listinfo/arch-dev-public


All times are GMT. The time now is 06:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.