FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 03-18-2009, 04:46 PM
Daniel Isenmann
 
Default New digikam and kipi-plugins (KDE4)

Hi,

now that the digikam developer team released the first stable KDE4
version I would like to move those version to [extra]. This will
replace the old digikam 0.9.5 (KDE3) and makes libkipi obsolete. A new
package called lensfun will be moved to [extra], too. This is necessary
and needed by the new digikam.

Everything is running here fine with the new version and I don't see
any errors or issues.

I'm not the maintainer of digikam, it's Tobias, but I use digikam in a
daily basis with my photos. Because of that I have built the 0.10.0
release for testing today.

What do you think, can we move it and replace the old KDE3 version with
the new KDE4 version?

Daniel
 
Old 03-18-2009, 05:42 PM
Tobias Powalowski
 
Default New digikam and kipi-plugins (KDE4)

Am Mittwoch 18 März 2009 schrieb Daniel Isenmann:
> Hi,
>
> now that the digikam developer team released the first stable KDE4
> version I would like to move those version to [extra]. This will
> replace the old digikam 0.9.5 (KDE3) and makes libkipi obsolete. A new
> package called lensfun will be moved to [extra], too. This is necessary
> and needed by the new digikam.
>
> Everything is running here fine with the new version and I don't see
> any errors or issues.
>
> I'm not the maintainer of digikam, it's Tobias, but I use digikam in a
> daily basis with my photos. Because of that I have built the 0.10.0
> release for testing today.
>
> What do you think, can we move it and replace the old KDE3 version with
> the new KDE4 version?
>
> Daniel
need to check first my digikam crashes immediatly if i do some scrolling or
picutre viewing.
greetings
tpowa

--
Tobias Powalowski
Archlinux Developer & Package Maintainer (tpowa)
http://www.archlinux.org
tpowa@archlinux.org
 
Old 03-18-2009, 05:49 PM
Daniel Isenmann
 
Default New digikam and kipi-plugins (KDE4)

On Wed, 18 Mar 2009 19:42:59 +0100
Tobias Powalowski <t.powa@gmx.de> wrote:

> Am Mittwoch 18 März 2009 schrieb Daniel Isenmann:
> > Hi,
> >
> > now that the digikam developer team released the first stable KDE4
> > version I would like to move those version to [extra]. This will
> > replace the old digikam 0.9.5 (KDE3) and makes libkipi obsolete. A
> > new package called lensfun will be moved to [extra], too. This is
> > necessary and needed by the new digikam.
> >
> > Everything is running here fine with the new version and I don't see
> > any errors or issues.
> >
> > I'm not the maintainer of digikam, it's Tobias, but I use digikam
> > in a daily basis with my photos. Because of that I have built the
> > 0.10.0 release for testing today.
> >
> > What do you think, can we move it and replace the old KDE3 version
> > with the new KDE4 version?
> >
> > Daniel
> need to check first my digikam crashes immediatly if i do some
> scrolling or picutre viewing.
> greetings
> tpowa
>

Maybe you must delete your ~/.kde4/share/config/digikamrc file. I have
done it from beta to rc1. Maybe this solves the problem. Updating from
rc1 to rc2 to final was withouth problems. Everything is fine...

--
Daniel Isenmann
Vogesenstr.6
76676 Graben-Neudorf

Tel.: 07255 7683338
Mobil: 0163 1439140
E-Mail: daniel.isenmann@gmx.de
 
Old 03-18-2009, 05:56 PM
Tobias Powalowski
 
Default New digikam and kipi-plugins (KDE4)

Am Mittwoch 18 März 2009 schrieb Daniel Isenmann:
> On Wed, 18 Mar 2009 19:42:59 +0100
>
> Tobias Powalowski <t.powa@gmx.de> wrote:
> > Am Mittwoch 18 März 2009 schrieb Daniel Isenmann:
> > > Hi,
> > >
> > > now that the digikam developer team released the first stable KDE4
> > > version I would like to move those version to [extra]. This will
> > > replace the old digikam 0.9.5 (KDE3) and makes libkipi obsolete. A
> > > new package called lensfun will be moved to [extra], too. This is
> > > necessary and needed by the new digikam.
> > >
> > > Everything is running here fine with the new version and I don't see
> > > any errors or issues.
> > >
> > > I'm not the maintainer of digikam, it's Tobias, but I use digikam
> > > in a daily basis with my photos. Because of that I have built the
> > > 0.10.0 release for testing today.
> > >
> > > What do you think, can we move it and replace the old KDE3 version
> > > with the new KDE4 version?
> > >
> > > Daniel
> >
> > need to check first my digikam crashes immediatly if i do some
> > scrolling or picutre viewing.
> > greetings
> > tpowa
>
> Maybe you must delete your ~/.kde4/share/config/digikamrc file. I have
> done it from beta to rc1. Maybe this solves the problem. Updating from
> rc1 to rc2 to final was withouth problems. Everything is fine...
Ok seems last update did the trick it is not crashing anymore
We should also check the old depends of digikam if any other program still
needs them, if not kdegraphics should replace them.

greetings
tpowa
--
Tobias Powalowski
Archlinux Developer & Package Maintainer (tpowa)
http://www.archlinux.org
tpowa@archlinux.org
 
Old 03-18-2009, 09:22 PM
Daniel Isenmann
 
Default New digikam and kipi-plugins (KDE4)

On Wed, 18 Mar 2009 19:56:00 +0100
Tobias Powalowski <t.powa@gmx.de> wrote:

> Am Mittwoch 18 März 2009 schrieb Daniel Isenmann:
> > On Wed, 18 Mar 2009 19:42:59 +0100
> >
> > Tobias Powalowski <t.powa@gmx.de> wrote:
> > > Am Mittwoch 18 März 2009 schrieb Daniel Isenmann:
> > > > Hi,
> > > >
> > > > now that the digikam developer team released the first stable
> > > > KDE4 version I would like to move those version to [extra].
> > > > This will replace the old digikam 0.9.5 (KDE3) and makes
> > > > libkipi obsolete. A new package called lensfun will be moved to
> > > > [extra], too. This is necessary and needed by the new digikam.
> > > >
> > > > Everything is running here fine with the new version and I
> > > > don't see any errors or issues.
> > > >
> > > > I'm not the maintainer of digikam, it's Tobias, but I use
> > > > digikam in a daily basis with my photos. Because of that I have
> > > > built the 0.10.0 release for testing today.
> > > >
> > > > What do you think, can we move it and replace the old KDE3
> > > > version with the new KDE4 version?
> > > >
> > > > Daniel
> > >
> > > need to check first my digikam crashes immediatly if i do some
> > > scrolling or picutre viewing.
> > > greetings
> > > tpowa
> >
> > Maybe you must delete your ~/.kde4/share/config/digikamrc file. I
> > have done it from beta to rc1. Maybe this solves the problem.
> > Updating from rc1 to rc2 to final was withouth problems. Everything
> > is fine...
> Ok seems last update did the trick it is not crashing anymore
> We should also check the old depends of digikam if any other program
> still needs them, if not kdegraphics should replace them.
>
> greetings
> tpowa

Packages were moved to [extra]. All necessary dependencies were moved,
too. There are two packages in [extra] which can be deleted now, but
they should be replaced by kdegraphics. I will talk to Pierre about
this tomorrow.

Cheers,
Daniel
 
Old 03-18-2009, 09:36 PM
Pierre Schmitz
 
Default New digikam and kipi-plugins (KDE4)

Am Mittwoch, 18. März 2009 23:22:35 schrieb Daniel Isenmann:
> Packages were moved to [extra]. All necessary dependencies were moved,
> too. There are two packages in [extra] which can be deleted now, but
> they should be replaced by kdegraphics. I will talk to Pierre about
> this tomorrow.

Just tell me which packages you mean or simply update kdegraphics in trunk.
KDE 4.2.2 should be tagged end of next week.

--

Pierre Schmitz


Clemens-August-Straße 76
53115 Bonn

Telefon 0228 9716608
Mobil 0160 95269831
Jabber pierre@jabber.archlinux.de
WWW http://www.archlinux.de
 
Old 03-18-2009, 09:46 PM
Daniel Isenmann
 
Default New digikam and kipi-plugins (KDE4)

On Wed, 18 Mar 2009 23:36:14 +0100
Pierre Schmitz <pierre@archlinux.de> wrote:

> Am Mittwoch, 18. März 2009 23:22:35 schrieb Daniel Isenmann:
> > Packages were moved to [extra]. All necessary dependencies were
> > moved, too. There are two packages in [extra] which can be deleted
> > now, but they should be replaced by kdegraphics. I will talk to
> > Pierre about this tomorrow.
>
> Just tell me which packages you mean or simply update kdegraphics in
> trunk. KDE 4.2.2 should be tagged end of next week.
>

libkexiv2 and libkdcraw are both provided by kdegraphics. So they
can be replaced by kdegraphics. Just add those to replace and provides
array.

They were old KDE3 libs and no other application needs them anymore, so
they can be removed.
 
Old 03-18-2009, 10:41 PM
Pierre Schmitz
 
Default New digikam and kipi-plugins (KDE4)

Am Mittwoch, 18. März 2009 23:46:04 schrieb Daniel Isenmann:
> libkexiv2 and libkdcraw are both provided by kdegraphics. So they
> can be replaced by kdegraphics. Just add those to replace and provides
> array.
>
> They were old KDE3 libs and no other application needs them anymore, so
> they can be removed.

Done. I just added them to replaces; provides makes no sense since they are
not compatible anyway.

--

Pierre Schmitz


Clemens-August-Straße 76
53115 Bonn

Telefon 0228 9716608
Mobil 0160 95269831
Jabber pierre@jabber.archlinux.de
WWW http://www.archlinux.de
 

Thread Tools




All times are GMT. The time now is 05:39 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org