FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 09-02-2008, 03:37 PM
Xavier
 
Default Xorg-server 1.5RC6 enters testing

On Tue, Sep 2, 2008 at 5:01 PM, Xavier <shiningxc@gmail.com> wrote:
>
> And just for clarification, this looks like a very special bug which
> appears only under some special circumstances. That is why it is very
> difficult to reproduce. And that is why I had to ask everyone if they
> can check whether it is reproducible on their system.
>
> In other words, it will go fine for most people. We are only
> interested by the few cases where it does not go fine
>

Ok, I think you can forget about this problem, it is likely just an
user (developer?) mistake which was already made before :
http://archlinux.org/pipermail/pacman-dev/2008-March/011491.html

That is, don't use the -d flag which skips all the dependency
checking, otherwise you are asking for troubles.
 
Old 09-05-2008, 04:02 AM
"Dan McGee"
 
Default Xorg-server 1.5RC6 enters testing

On Sun, Aug 31, 2008 at 1:37 PM, Jan de Groot <jan@jgc.homeip.net> wrote:
> Xorg-server 1.5RC6 (1.4.99.906) enters tesing. This version of
> xorg-server includes input hotplugging using hal, better EXA support and
> less memory usage.
> Note that this version requires an upgrade of all videodrivers.
> All videodrivers shipped with X.Org have been rebuilt to reflect this
> change. Nvidia drivers don't seem to need a rebuild, while AMD's
> catalyst drivers don't support the new X.Org version. Fglrx users should
> not upgrade to this version.
>
> Please give this version of X.Org an extensive test run and report bugs.

I am having problems with nvidia, specifically the nvidia-96xx driver:

(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined
symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)

A recompile of the driver didn't seem to help anything. I'm booted up
with the nv driver now, which works OK, but not nearly as good (and
only 2D) as the closed-source driver unfortunately.

Any thoughts on this? I know so little about X/graphics drivers.

-Dan
 
Old 09-05-2008, 08:17 AM
Jan de Groot
 
Default Xorg-server 1.5RC6 enters testing

On Thu, 2008-09-04 at 23:02 -0500, Dan McGee wrote:
> I am having problems with nvidia, specifically the nvidia-96xx driver:
>
> (II) LoadModule: "nvidia"
> (II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
> dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined
> symbol: AllocateScreenPrivateIndex
> (EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
> (II) UnloadModule: "nvidia"
> (EE) Failed to load module "nvidia" (loader failed, 7)
>
> A recompile of the driver didn't seem to help anything. I'm booted up
> with the nv driver now, which works OK, but not nearly as good (and
> only 2D) as the closed-source driver unfortunately.
>
> Any thoughts on this? I know so little about X/graphics drivers.

Yes, nvidia doesn't support xorg-server 1.5 in their legacy drivers yet.
For now it means switching to the free drivers. The status is the same
for ATI users who are using catalyst now. To use xorg-server 1.5 they
will have to switch to xf86-video-ati or radeonhd.
 
Old 09-05-2008, 10:51 AM
Thomas Bächler
 
Default Xorg-server 1.5RC6 enters testing

Jan de Groot schrieb:

A recompile of the driver didn't seem to help anything.


There is nothing to compile here, the X driver is just a binary.


Yes, nvidia doesn't support xorg-server 1.5 in their legacy drivers yet.
For now it means switching to the free drivers.


In the past, nvidia has always provided compatible drivers for new
kernels and X server, even for the two legacy branches. So we can assume
that they will eventually support 1.5.



The status is the same
for ATI users who are using catalyst now. To use xorg-server 1.5 they
will have to switch to xf86-video-ati or radeonhd.


Unless you have a r400 card: Those are only supported by vesa and catalyst.
 
Old 09-06-2008, 05:27 AM
Amanai
 
Default Xorg-server 1.5RC6 enters testing

Why not update to the Final?
 
Old 09-07-2008, 02:19 AM
"Aaron Griffin"
 
Default Xorg-server 1.5RC6 enters testing

On 8/31/08, Jan de Groot <jan@jgc.homeip.net> wrote:
> Xorg-server 1.5RC6 (1.4.99.906) enters tesing. This version of
> xorg-server includes input hotplugging using hal, better EXA support and
> less memory usage.
> Note that this version requires an upgrade of all videodrivers.
> All videodrivers shipped with X.Org have been rebuilt to reflect this
> change. Nvidia drivers don't seem to need a rebuild, while AMD's
> catalyst drivers don't support the new X.Org version. Fglrx users should
> not upgrade to this version.
>
> Please give this version of X.Org an extensive test run and report bugs.

Just an FYI, I'm sure it's upstream, but I'm reporting it here for the
fun of it. Using the radeonhd driver on this laptop, when I close the
lid, the screen corrupts. Switching to a non-X vt and back fixes it,
so it's not a huge issue. I just laughed when I first saw it.
 

Thread Tools




All times are GMT. The time now is 09:48 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org