FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > ArchLinux > ArchLinux Development

 
 
LinkBack Thread Tools
 
Old 08-03-2008, 04:08 PM
Jan de Groot
 
Default gnutls update in testing

GNUTLS has been updated to 2.4.1 in testing (x86_64 only at this moment,
i686 is in progress).

All known dependencies and those reported by lddd on my system have been
rebuilt. I've added versioned dependencies to these packages to make
them easier to identify for rebuild actions on the next major upgrade.

Main changes:
- GNUTLS binaries are GPL3 now, library is still LGPL2.1+
- OpenCDK is no longer a dependency, the required parts are merged with
gnutls
- LZO2 compression is no longer supported. LZO is GPL2-only and is
incompatible with GPL3 that way. LZO compression isn't defined as a
standard either, it was an experimental gnutls extension

Please test these packages and report any additional required rebuilds
to the bugtracker.
 
Old 08-07-2008, 05:22 PM
"Aaron Griffin"
 
Default gnutls update in testing

On Sun, Aug 3, 2008 at 11:08 AM, Jan de Groot <jan@jgc.homeip.net> wrote:
> GNUTLS has been updated to 2.4.1 in testing (x86_64 only at this moment,
> i686 is in progress).
>
> All known dependencies and those reported by lddd on my system have been
> rebuilt. I've added versioned dependencies to these packages to make
> them easier to identify for rebuild actions on the next major upgrade.
>
> Main changes:
> - GNUTLS binaries are GPL3 now, library is still LGPL2.1+
> - OpenCDK is no longer a dependency, the required parts are merged with
> gnutls
> - LZO2 compression is no longer supported. LZO is GPL2-only and is
> incompatible with GPL3 that way. LZO compression isn't defined as a
> standard either, it was an experimental gnutls extension
>
> Please test these packages and report any additional required rebuilds
> to the bugtracker.

I haven't noticed any issues, but I haven't tested anything major.
weechat and vlc still seem to work for me, but I haven't tested
anything like cups and the like.

For reference, 'required by' is here:
https://dev.archlinux.org/packages/testing/i686/gnutls/
 
Old 08-07-2008, 05:39 PM
Jan de Groot
 
Default gnutls update in testing

On Thu, 2008-08-07 at 12:22 -0500, Aaron Griffin wrote:
> I haven't noticed any issues, but I haven't tested anything major.
> weechat and vlc still seem to work for me, but I haven't tested
> anything like cups and the like.
>
> For reference, 'required by' is here:
> https://dev.archlinux.org/packages/testing/i686/gnutls/

Haven't noticed problems either here. About the reference: I used that
list to do my initial rebuilds, and as you can see with the testing
packages that require gnutls now, I made sure they will show up for the
next big rebuild there also
 
Old 08-07-2008, 05:41 PM
"Aaron Griffin"
 
Default gnutls update in testing

On Thu, Aug 7, 2008 at 12:39 PM, Jan de Groot <jan@jgc.homeip.net> wrote:
> On Thu, 2008-08-07 at 12:22 -0500, Aaron Griffin wrote:
>> I haven't noticed any issues, but I haven't tested anything major.
>> weechat and vlc still seem to work for me, but I haven't tested
>> anything like cups and the like.
>>
>> For reference, 'required by' is here:
>> https://dev.archlinux.org/packages/testing/i686/gnutls/
>
> Haven't noticed problems either here. About the reference: I used that
> list to do my initial rebuilds, and as you can see with the testing
> packages that require gnutls now, I made sure they will show up for the
> next big rebuild there also

Yeah, I linked that so other people could test things. I don't use
bitlbee and the like...
 

Thread Tools




All times are GMT. The time now is 01:59 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org